JSI Tip 2268. Windows 2000 upgrade could not detect the version of Windows you are currently running?

If you start an upgrade from within Windows NT (or W9x), you may receive:

Windows 2000 Setup could not detect the version of Windows you are currently running. Setup cannot continue.

This trouble is generally cause because you cloned your current OS and the cloning software dropped your product ID (PID).

To correct the problem, use your registry editor to navigate to:

HKEY_LOCAL_MACHINE/Software/Microsoft/Windows NT/CurrentVersion/ProductID

Edit the ProductId string value and enter your PID.

NOTE: W9x users should replace Windows NT, in the above registry path, with Windows.

Hide comments

Comments

  • Allowed HTML tags: <em> <strong> <blockquote> <br> <p>

Plain text

  • No HTML tags allowed.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Lines and paragraphs break automatically.
Publish