<!DOCTYPE html>
<html
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#" class="html not-front not-logged-in no-sidebars page-node page-node- page-node-140935 node-type-article header-with-pillar article-article">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <meta charset="utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge, chrome=1" />
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_152x152.png" sizes="152x152" />
<link rel="shortcut icon" href="https://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_180x180.png" sizes="180x180" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_167x167.png" sizes="167x167" />
<meta name="title" content="npm Improves Workflow of Enterprise JavaScript Developer Platform" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_120x120.png" sizes="120x120" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_76x76.png" sizes="76x76" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch.png" />
<meta name="description" content="npm’s enterprise JavaScript platform gains new package filtering capabilities and enhances single sign-on, in an effort to improve developer workflow." />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.itprotoday.com/programming-languages/npm-updates-enterprise-javascript-developer-platform" />
<link rel="shortlink" href="https://www.itprotoday.com/node/140935" />
<meta property="og:site_name" content="IT Pro" />
<meta property="og:type" content="article" />
<meta property="og:title" content="npm Updates Enterprise JavaScript Developer Platform" />
<meta property="og:description" content="The latest version of npm Enterprise adds new package filtering capabilities and enhances single sign-on, in an effort to improve developer workflow." />
<meta property="og:updated_time" content="2019-07-23T20:45:36+00:00" />
<meta property="og:image" content="https://www.itprotoday.com/sites/itprotoday.com/files/JavaScript-code.jpg" />
<meta property="twitter:card" content="summary" />
<meta property="twitter:url" content="https://www.itprotoday.com/programming-languages/npm-updates-enterprise-javascript-developer-platform" />
<meta property="twitter:title" content="npm Updates Enterprise JavaScript Developer Platform" />
<meta property="article:published_time" content="2019-07-23T20:44:19+00:00" />
<meta property="article:modified_time" content="2019-07-23T20:45:36+00:00" />
<meta property="og:audio" content="http://" />
<meta property="og:audio:secure_url" content="https://" />
<meta property="og:video:url" content="http://" />
<meta property="og:video:secure_url" content="https://" />
<meta property="og:video:type" content="text/html" />
    <title>npm Improves Workflow of Enterprise JavaScript Developer Platform | IT Pro</title>
    <link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_PpiQEI-azlEmknynFVbTW6pWwXhVPT_fbABYbBL6JWQ.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_DHcXHPYBSjIVaCQZEG4ZlpLkvslnFlBCnQUCzlbRBio.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_4GJdl2xvrwyZP8r03oU7AnszTtBYGy_ecYVYwmYoww4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_pZxsco4eNR4BBsE0WxA8VRuq3YpiLLEug_6PnA6UUQc.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_aeyuIEVQiEqZZ-zjT06bM8DBx8jK7OLW3BOlZjqDYWg.css" media="all" />

<!--[if lte IE 9]>
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_d5304rVRgE97dcoJVANw-HS6Cz-71UhME-UbNuFSgx8.css" media="all" />
<![endif]-->
    <!-- HTML5 element support for IE6-8 -->
    <!--[if lt IE 9]>
    <script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
    <![endif]-->
    <script>
      var gdpr_cookie = "off";
      // Check if cookies enabled in browser.
      var cookieEnabled = navigator.cookieEnabled;
      if (typeof navigator.cookieEnabled === 'undefined' && !cookieEnabled) {
        document.cookie = 'testCookie';
        cookieEnabled = (document.cookie.indexOf('testCookie') !== -1);
      }
      if (cookieEnabled) {
        var is_cookie = document.cookie.indexOf('penton_gdpr_cookie');
        if (is_cookie == -1) {
          console.log('gdpr cookie not set');
          // Cookie is not yet set - banner just served
          gdpr_cookie = "on";
        }
      }
      console.log('gdprCookie==>' + gdpr_cookie);
    </script>
        <script>
      var isblocked = "notblocked";
      console.log('lpage==>' + isblocked);
      var pathname = window.location.pathname;
      var adu = "/3834/itprotoday.home/article/devops_and_software_development/programming_languages";
      var adblockOn = 1;
    </script>
    <script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
    <script>
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
    </script>
    <script>
      if (adu !== "" && (pathname.indexOf('/cart') < 0) && (pathname.indexOf('/store') < 0) && (pathname.indexOf('/products') < 0) && (pathname.indexOf('/product-types') < 0) && (pathname.indexOf('/store-topics') < 0) && ((pathname.indexOf('/gallery')) !== (pathname.length - 8)) && (pathname.indexOf('/user/login') < 0) && (isblocked == "notblocked") && (pathname.indexOf('penton_ur_thank_you') < 0)) {
        var targ_arr = JSON.parse('[{"target":"pos","value":"728_1_a"},{"target":"combo","value":"wrap"},{"target":"ptype","value":"Article"},{"target":"nid","value":"140935"},{"target":"pterm","value":"programming_languages"},{"target":"sterm","value":"devops_and_software_development"},{"target":"author","value":"sean_michael_kerner"},{"target":"reg","value":"anonymous"}]');
        googletag.cmd.push(function() {
          if (gdpr_cookie == "off") {
            googletag.pubads().setRequestNonPersonalizedAds(0);
          } else if (gdpr_cookie == "on") {
            googletag.pubads().setRequestNonPersonalizedAds(1);
          }
          var welcome_ad = googletag.defineSlot(adu, [1, 1], "div-interstitial");
          welcome_ad.addService(googletag.pubads());
          welcome_ad.setTargeting("pos", "interstitial_a");
          welcome_ad.setTargeting("gdpr_banner", gdpr_cookie);
          for (var i=0; i<targ_arr.length; i++) {
            var targ = targ_arr[i]['target'];
            var val = targ_arr[i]['value'].split(',');
            if (targ !== 'pos' && targ !== 'combo') {
              welcome_ad.setTargeting(targ, val);
            }
          }

          setTimeout(function() {
            console.log('adblockval');console.log(adblockOn);
            if(adblockOn == 1) {
              var bDiv = document.getElementById("body-wrapper");
              window.scrollTo(0, 0);
              if(bDiv.style.removeProperty) {
                bDiv.style.removeProperty('opacity');
              } else {
                bDiv.style.removeAttribute('opacity');
              }
            }
          }, 2000);

          googletag.pubads().addEventListener('slotRenderEnded', function(event) {
            adblockOn = 0;
            if(event.slot.getSlotElementId() == "div-interstitial") {
              if(event.isEmpty) {
                console.log('emptyInterstitial');
                var bDiv = document.getElementById("body-wrapper");
                window.scrollTo(0, 0);
                if(bDiv.style.removeProperty) {
                  bDiv.style.removeProperty('opacity');
                } else {
                  bDiv.style.removeAttribute('opacity');
                }
              } else {
                console.log('notemptyInterstitial');
              }

              var dfplogpatt = new RegExp('dfp_log');
              var isDebug = dfplogpatt.test(location.search);
              if(isDebug) {
                console.log('%c********DFPTag: Interstitial********', 'font-size:medium;font-style:bold');
                console.log('adunit: '+adu);
                if (gdpr_cookie == "off") {
                  console.log('nonpersonalized ads: 0');
                } else if (gdpr_cookie == "on") {
                  console.log('nonpersonalized ads: 1');
                }
                console.log('targetingpair==> pos:interstitial_a');
                console.log('targetingpair==> gdpr_banner:'+gdpr_cookie);
                for(var i=0; i<targ_arr.length; i++) {
                  var targ = targ_arr[i]['target'];
                  var val = targ_arr[i]['value'].split(',');
                  if(targ !== 'pos' && targ !== 'combo') {
                    console.log('targetingpair==> '+targ+':'+val);
                  }
                }
                console.log('adsize: [1, 1]');
                console.log('oop: false');
                console.log('%c************************************', 'font-size:medium;font-style:bold');
              }
            }
          });
          googletag.enableServices();
        });
      }
    </script>
      </head>
  <body>
        <div id="wl_flogop_div" class="hidden">https://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/footer.png</div>
    <div id="div-interstitial">
      <script>
        if(adu !== "" && (pathname.indexOf('/cart') < 0) && (pathname.indexOf('/store') < 0) && (pathname.indexOf('/products') < 0) && (pathname.indexOf('/product-types') < 0) && (pathname.indexOf('/store-topics') < 0) && ((pathname.indexOf('/gallery')) !== (pathname.length - 8)) && (pathname.indexOf('/user/login') < 0) && (isblocked == "notblocked") && (pathname.indexOf('penton_ur_thank_you') < 0)  ) {
          googletag.cmd.push(function() {
            googletag.display("div-interstitial");
          });
        }
      </script>
    </div>
        <div id="body-wrapper"  style="opacity:0;" >
            <header class="header js-header">
  <!-- Pillar Navigation region -->
<nav class="pillar-nav">
<div id="block-penton-informa-banner-penton-informa-banner" class="block block-penton-informa-banner">

    
  <div class="content">
    <div id="iribbon-container">
    <button id="iribbon-title" title="show/hide">Informa</button>
    <div id="iribbon-detail" class="ribbon-hide">
        <div id="iribbon-left">
            <p>IT Pro Today is part of the Informa Tech Division of Informa PLC</p>
            <ul>
                <li class="iribbon-mainlink"><a href="http://informa.com/">Informa PLC</a></li>
                <li><a href="http://informa.com/About-Us/">About us</a></li>
                <li><a href="http://informa.com/Investors/">Investor relations</a></li>
                <li><a href="http://informa.com/Talent/">Talent</a></li>
            </ul>
        </div>
        <div id="iribbon-right">
            <p>This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them. Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.</p>
        </div>
    </div>
</div>  </div>
</div>
<div id="block-menu-menu-pillar-navigation" class="pillar-nav__inner l-content clearfix">
  <div class="pillar-nav__header">Discover:</div>
  <ul class="pillar-nav__items js-menumore-discover"><li class="pillar-nav__item js-menumore-item-text  "><a href="https://www.itprotoday.com/rsa-conference">RSA Coverage</a></li>
<li class="pillar-nav__item js-menumore-item-text pillar-nav__item--event "><a href="https://tmt.knect365.com/iot-world/?utm_source=ITPMedia&amp;utm_medium=website&amp;utm_campaign=eyebrow-link">IoT World</a></li>
<li class="pillar-nav__item js-menumore-item-text  "><a href="https://afcom.com/Public/Leaders_Labs/Public/Leaders_Labs/About_Leaders_Labs/Leaders_Labs.aspx?hkey=842624e7-2596-4ceb-ba12-9f2ee91469a7">AFCOM Leaders Lab</a></li>
<li class="pillar-nav__item js-menumore-item-text pillar-nav__item--event "><a href="https://tmt.knect365.com/container-world/?utm_source=ITPMedia&amp;utm_medium=website&amp;utm_campaign=eyebrow-link">Container World</a></li>
<li class="pillar-nav__item js-menumore-item-text pillar-nav__item--event "><a href="https://afcom.com/Public/Leaders_Labs/Public/Leaders_Labs/About_Leaders_Labs/Leaders_Labs.aspx?hkey=842624e7-2596-4ceb-ba12-9f2ee91469a7">Leaders lab</a></li>

    <li class="pillar-nav__item pillar-more js-menumore-more-item">
      <a class="pillar-more-btn">More<i class="fa fa-caret-down"></i></a>
      <ul class="pillar-list-nested js-menumore-sub"></ul>
    </li>
  </ul></div>
</nav>
<!-- /Pillar Navigation region -->
  <!-- Header -->
  <div class="header-inner l-content">
    <!-- Hamburger menu -->
<div class="menu-toggler js-ham-menu-toggler">
  <div class="menu-toggler-img-wrap js-menu-toggler">
    <div class="menu-toggler-hamburger">
      <div class="hamburger-text">Menu</div>
      <div class="hamburger-line"></div>
      <div class="hamburger-line"></div>
      <div class="hamburger-line"></div>
    </div>
  </div>
  <aside class="hamburger-menu">
    <div class="hamburger-menu-inner clearfix js-toggle-menu js-sticky-ham-menu">
      <div class="hamburger-menu-container">
                  <div class="user-thumb-text">
            <a href="/penton_modal/nojs/login" class="ctools-use-modal sattelite-event-caller sattelite-event-caller__hamburger-clicked ctools-modal-modal-popup-login" rel="nofollow">Log In</a> or <a href="/penton_modal/nojs/register/basic" class="ctools-use-modal sattelite-event-caller sattelite-event-caller__hamburger-clicked ctools-modal-modal-popup-medium" rel="nofollow">Register</a>          </div>
                <ul class="hamburger-menu-nav"><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/next-gen" title="">Next Gen</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/collaboration" title="">Collaboration</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/cloud-computing-0" title="">Cloud Computing</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/compute-engines" title="">Compute Engines</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/data-analytics-and-data-management" title="">Data Analytics and Data Management</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/data-center" title="">Data Center</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/devops-and-software-development" title="">DevOps and Software Development</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/mobility" title="">Mobility</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/security" title="">Security</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/storage" title="">Storage</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/windows-and-user-productivity" title="">Windows and User Productivity</a></li></ul><ul class="hamburger-menu-sub-nav"><li class="hamburger-menu-sub-nav__item"><a href="/industry-perspectives" title="">Industry Perspectives</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://www.itprotoday.com/it-buyers-guides" title="">Buyer’s guides</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://www.itprotoday.com/it-top-10-reports" title="">Top 10 reports</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://www.itprotoday.com/special-reports-it-tech-shaping-tomorrow" title="">Special reports</a></li><li class="hamburger-menu-sub-nav__item"><a href="/webinar-0" title="">Webinars</a></li><li class="hamburger-menu-sub-nav__item"><a href="/whitepapers" title="">Whitepapers</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://www.itprotoday.com/business-resources/technology-providers-company-profiles" title="">Technology Provider</a></li><li class="hamburger-menu-sub-nav__item"><a href="/business-resources" title="">Business Resources</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://afcom.com/Public/Leaders_Labs/Public/Leaders_Labs/About_Leaders_Labs/Leaders_Labs.aspx?hkey=842624e7-2596-4ceb-ba12-9f2ee91469a7" title="">AFCOM Leaders Lab</a></li><li class="hamburger-menu-sub-nav__item"><a href="/newsletters/signup" title="">Newsletter Preference</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://www.itprotoday.com/advertise-itprotodaycom" title="">Advertise</a></li><li class="hamburger-menu-sub-nav__item"><a href="/about-us" title="">About Us</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://knect365.com/privacy-policy" title="">Privacy Policy</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://www.penton.com/terms-of-service/" title="">Terms of Service</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://corporate.knect365.com/privacy-centre/our-cookie-policy/" title="">Cookie Policy</a></li></ul><div class="social-icons"><a href="https://www.facebook.com/ITProToday/" title="" class="social-icons__link"><i class="social-icons__icon fa fa-facebook"></i></a><a href="https://twitter.com/ITProToday" title="" class="social-icons__link"><i class="social-icons__icon fa fa-twitter"></i></a><a href="https://www.linkedin.com/company/itpro-today/" title="" class="social-icons__link"><i class="social-icons__icon fa fa-linkedin"></i></a></div>              </div>
    </div>
  </aside>
</div>
<!-- /Hamburger menu -->
    <!-- Header Logo -->
    <div class="header-logo">
                      <a href="/" class="header-logo__link"><img src="https://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/header.png" alt="IT Pro" title="IT Pro" /></a>                  </div>
    <!-- /Header Logo -->
          <!-- Header User links -->
      <ul class="header-nav">
                  <li class="header-nav__item header-nav__item__search">
            <a href="/search" class="header-nav-link"><i class="fa fa-search"></i>Search</a>          </li>
                          <li class="header-nav__item no-mobile">
            <a href="/penton_modal/nojs/login" class="ctools-use-modal ctools-modal-modal-popup-login header-nav-link" rel="nofollow">Log In</a>          </li>
          <li class="header-nav__item no-mobile last">
            <a href="/penton_modal/nojs/register/basic" class="ctools-use-modal ctools-modal-modal-popup-medium header-nav-link sattelite-event-caller sattelite-event-caller__header-clicked" rel="nofollow">Register</a>          </li>
                <!-- Cart -->
                <!-- /Cart -->
      </ul>
      </div>

  <!-- legal communication alert -->
  <div class="js-penton-legal-comm-ajax-output-alert">
      </div>
  <!-- /legal communication alert -->
<!-- /Header -->
</header>
<!-- Page -->
<main>
  <div id="page-wraper">
    <!-- Header Adv -->
    <div class="banner-top-wrapper">
      <div id="banner-top" class="dfp-ad-hideempty hidden">
        <div data-dfp-position="top_banner"></div>
      </div>
    </div>
        <!-- Admin Tabs -->
          <section id="admin-tabs" class="l-content">
              </section>
        <!-- /Admin Tabs -->
    <!-- /Header Adv -->
    <div class="wrapper l-content">
                                <!-- Sidebar -->
        <aside id="sidebar" class="l-sidebar sidebar">
            <div class="region region-left-col">
          <div class="slide-out-sidebar-button js-expand-sidebar">
        <span class="slide-out-recent">Recent</span>
      </div>
        <div class="sidebar-wrapper sidebar-scrollable js-sticky-leftcol">
      <section id="penton_recent_content_block">
  <aside>
    <div class="r-a-header">Recent</div>
                
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/backup/role-backup-and-recovery-cyberthreat-prep-and-resilience">
            Role of Backup and Recovery in Cyberthreat Prep and Resilience            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jul 24, 2019</span>        </span>
          </div>
  </div>
</article>
                  <div data-dfp-position="native_leftrail_1" class="dfp-ad-hideempty hidden n_hidden n_leftrail1_2"></div>
            
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/programming-languages/npm-updates-enterprise-javascript-developer-platform">
            npm Updates Enterprise JavaScript Developer Platform            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jul 23, 2019</span>        </span>
          </div>
  </div>
</article>
            <div class="banner-aside-wrapper dfp-ad-hideempty">
      <div class="banner-aside js-sticky-banner dfp-ad-hideempty hidden">
        <div data-dfp-position="left_rail_rect"></div>
      </div>
    </div>
    <hr>
                    
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/linux/quick-change-ceos-suse-linux">
            Quick Change in CEOs at SUSE Linux            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jul 22, 2019</span>        </span>
          </div>
  </div>
</article>
                  <div data-dfp-position="native_leftrail_2" class="dfp-ad-hideempty hidden n_hidden n_leftrail1_2"></div>
            
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/iot/fleet-telematics-technology-trip-continues">
            Fleet Telematics: A Technology Trip Continues            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jul 22, 2019</span>        </span>
          </div>
  </div>
</article>
                
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/windows-and-user-productivity/microsoft-pays-25-million-end-us-probe-bribery-overseas">
            Microsoft Pays $25 Million to End U.S. Probe Into Bribery Overseas            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jul 22, 2019</span>        </span>
          </div>
  </div>
</article>
      </aside>
</section>


<section id="penton_featured_content_block">
  <aside>
    <div class="r-a-header">Featured</div>
          
<article class="article-teaser article-teaser__no-img article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/windows-78/windows-7-10-migration-tools-buyer-s-guide">
            Windows 7 to 10 Migration Tools Buyer’s Guide            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jun 17, 2019</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/devops-and-software-development/5-key-it-skills-new-decade">
            5 Key IT Skills for the New Decade            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jun 27, 2019</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/devops-and-software-development/future-iot-devices-question">
            The Future of IoT Devices Is in Question            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jul 22, 2019</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/energy/another-thing-you-lose-when-you-move-cloud">
            Another Thing You Lose When You Move to the Cloud            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jul 19, 2019</span>        </span>
          </div>
  </div>
</article>
      </aside>
</section>
    </div>
  </div>
        </aside>
        <!-- /Sidebar -->
            <!-- Main Content Area -->
      <div class="page main-area l-main-area">
        <div id="main_content" class="clearfix">
          
            <div class="region region-main-col">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <section class="main-articles-container js-lazy-pager-wrapper">

    <article itemscope itemtype="http://schema.org/NewsArticle" class=" big-article article-type-article article-140935 node-type-article with-feat-img article-standalone js-lazy-pager-content"  data-nid="140935" data-url="/programming-languages/npm-updates-enterprise-javascript-developer-platform" data-title="npm Updates Enterprise JavaScript Developer Platform" data-seo-title="npm Improves Workflow of Enterprise JavaScript Developer Platform" data-type="article" data-terms="devops_and_software_development/programming_languages" data-ptermhier="DevOps and Software Development &gt; Programming Languages" data-pterm="Programming Languages" data-sterm="DevOps and Software Development" data-program="" data-tax="Programming Languages|DevOps and Software Development" data-buyersjourney="" data-ext="" data-author="Sean Michael Kerner" data-pub="Jul 23, 2019" data-visibility="visible" data-perm="public" data-pid="7d022aea-9bef-4603-88b1-41fc1057db5a" data-content="">
    <meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.itprotoday.com/programming-languages/npm-updates-enterprise-javascript-developer-platform"/>
    <meta itemprop="datePublished" content="2019-07-23T20:37:00+00:00"/>    <meta itemprop="dateModified" content="2019-07-23T20:45:36+00:00"/>
              <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
          <meta itemprop="url" content="https://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/header.png">
          <meta itemprop="width" content="980">
          <meta itemprop="height" content="173">
        </div>
        <meta itemprop="name" content="IT Pro">
      </div>
    
    
    <div class="big-article__top">

      
              <div class="big-article__image" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
          <img class="medium js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_featured_retina/public/JavaScript-code.jpg?itok=OOWmNjSd" src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_featured_standard/public/JavaScript-code.jpg?itok=HrIKNMWo" width="770" height="400" alt="JavaScript code" title="JavaScript code" />          <meta itemprop="url" content="https://www.itprotoday.com/sites/itprotoday.com/files/JavaScript-code.jpg">
          <meta itemprop="width" content="1537">
          <meta itemprop="height" content="769">

                      <span class="text-to-image">Getty Images</span>
                  </div>
              
      <div class="big-article__head row">
        <div class="heading ">
                    <div class="breadcrumbs"><span class="parent-category"><a href="/devops-and-software-development">DevOps and Software Development</a><span>&gt;</span></span><a href="/devops-and-software-development/programming-languages">Programming Languages</a></div>          <h1 itemprop="headline">npm Updates Enterprise JavaScript Developer Platform</h1>
                      <div itemprop="description">
              
  <div class="field field-name-field-penton-content-summary field-type-text-long field-label-hidden">
    The latest version of npm Enterprise adds new package filtering capabilities and enhances single sign-on, in an effort to improve developer workflow.  </div>
            </div>
                                <p class="author-and-date" itemprop="author" itemscope="" itemtype="https://schema.org/Person"><span itemprop="name"><a href="/author/Sean-Kerner" itemprop="url">Sean Michael Kerner</a></span> | <span class="date-display-single">Jul 23, 2019</span></p>
                  </div>
      </div>

      
    </div>

              <div class="share-icons">
            <a href="/penton_modal/nojs/print/140935"
         class="print ctools-use-modal ctools-modal-modal-popup-basic"
         rel="nofollow">
        <i class="fa fa-print"></i>
      </a>
          <a href="/penton_modal/nojs/forward/140935/0"
         class="envelope ctools-use-modal ctools-modal-modal-popup-basic-email"
         rel="nofollow">
        <i class="fa fa-envelope"></i>
      </a>
                  <a href="https://www.facebook.com/sharer.php?u=https://www.itprotoday.com/programming-languages/npm-updates-enterprise-javascript-developer-platform&amp;t=npm Updates Enterprise JavaScript Developer Platform"
         class="facebook"
         target="_blank">
        <i class="fa fa-facebook"></i>
      </a>
                <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.itprotoday.com/programming-languages/npm-updates-enterprise-javascript-developer-platform&amp;title=npm Updates Enterprise JavaScript Developer Platform&amp;summary=npm Inc. is continuing to grow its enterprise JavaScript platform with new features that improve developer workflow and security.&amp;source=IT Pro"
         class="linkedin"
         target="_blank">
        <i class="fa fa-linkedin"></i>
      </a>
                <a href="https://twitter.com/share?url=https://www.itprotoday.com/programming-languages/npm-updates-enterprise-javascript-developer-platform&amp;text=npm Updates Enterprise JavaScript Developer Platform"
         class="twitter"
         target="_blank">
        <i class="fa fa-twitter"></i>
      </a>
                <a href="https://pinterest.com/pin/create/button/?url=https://www.itprotoday.com/programming-languages/npm-updates-enterprise-javascript-developer-platform&amp;description=npm Inc. is continuing to grow its enterprise JavaScript platform with new features that improve developer workflow and security.&amp;media="
         class="pinterest"
         target="_blank">
        <i class="fa fa-pinterest"></i>
      </a>
              <a class="pinterest"
           target="_blank">
           <i class="fa fa-pinterest"></i>
        </a>
            </div>

              
    
    <div class="article-content-wrap">
      
      <div itemprop="articleBody" class="article-content ">
                  <div class="article-banner dfp-ad-hideempty hidden">
            <div data-dfp-position="inarticle1"></div>
          </div>
                
        <p><span style="color:black">npm Inc. is continuing to grow its enterprise <a href="https://www.itprotoday.com/web-application-management/javascript-it-good-they-say" style="text-decoration:underline">JavaScript</a> platform with new features that improve developer workflow and security.</span></p>

<p><span style="color:black">npm Inc. is the commercial organization behind the node package manager (<u><a href="https://docs.npmjs.com/cli/npm" style="text-decoration:underline target=_blank" target="_blank">npm</a></u>) and its associated public registry, which is used by more than 11 million developers to support application development with the widely used node JavaScript framework. The first release of npm Enterprise came out in March, providing organizations with features that go beyond what is in the public npm registry to help enable enterprise development workflows. In the new update, npm Enterprise is building out those enterprise capabilities to provide additional functionality.</span></p>

<p><span style="color:black">"The initial release was just bringing in the functionality that developers know and love from npm and enabling that in the enterprise," Ahmad Nassri, CTO of npm, told ITPro Today. "Now we're taking it a step even further, with advanced workflows that service the administrators and the enterprise security teams from a large team perspective, as opposed to an individual maintainer for a package."</span></p>

<p><span style="color:black">The npm Enterprise offering is a cloud-based platform that both enables organizations to manage private JavaScript packages as well as provides integration with the public npm registry. The enterprise JavaScript platform provides collaboration and now security controls to promote best practices for code usage across an organization. The updated package filtering capabilities in the npm Enterprise update are designed to make it easier for organizations to keep track of the packages being used.</span></p>

<p><span style="color:black">"We're effectively giving enterprise administrators and the security teams at companies keys and the knobs to configure the workflows that they need to surface, based on their risks and the business policy that they want to apply," Nassri said.</span></p>

<p><span style="color:black">Nassri added that in the new update, the package filtering features can enable an enterprise administrator to dictate a level of policy. So, for example, packages that have a known vulnerability at a given severity level cannot be used within the business. Going a step further, the plan is to further enhance the control and visibility around packages such that other attributes of npm packages will be surfaced for users.</span></p>

<p><span style="color:black">"Just because something is published on the public registry doesn't necessarily mean it's free and doesn't necessarily mean it's not copyrighted and is allowed for your business," he said. "Our current trajectory for improving those workflows for our enterprise customers is to dive deeper into those areas, but right now this initial release is going to look at the security aspects of things."</span></p>

<h2><span style="color:black"><strong>npm Orgs</strong></span></h2>

<p><span style="color:black">Integration with <a href="https://www.itprotoday.com/security/moving-toward-password-less-authentication-future" style="text-decoration:underline">single sign-on</a> (SSO) has also been enhanced in the npm Enterprise update, making it easier for organizations to enable more advanced access and authentication options. Among the SSO enhancements are support for the <a href="https://www.itprotoday.com/identity-management-and-access-control/what-are-oauth-20-and-openid-connect" style="text-decoration:underline">OpenID Connect</a> and <a href="https://marketresearchupdates.com/2019/06/28/incredible-possibilities-security-assertion-markup-language-saml-authentication-market-studied-detail-along-top-companies-amazon-gemalto-microsoft-oracle-auth0-ibm-ping-identity/" style="text-decoration:underline target=_blank" target="_blank">Security Assertion Markup Language</a> (SAML) standards. </span></p>

<p><span style="color:black">The SSO support is particularly useful for npm orgs—at npm every team can have a different org with a specific scope for their own team with their own set of technologies, according to Nassri. Tying in the SSO can now enable an npm Enterprise administrator to invite those outside of a company, including contractors, to be part of the org group, with an appropriate level of scope.</span></p>

<h2><span style="color:black"><strong>Using npm Enterprise</strong></span></h2>

<p><span style="color:black">The public npm registry has been in use since 2010, and developers tend to already have an established workflow for how they work with npm in general. Nassri emphasized that npm Enterprise doesn't change the developer workflow in terms of the process that developers are already familiar with using.</span></p>

<p><span style="color:black">"So if you're a developer and you rely on npm as part of your <a href="https://www.itprotoday.com/devops-and-software-development/problem-continuous-delivery-defining-continuous" style="text-decoration:underline">CI [continuous integration environment</a>, if an administrator comes in and starts applying a policy, your workflow stays the same. You don't have to change anything in terms of your build tools or your local tools," he said. "Instead, what you're seeing is when the policy starts hitting against risk profiles, or areas that an administrator has disabled, you start getting more meaningful messages about that."</span></p>

<p><span style="color:black">The npm Enterprise service also provides JavaScript footprint analysis and usage pattern reporting capabilities. Nassri said that many organizations have not been fully prepared for the growth of JavaScript usage within their development teams.</span></p>

<p><span style="color:black">"We're actually trying to provide them context with a better understanding of their footprint, and helping to get an understanding of how developers are building things," he said. "Every organization has different patterns and different workflows."</span></p>

<p><span style="color:black">Looking forward, the plan for npm Inc. is to continue to improve its enterprise JavaScript platform and the overall developer experience.</span></p>

<p><span style="color:black">"We want to work closer with enterprise customers and make sure we're surfacing the right patterns and patterns that scale to the size that they operate in," Nassri said. "That could surface in so many different ways, whether in product features, user management features or with information that we can provide about usage patterns."</span></p>

        
                                        </div>

      
                <div class="secondary-tags">
      TAGS:              <a href="/devops-and-software-development" class="secondary-tag">DevOps and Software Development</a>        </div>
      
              
  <div class="comments-wrapper" id="comments-140935">
    <div class="comments">
      <a href="javascript:void(0)" class="comments--show hidden">0 comments</a>    </div>
    <div class="comments-container">
      <div class="fill-comments">
        <div class="comments-header"><span class="comments--hide">Hide comments</span></div>
                  <form class="comment-form" action="/comment/reply/140935" method="post" id="comment-form" accept-charset="UTF-8"><div><div class="user-comment-body">
  <div class="user-comment-field">
    <div class="user-photo">
      <img class="user-thumb-img" src="https://www.itprotoday.com/sites/all/themes/penton_core_theme/images/account-default-image.png" alt="" />    </div>
    <div class="user-content">
      <div class="user-name">
        <a href="/" class="js-penton-user-url-profile"></a>      </div>
      <div class="user-comment">
        <div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="comment_body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label class="element-invisible" for="edit-comment-body-140935">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full ckeditor-mod form-textarea required" placeholder="Be the first to comment..." id="edit-comment-body-140935" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
<a class="ckeditor_links" style="display:none" href="javascript:void(0);" onclick="javascript:Drupal.ckeditorToggle(['edit-comment-body-140935'],'Switch to plain text editor','Switch to rich text editor');" id="switch_edit-comment-body-140935">Switch to plain text editor</a><fieldset class="filter-wrapper element-invisible form-wrapper" id="edit-comment-body-und-0-format"><div class="fieldset-wrapper"><div class="filter-help form-wrapper" id="edit-comment-body-und-0-format-help"><p><a href="/filter/tips" target="_blank">More information about text formats</a></p></div><div class="form-item form-type-select form-item-comment-body-und-0-format">
  <label for="edit-comment-body-und-0-format--2">Text format </label>
 <select class="filter-list form-select" id="edit-comment-body-und-0-format--2" name="comment_body[und][0][format]"><option value="comments" selected="selected">Comments</option><option value="plain_text">Plain text</option></select>
</div>
<div class="filter-guidelines form-wrapper" id="edit-comment-body-und-0-format-guidelines"><div class="filter-guidelines-item filter-guidelines-comments"><h3>Comments</h3><ul class="tips"><li>Allowed HTML tags: &lt;em&gt; &lt;strong&gt; &lt;blockquote&gt; &lt;br&gt; &lt;p&gt;</li></ul></div><div class="filter-guidelines-item filter-guidelines-plain_text"><h3>Plain text</h3><ul class="tips"><li>No HTML tags allowed.</li><li>Web page addresses and e-mail addresses turn into links automatically.</li><li>Lines and paragraphs break automatically.</li></ul></div></div></div></fieldset>
</div>
<a href="#" class="publish js-publish user-comment__publishbtn">Publish</a><span class='comment-error'><a href="/penton_modal/nojs/login" class="ctools-use-modal ctools-modal-modal-popup-login" rel="nofollow">Log in or register to comment</a></span></div></div>      </div>
    </div>
  </div>
</div>
<input type="hidden" name="cid" value="" />
<input type="hidden" name="pid" value="" />
<input type="hidden" name="form_build_id" value="form-ZX1OWiKss6dzSVWYDUeN1pIklsdsW4H071mBQVqCWlU" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<input type="hidden" name="captcha_sid" value="85510642" />
<input type="hidden" name="captcha_token" value="e3663a2d9864ee14dc3af39b00ecd10d" />
<div class="element-invisible"><div class="form-actions form-wrapper" id="edit-actions"><button id="edit-submit-140935" name="op" value="Save" class="form-submit">Save</button>
</div></div><div class="url-textfield"><div class="form-item form-type-textfield form-item-url">
  <label for="edit-url">Leave this field blank </label>
 <input autocomplete="off" type="text" id="edit-url" name="url" value="" size="20" maxlength="128" class="form-text" />
</div>
</div></div></form>                <div class="comments-inner-container">
                  </div>
      </div>
    </div>
  </div>
      
    </div>

    
    <div class="row related-articles-row">
              <div class="related-articles-heading">Related</div><div class="related-articles-wrapper"><a href="/programming-languages/how-tara-ai-helping-developers-build-better-software-faster" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/software-developer.jpg?itok=YXNLj37h" src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/software-developer.jpg?itok=UqdJo9tl" width="90" height="83" alt="software developer" /></div><div class="small-article__inner"><div class="small-article__inner-title">How Tara AI Is Helping Developers Build Better Software Faster</div><span>Jul 08, 2019</span></div></article></a><a href="/programming-languages/best-programming-languages-born-last-decade" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/Screen%20Shot%202018-12-08%20at%204.45.18%20PM_0.png?itok=mf1hq5aF" src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/Screen%20Shot%202018-12-08%20at%204.45.18%20PM_0.png?itok=QKQuiDuc" width="90" height="83" alt="Code on screen" /></div><div class="small-article__inner"><div class="small-article__inner-title">The Best Programming Languages Born in the Last Decade</div><span>Dec 09, 2018</span></div></article></a><article class="dfp-ad-hideempty hidden n_hidden small-article" data-dfp-position="native_related"></article><a href="/programming-languages/containers-and-serverless-computing-model-what-aws-azure-and-google-offer" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/Screen%20Shot%202018-11-28%20at%209.14.47%20PM_0.png?itok=8IMa0Nfe" src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/Screen%20Shot%202018-11-28%20at%209.14.47%20PM_0.png?itok=VSJBeVUV" width="90" height="83" alt="Computer binary" /></div><div class="small-article__inner"><div class="small-article__inner-title">Containers and the Serverless Computing Model: What AWS, Azure and Google Offer</div><span>Nov 29, 2018</span></div></article></a><a href="/programming-languages/millennials-and-open-source-dont-know-dont-care" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/Screen%20Shot%202018-11-26%20at%209.06.29%20PM_0.png?itok=NnE1uFBg" src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/Screen%20Shot%202018-11-26%20at%209.06.29%20PM_0.png?itok=7NZSfGxt" width="90" height="83" alt="Millennials" /></div><div class="small-article__inner"><div class="small-article__inner-title">Millennials and Open Source: Don't Know, Don't Care?</div><span>Nov 27, 2018</span></div></article></a></div>          </div>

    
    <div class="item-list"><ul class="lazy-pagination"><li class="read-more pagination-read-more next first"><a href="/programming-languages/how-tara-ai-helping-developers-build-better-software-faster?parent=140935&infscr=1" rel="nofollow">Load More</a></li>
<li class="last"><a href="/programming-languages/how-tara-ai-helping-developers-build-better-software-faster" rel="next">Next Article</a></li>
</ul></div>
    
  </article>

  
</section>
  </div>
</div>
  </div>

        </div>
                <div class="banner-bottom-wrapper">
          <div id="banner-bottom" class="dfp-ad-hideempty hidden">
            <div data-dfp-position="bottom_banner"></div>
          </div>
        </div>
                <!-- /Main Content Area -->
                  <!-- Footer -->
          <!-- Check to see if we are in the store -->
  <footer class="l-footer l-footer-min ">
    <div class="l-footer-inner">
      <div class="l-footer-info">
        <div class="footer-logo-min">
                      <a href="/"><img class="footer-logo-min__site_logo" src="https://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/footer.png" alt="Logo" /></a>                    <div class="small-12 medium-5 columns">
            <div class="footer-links">
                            <a href="https://informa.com/"><img src="/sites/all/themes/penton_core_theme/images/powered_by_informa_businessline.png" alt="Powered by Informa" /></a>            </div>
          </div>
        </div>
        <ul class="footer-min-col">
          <li class="footer-min-col__item">
      <a href="/about-us" class="footer-min-col-link">About</a>    </li>
          <li class="footer-min-col__item">
      <a href="https://www.itprotoday.com/advertise-itprotodaycom" class="footer-min-col-link">Advertise</a>    </li>
          <li class="footer-min-col__item">
      <a href="/contact-us" class="footer-min-col-link">Contact Us</a>    </li>
          <li class="footer-min-col__item">
      <a href="/sitemap" class="footer-min-col-link">Sitemap</a>    </li>
            </ul>
      <ul class="footer-min-col no-margin">
        <li class="footer-min-col__item">
      <a href="http://www.penton.com/privacy-policy#ThirdPartyAdvertisingTech" class="footer-min-col-link">Ad Choices</a>    </li>
          <li class="footer-min-col__item">
      <a href="http://engage.informa.com/privacy-statement" class="footer-min-col-link">Privacy Policy</a>    </li>
          <li class="footer-min-col__item">
      <a href="http://engage.informa.com/terms-of-service" class="footer-min-col-link">Terms of Service</a>    </li>
          <li class="footer-min-col__item">
      <a href="https://engage.informa.com/cp/cookie-policy/" class="footer-min-col-link">Cookie Policy</a>    </li>
  </ul>
<div class="social-min-col">
  <p class="social-min-col__label">Follow us:</p>
  <div class="social-icons"><a href="https://www.facebook.com/ITProToday/" title="" class="social-icons__link"><i class="social-icons__icon fa fa-facebook"></i></a><a href="https://twitter.com/ITProToday" title="" class="social-icons__link"><i class="social-icons__icon fa fa-twitter"></i></a><a href="https://www.linkedin.com/company/itpro-today/" title="" class="social-icons__link"><i class="social-icons__icon fa fa-linkedin"></i></a></div></div>
      </div>
      <div class="l-footer-rights">
        <span class="copyrights">
          &#169; 2019 Informa USA, Inc., All Rights Reserved
        </span>
      </div>
    </div>
  </footer>
          <!-- /Footer -->
              </div>
    </div>
  </div>
</main>
<!-- /Page -->
<div id="hidden-dfp" class="dfp-ad-hideempty hidden">
  <div data-dfp-position="hidden" class="hidden-for-ads"></div>
</div>
      <script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js__PiZuK2o4XAnDCWOhogiGF01gyHzeu7QxvOyfTe-YyM.js"></script>
<script type="text/javascript" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_s3L_uC35AiN5EGYY533su-jccnLRp2aKpOnjgPLbo34.js"></script>
<script type="text/javascript" src="//assets.adobedtm.com/2ebe67d2ca0193084439038012c34f9112a85c00/satelliteLib-48191dfa1509ee2d203e3f6eb4bc8a3de3320ce9.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_aqDLL_44zBARAgd_FTblZWchUi73E-YeDLd8oMO1dX0.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_GvFI1Erj9lwgnlQvjzhlnt7VnWq4wEBj5E2GXC1YDg4.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.CKEDITOR_BASEPATH = "/sites/all/modules/contrib/ckeditor/ckeditor/"
//--><!]]>
</script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_FloLC-L2hL--gn7qKaXXBNWxL6qI_-SL4q2_WBFL5X4.js"></script>
<script type="text/javascript" src="//video.limelight.com/player/embed.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_xht8E4BLA53oTxrfnKlXrB1kiW1yjdvRUnS5OTDFd_A.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
informaBouncexSettings = {"id":"1","property_name":"ITPro Today","colors_text_primary":"#ffffff","colors_text_secondary":"#ffffff","colors_bg_primary":"#004563","colors_bg_secondary":"#51bae6","brochure_url":"https:\/\/www.itprotoday.com","logo_url":"https:\/\/www.itprotoday.com\/sites\/all\/themes\/penton_subtheme_itprotoday\/images\/logos\/header.png","subscription_url":"https:\/\/www.itprotoday.com\/newsletters\/signup","gaViewID":"186866656","elqFormId":"1037","elqFormName":"INET_Promo_BounceXIntegration","eloquaInstance":"PentoniNET","elqSiteID":"1885539667","created":"1552499984"};
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
informaBouncexCmpgn = {"disengagement":{"step1":{"preheader":"ENTER YOUR EMAIL TO DOWNLOAD ","header":"TECHNOLOGY SALARY SURVEY FINDINGS: CURRENT COMPENSATION, FUTURE COMPENSATION","cta":"SEE SURVEY FINDINGS","ntb":"CONTINUE TO SITE"},"step2":{"preheader":"GREAT","header":"YOU NOW HAVE ACCESS TO THE FULL TECHNOLOGY SALARY SURVEY FINDINGS","cta":"SEE THE REPORT","ntb":""},"step3":{"preheader":"","header":"","cta":"","ntb":""},"offer":"ITPSalaryReport_disengagement"},"clickToCaptureDesktop":{"step1":{"preheader":"","header":"DO YOU WANT TO GET ANALYSIS AND PRO TIPS DAILY?","cta":"YES, KEEP ME UPDATED","ntb":""},"step2":{"preheader":"ENTER YOUR EMAIL TO RECEIVE","header":"INDUSTRY NEWS, PRODUCTS, FAQs, TIPS AND RESOURCES","cta":"SIGN ME UP","ntb":"CONTINUE TO SITE"},"step3":{"preheader":"GREAT","header":"YOU'LL NOW RECEIVE DAILY ANALYSIS AND PRO TIPS","cta":"CONTINUE TO SITE","ntb":""},"offer":"ITPNewsletter_Desktop"},"clickToCaptureMobile":{"step1":{"preheader":"","header":"DO YOU WANT TO GET ANALYSIS AND PRO TIPS DAILY?","cta":"YES, I WANT ACCESS","ntb":"NO, I DON'T WANT UPDATES"},"step2":{"preheader":"ENTER YOUR EMAIL TO RECEIVE","header":"INDUSTRY NEWS, PRODUCTS, FAQs, TIPS AND RESOURCES","cta":"SIGN ME UP","ntb":"CONTINUE TO SITE"},"step3":{"preheader":"GREAT","header":"YOU'LL NOW RECEIVE DAILY ANALYSIS AND PRO TIPS","cta":"CONTINUE TO SITE","ntb":""},"offer":"ITPNewsletter_Mobile"},"inlinezone":{"step1":{"preheader":"DO YOU WANT ACCESS TO","header":"2019 TECHNOLOGY SALARY SURVEY FINDINGS?","cta":"YES, UNLOCK ACCESS","ntb":"NO, NOT RIGHT NOW"},"step2":{"preheader":"ENTER YOUR EMAIL TO DOWNLOAD ","header":"TECHNOLOGY SALARY SURVEY FINDINGS: CURRENT COMPENSATION, FUTURE COMPENSATION","cta":"SEE SURVEY FINDINGS","ntb":"CONTINUE TO SITE"},"step3":{"preheader":"GREAT","header":"YOU NOW HAVE ACCESS TO THE FULL TECHNOLOGY SALARY SURVEY FINDINGS","cta":"SEE THE REPORT","ntb":""},"offer":"ITPSalaryReport_Inline"}};
//--><!]]>
</script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_VvSlYoodLAf6CoZ1-kQ6MDC-Fvy22ighqZW1xFo6HqA.js"></script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_L6OZG5KXpK9TmHNSbl24vOE0yJf48VytacfkHRBNEVc.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
Drupal.settings.penton_eloqua_api = {"fields":["nl","utm_rid"]};
//--><!]]>
</script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_qekzEEdO6OYK9JDfHY1d86k3s6DkdpDGSrJKG4vEaz4.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_UyCyyzd14kvoxu1M3ZxsQxsSluv_Y7s3umEmhpCttcU.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_Ev2a03hYfNqtDZW8vAZHfy3Nf4HzCwV9KR-zrDXM2_g.js"></script>
<script type="text/javascript">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</script>
      <script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_39wR4vuLCUZcIK_NsEhVLhl6834Dd3heLLFQ5DLVNsc.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/all/modules/contrib/ckeditor/ckeditor/ckeditor.js?pv3868"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_hTvEvnr-CSP0ayePYXq_lDVR4Xlir2rUBDh7jP_21fI.js"></script>
    </div>
  </body>
</html>
