<!DOCTYPE html>
<html lang="en"
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#" class="html not-front not-logged-in no-sidebars page-node page-node- page-node-143369 node-type-article header-with-pillar article-article">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <meta charset="utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge, chrome=1" />
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_152x152.png" sizes="152x152" />
<link rel="shortcut icon" href="https://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_180x180.png" sizes="180x180" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_167x167.png" sizes="167x167" />
<meta name="title" content="Java Language, at 25, Shows No Signs of Decline" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_120x120.png" sizes="120x120" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch.png" />
<meta name="eloqua-tags" content="ITP-P-programming-languages, , ITP-Journey-awareness"/><link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_76x76.png" sizes="76x76" />
<meta name="description" content="After 25 years of availability, the Java language is still widely used and even accelerating with a faster release cycle." />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.itprotoday.com/programming-languages/java-language-25-write-once-run-anywhere-lives" />
<link rel="shortlink" href="https://www.itprotoday.com/node/143369" />
<meta property="og:site_name" content="IT Pro" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Java Language at 25: Write Once, Run Anywhere Lives On" />
<meta property="og:description" content="After 25 years of availability, Java shows no signs of decline as a widely used developer language that is now accelerating with a faster release cycle." />
<meta property="og:updated_time" content="2020-06-10T20:56:30+00:00" />
<meta property="og:image" content="https://www.itprotoday.com/sites/itprotoday.com/files/java-at-25.png" />
<meta property="twitter:card" content="summary" />
<meta property="twitter:url" content="https://www.itprotoday.com/programming-languages/java-language-25-write-once-run-anywhere-lives" />
<meta property="twitter:title" content="Java Language at 25: Write Once, Run Anywhere Lives On" />
<meta property="article:published_time" content="2020-06-10T19:57:59+00:00" />
<meta property="article:modified_time" content="2020-06-10T20:56:30+00:00" />
<meta property="og:audio" content="http://" />
<meta property="og:audio:secure_url" content="https://" />
<meta property="og:video:url" content="http://" />
<meta property="og:video:secure_url" content="https://" />
<meta property="og:video:type" content="text/html" />
    <title>Java Language, at 25, Shows No Signs of Decline | IT Pro</title>
    <link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_PpiQEI-azlEmknynFVbTW6pWwXhVPT_fbABYbBL6JWQ.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_DHcXHPYBSjIVaCQZEG4ZlpLkvslnFlBCnQUCzlbRBio.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_4GJdl2xvrwyZP8r03oU7AnszTtBYGy_ecYVYwmYoww4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_I7cOhAJWaIpSCM6sIXyWxzy7fevGuWHA66fLbaH3cFE.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_9ZJgsxVcrJK3ApK_vU9P9ZzczaRkb04dRsdUkQHuiB8.css" media="all" />

<!--[if lte IE 9]>
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_d5304rVRgE97dcoJVANw-HS6Cz-71UhME-UbNuFSgx8.css" media="all" />
<![endif]-->
    <!-- HTML5 element support for IE6-8 -->
    <!--[if lt IE 9]>
    <script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
    <![endif]-->
    <script>
      var gdpr_cookie = "off";
      // Check if cookies enabled in browser.
      var cookieEnabled = navigator.cookieEnabled;
      if (typeof navigator.cookieEnabled === 'undefined' && !cookieEnabled) {
        document.cookie = 'testCookie';
        cookieEnabled = (document.cookie.indexOf('testCookie') !== -1);
      }
      if (cookieEnabled) {
        var is_cookie = document.cookie.indexOf('penton_gdpr_cookie');
        if (is_cookie == -1) {
          console.log('gdpr cookie not set');
          // Cookie is not yet set - banner just served
          gdpr_cookie = "on";
        }
      }
      console.log('gdprCookie==>' + gdpr_cookie);
    </script>
        <script>
      var isblocked = "notblocked";
      console.log('lpage==>' + isblocked);
      var pathname = window.location.pathname;
      var adu = "/3834/itprotoday.home/article/devops_and_software_development/programming_languages";
      var adblockOn = 1;
    </script>
    <script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
    <script>
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
    </script>
    <script>
      if (adu !== "" && (pathname.indexOf('/cart') < 0) && (pathname.indexOf('/store') < 0) && (pathname.indexOf('/products') < 0) && (pathname.indexOf('/product-types') < 0) && (pathname.indexOf('/store-topics') < 0) && ((pathname.indexOf('/gallery')) !== (pathname.length - 8)) && (pathname.indexOf('/user/login') < 0) && (isblocked == "notblocked") && (pathname.indexOf('penton_ur_thank_you') < 0)) {
        var targ_arr = JSON.parse('[{"target":"pos","value":"728_1_a"},{"target":"combo","value":"wrap"},{"target":"ptype","value":"Article"},{"target":"nid","value":"143369"},{"target":"pterm","value":"programming_languages"},{"target":"author","value":"sean_michael_kerner"},{"target":"reg","value":"anonymous"}]');
        googletag.cmd.push(function() {
          if (gdpr_cookie == "off" && typeof googletag !== 'undefined' && typeof googletag.pubads !== 'undefined'  && googletag.apiReady) {
            googletag.pubads().setRequestNonPersonalizedAds(0);
          } else if (gdpr_cookie == "on" && typeof googletag !== 'undefined' && typeof googletag.pubads !== 'undefined'  && googletag.apiReady) {
            googletag.pubads().setRequestNonPersonalizedAds(1);
          }
          var welcome_ad = googletag.defineSlot(adu, [1, 1], "div-interstitial");
          welcome_ad.addService(googletag.pubads());
          welcome_ad.setTargeting("pos", "interstitial_a");
          welcome_ad.setTargeting("gdpr_banner", gdpr_cookie);
          for (var i=0; i<targ_arr.length; i++) {
            var targ = targ_arr[i]['target'];
            var val = targ_arr[i]['value'].split(',');
            if (targ !== 'pos' && targ !== 'combo') {
              welcome_ad.setTargeting(targ, val);
            }
          }

          setTimeout(function() {
            console.log('adblockval');console.log(adblockOn);
            if(adblockOn == 1) {
              var bDiv = document.getElementById("body-wrapper");
              window.scrollTo(0, 0);
              if(bDiv.style.removeProperty) {
                bDiv.style.removeProperty('opacity');
              } else {
                bDiv.style.removeAttribute('opacity');
              }
            }
          }, 2000);

          if (typeof googletag !== 'undefined' && typeof googletag.pubads !== 'undefined'  && googletag.apiReady) {
            googletag.pubads().addEventListener('slotRenderEnded', function(event) {
              adblockOn = 0;
              if(event.slot.getSlotElementId() == "div-interstitial") {
                if(event.isEmpty) {
                  console.log('emptyInterstitial');
                  var bDiv = document.getElementById("body-wrapper");
                  window.scrollTo(0, 0);
                  if(bDiv.style.removeProperty) {
                    bDiv.style.removeProperty('opacity');
                  } else {
                    bDiv.style.removeAttribute('opacity');
                  }
                } else {
                  console.log('notemptyInterstitial');
                }

                var dfplogpatt = new RegExp('dfp_log');
                var isDebug = dfplogpatt.test(location.search);
                if(isDebug) {
                  console.log('%c********DFPTag: Interstitial********', 'font-size:medium;font-style:bold');
                  console.log('adunit: '+adu);
                  if (gdpr_cookie == "off") {
                    console.log('nonpersonalized ads: 0');
                  } else if (gdpr_cookie == "on") {
                    console.log('nonpersonalized ads: 1');
                  }
                  console.log('targetingpair==> pos:interstitial_a');
                  console.log('targetingpair==> gdpr_banner:'+gdpr_cookie);
                  for(var i=0; i<targ_arr.length; i++) {
                    var targ = targ_arr[i]['target'];
                    var val = targ_arr[i]['value'].split(',');
                    if(targ !== 'pos' && targ !== 'combo') {
                      console.log('targetingpair==> '+targ+':'+val);
                    }
                  }
                  console.log('adsize: [1, 1]');
                  console.log('oop: false');
                  console.log('%c************************************', 'font-size:medium;font-style:bold');
                }
              }
            });
            googletag.enableServices();
          }
        });
      }
    </script>
      </head>
  <body>
        <div id="wl_flogop_div" class="hidden">/sites/all/themes/penton_subtheme_itprotoday/images/logos/footer.png</div>
    <div id="div-interstitial">
      <script>
        if(adu !== "" && (pathname.indexOf('/cart') < 0) && (pathname.indexOf('/store') < 0) && (pathname.indexOf('/products') < 0) && (pathname.indexOf('/product-types') < 0) && (pathname.indexOf('/store-topics') < 0) && ((pathname.indexOf('/gallery')) !== (pathname.length - 8)) && (pathname.indexOf('/user/login') < 0) && (isblocked == "notblocked") && (pathname.indexOf('penton_ur_thank_you') < 0)  ) {
          googletag.cmd.push(function() {
            googletag.display("div-interstitial");
          });
        }
      </script>
    </div>
        <div id="body-wrapper"  style="opacity:0;" >
      <noscript aria-hidden="true"><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KQFKXN4" height="0" width="0" style="display:none;visibility:hidden" title="Google Tag Manager">Google Tag Manager</iframe></noscript>      <header class="header js-header">
  <a id="skip-navigation" href="#main_content">Skip navigation</a>
  <!-- Pillar Navigation region -->
<nav class="pillar-nav">
<div id="block-penton-informa-banner-penton-informa-banner" class="block block-penton-informa-banner">

    
  <div class="content">
    <div id="iribbon-container">
    <button id="iribbon-title" title="show/hide">Informa</button>
    <div id="iribbon-detail" class="ribbon-hide">
        <div id="iribbon-left">
            <p>IT Pro Today is part of the Informa Tech Division of Informa PLC</p>
            <ul>
                <li class="iribbon-mainlink"><a href="https://informa.com/">Informa PLC</a></li>
                <li><a href="https://informa.com/About-Us/">About us</a></li>
                <li><a href="https://informa.com/Investors/">Investor relations</a></li>
                <li><a href="https://informa.com/Talent/">Talent</a></li>
            </ul>
        </div>
        <div id="iribbon-right">
            <p>This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them. Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.</p>
        </div>
    </div>
</div>
  </div>
</div>
<div id="block-menu-menu-pillar-navigation" class="pillar-nav__inner l-content clearfix">
  <div class="pillar-nav__header">Discover:</div>
  <ul class="pillar-nav__items js-menumore-discover"><li class="pillar-nav__item js-menumore-item-text  "><a href="https://www.blackhat.com/">Black Hat</a></li>
<li class="pillar-nav__item js-menumore-item-text  "><a href="https://www.interop.com/?_mc=hsad_x_itpro_le_aud_intplv_x_x-itpro-discbar">Interop</a></li>
<li class="pillar-nav__item js-menumore-item-text pillar-nav__item--event "><a href="https://tmt.knect365.com/iot-world/?utm_source=ITPMedia&amp;utm_medium=website&amp;utm_campaign=eyebrow-link">IoT World</a></li>
<li class="pillar-nav__item js-menumore-item-text  "><a href="https://afcom.com/Public/Leaders_Labs/Public/Leaders_Labs/About_Leaders_Labs/Leaders_Labs.aspx?hkey=842624e7-2596-4ceb-ba12-9f2ee91469a7">AFCOM Leaders Lab</a></li>
<li class="pillar-nav__item js-menumore-item-text pillar-nav__item--event "><a href="https://afcom.com/Public/Leaders_Labs/Public/Leaders_Labs/About_Leaders_Labs/Leaders_Labs.aspx?hkey=842624e7-2596-4ceb-ba12-9f2ee91469a7">Leaders lab</a></li>

    <li class="pillar-nav__item pillar-more js-menumore-more-item">
      <a class="pillar-more-btn">More<i class="fa fa-caret-down"></i></a>
      <ul class="pillar-list-nested js-menumore-sub"></ul>
    </li>
  </ul></div>
</nav>
<!-- /Pillar Navigation region -->
  <!-- Header -->
  <div class="header-inner l-content">
    <!-- Hamburger menu -->
<div class="menu-toggler js-ham-menu-toggler">
  <a href="#menu" class="menu-toggler-img-wrap js-menu-toggler">
    <div class="menu-toggler-hamburger">
      <div class="hamburger-text">Menu</div>
      <div class="hamburger-line"></div>
      <div class="hamburger-line"></div>
      <div class="hamburger-line"></div>
    </div>
  </a>
  <aside class="hamburger-menu">
    <div class="hamburger-menu-inner clearfix js-toggle-menu js-sticky-ham-menu">
      <div class="hamburger-menu-container">
                  <div class="user-thumb-text">
            <a href="/penton_modal/nojs/login" class="ctools-use-modal sattelite-event-caller sattelite-event-caller__hamburger-clicked ctools-modal-modal-popup-login" rel="nofollow">Log In</a> or <a href="/penton_modal/nojs/register/basic" class="ctools-use-modal sattelite-event-caller sattelite-event-caller__hamburger-clicked ctools-modal-modal-popup-medium" rel="nofollow">Register</a>          </div>
                <ul class="hamburger-menu-nav"><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/next-gen" title="">Next Gen</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/collaboration" title="">Collaboration</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/cloud-computing-0" title="">Cloud Computing</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/compute-engines" title="">Compute Engines</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/data-analytics-and-data-management" title="">Data Analytics and Data Management</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/data-center" title="">Data Center</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/devops-and-software-development" title="">DevOps and Software Development</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/mobility" title="">Mobility</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/security" title="">Security</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/storage" title="">Storage</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/windows-and-user-productivity" title="">Windows and User Productivity</a></li></ul><ul class="hamburger-menu-sub-nav"><li class="hamburger-menu-sub-nav__item"><a href="/industry-perspectives" title="">Industry Perspectives</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://www.itprotoday.com/it-buyers-guides" title="">Buyer’s guides</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://www.itprotoday.com/it-top-10-reports" title="">Top 10 reports</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://www.itprotoday.com/special-reports-it-tech-shaping-tomorrow" title="">Special reports</a></li><li class="hamburger-menu-sub-nav__item"><a href="/webinar-0" title="">Webinars</a></li><li class="hamburger-menu-sub-nav__item"><a href="/whitepapers" title="">Whitepapers</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://www.itprotoday.com/business-resources/technology-providers-company-profiles" title="">Technology Provider</a></li><li class="hamburger-menu-sub-nav__item"><a href="/business-resources" title="">Business Resources</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://afcom.com/Public/Leaders_Labs/Public/Leaders_Labs/About_Leaders_Labs/Leaders_Labs.aspx?hkey=842624e7-2596-4ceb-ba12-9f2ee91469a7" title="">AFCOM Leaders Lab</a></li><li class="hamburger-menu-sub-nav__item"><a href="/newsletters/signup" title="">Newsletter Preference</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://www.itprotoday.com/advertise-itprotodaycom" title="">Advertise</a></li><li class="hamburger-menu-sub-nav__item"><a href="/about-us" title="">About Us</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://knect365.com/privacy-policy" title="">Privacy Policy</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://www.penton.com/terms-of-service/" title="">Terms of Service</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://corporate.knect365.com/privacy-centre/our-cookie-policy/" title="">Cookie Policy</a></li></ul><div class="social-icons"><a href="https://www.facebook.com/ITProToday/" title="" class="social-icons__link"><i aria-label="facebook" class="social-icons__icon fa fa-facebook"></i></a><a href="https://twitter.com/ITProToday" title="" class="social-icons__link"><i aria-label="twitter" class="social-icons__icon fa fa-twitter"></i></a><a href="https://www.linkedin.com/company/itpro-today/" title="" class="social-icons__link"><i aria-label="linkedin" class="social-icons__icon fa fa-linkedin"></i></a></div>              </div>
    </div>
  </aside>
</div>
<!-- /Hamburger menu -->
    <!-- Header Logo -->
    <div class="header-logo">
                      <a href="/" class="header-logo__link"><img src="/sites/all/themes/penton_subtheme_itprotoday/images/logos/header.png" alt="IT Pro" title="IT Pro" /></a>                  </div>
    <!-- /Header Logo -->
          <!-- Header User links -->
      <ul class="header-nav">
                  <li class="header-nav__item header-nav__item__search">
            <a href="/search" class="header-nav-link"><i class="fa fa-search"></i>Search</a>          </li>
                          <li class="header-nav__item no-mobile">
            <a href="/penton_modal/nojs/login" class="ctools-use-modal ctools-modal-modal-popup-login header-nav-link" rel="nofollow">Log In</a>          </li>
          <li class="header-nav__item no-mobile last">
            <a href="/penton_modal/nojs/register/basic" class="ctools-use-modal ctools-modal-modal-popup-medium header-nav-link sattelite-event-caller sattelite-event-caller__header-clicked" rel="nofollow">Register</a>          </li>
                <!-- Cart -->
                <!-- /Cart -->
      </ul>
      </div>

  <!-- legal communication alert -->
  <div class="js-penton-legal-comm-ajax-output-alert">
      </div>
  <!-- /legal communication alert -->
<!-- /Header -->
</header>
<!-- Page -->
<main>
  <div id="page-wraper">
    <!-- Header Adv -->
    <div class="banner-top-wrapper">
      <div id="banner-top" class="dfp-ad-hideempty hidden">
        <div data-dfp-position="top_banner"></div>
      </div>
    </div>
        <!-- Admin Tabs -->
          <section id="admin-tabs" class="l-content">
              </section>
        <!-- /Admin Tabs -->
    <!-- /Header Adv -->
    <div class="wrapper l-content">
                                <!-- Sidebar -->
        <aside id="sidebar" class="l-sidebar sidebar">
            <div class="region region-left-col">
          <div class="slide-out-sidebar-button js-expand-sidebar">
        <span class="slide-out-recent">Recent</span>
      </div>
        <div class="sidebar-wrapper sidebar-scrollable js-sticky-leftcol">
      <section id="penton_recent_content_block">
  <aside>
    <div class="r-a-header">Recent</div>
                
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/project-management/how-automate-workflow-trello-s-butler">
            How to Automate Workflow with Trello’s Butler            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jun 08, 2020</span>        </span>
          </div>
  </div>
</article>
                  <div data-dfp-position="native_leftrail_1" class="dfp-ad-hideempty hidden n_hidden n_leftrail1_2"></div>
            
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/backup/clumio-providing-data-protection-aws-native-services">
            Clumio Providing Data Protection for AWS Native Services            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jun 07, 2020</span>        </span>
          </div>
  </div>
</article>
            <div class="banner-aside-wrapper dfp-ad-hideempty">
      <div class="banner-aside js-sticky-banner dfp-ad-hideempty hidden">
        <div data-dfp-position="left_rail_rect"></div>
      </div>
    </div>
    <hr>
                    
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/machine-learning/amazon-s-heavily-automated-hr-leaves-workers-sick-leave-limbo">
            Amazon’s Heavily Automated HR Leaves Workers in Sick-Leave Limbo            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jun 05, 2020</span>        </span>
          </div>
  </div>
</article>
                  <div data-dfp-position="native_leftrail_2" class="dfp-ad-hideempty hidden n_hidden n_leftrail1_2"></div>
            
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/devops/5-reasons-not-use-kubernetes-distributions">
            5 Reasons Not to Use Kubernetes Distributions            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jun 05, 2020</span>        </span>
          </div>
  </div>
</article>
                
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/instant-messaging/slack-plunges-after-withdrawing-billings-view-uncertainty">
            Slack Plunges After Withdrawing Billings View on Uncertainty            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jun 04, 2020</span>        </span>
          </div>
  </div>
</article>
      </aside>
</section>


<section id="penton_featured_content_block">
  <aside>
    <div class="r-a-header">Featured</div>
          
<article class="article-teaser article-teaser__icon__white-paper article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/collaboration/make-remote-working-work-enterprise">
            Make Remote Working Work for the Enterprise            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Oct 09, 2019</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__no-img article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/windows-78/windows-7-10-migration-tools-buyer-s-guide">
            Windows 7 to 10 Migration Tools Buyer’s Guide            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jun 17, 2019</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/devops-and-software-development/5-key-it-skills-new-decade">
            5 Key IT Skills for the New Decade            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jun 27, 2019</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/containers/mirantis-unveils-first-homegrown-version-docker-enterprise-container-platform">
            Mirantis Unveils First Homegrown Version of Docker Enterprise Container Platform            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jun 04, 2020</span>        </span>
          </div>
  </div>
</article>
      </aside>
</section>
    </div>
  </div>
        </aside>
        <!-- /Sidebar -->
            <!-- Main Content Area -->
      <div class="page main-area l-main-area">
        <div id="main_content" class="clearfix" tabindex="-1">
          
            <div class="region region-main-col">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <section class="main-articles-container js-lazy-pager-wrapper">

    <article itemscope itemtype="http://schema.org/NewsArticle" class=" big-article article-type-article article-143369 node-type-article with-feat-img article-standalone js-lazy-pager-content"  data-nid="143369" data-url="/programming-languages/java-language-25-write-once-run-anywhere-lives" data-title="Java Language at 25: Write Once, Run Anywhere Lives On" data-seo-title="Java Language, at 25, Shows No Signs of Decline" data-type="article" data-terms="devops_and_software_development/programming_languages" data-ptermhier="DevOps and Software Development &gt; Programming Languages" data-pterm="Programming Languages" data-sterm="" data-program="" data-tax="Programming Languages" data-buyersjourney="Awareness" data-ext="" data-author="Sean Michael Kerner" data-pub="Jun 10, 2020" data-visibility="visible" data-perm="public" data-pid="39a39cb4-3ddb-413d-9d57-1da139300b7a" data-contentSponsor="" data-content="">
    <meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.itprotoday.com/programming-languages/java-language-25-write-once-run-anywhere-lives"/>
    <meta itemprop="datePublished" content="2020-06-10T19:52:00+00:00"/>    <meta itemprop="dateModified" content="2020-06-10T20:56:30+00:00"/>
        
    
    <div class="big-article__top">

      
              <div class="big-article__image" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
          <img class="medium lozad img-responsive js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_featured_retina/public/java-at-25.png?itok=P3jS6uhu" data-src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_featured_standard/public/java-at-25.png?itok=iaOAWM41" width="770" height="400" alt="Java at 25" title="Java at 25" />          <meta itemprop="url" content="https://www.itprotoday.com/sites/itprotoday.com/files/java-at-25.png">
          <meta itemprop="width" content="1398">
          <meta itemprop="height" content="800">

                      <span class="text-to-image">Oracle</span>
                  </div>
              
      <div class="big-article__head row">
        <div class="heading ">
                    <div class="breadcrumbs"><span class="parent-category"><a href="/devops-and-software-development">DevOps and Software Development</a><span>&gt;</span></span><a href="/devops-and-software-development/programming-languages">Programming Languages</a></div>          <h1 itemprop="headline">Java Language at 25: Write Once, Run Anywhere Lives On</h1>
                      <div itemprop="description">
              
  <div class="field field-name-field-penton-content-summary field-type-text-long field-label-hidden">
    After 25 years of availability, Java shows no signs of decline as a widely used developer language that is now accelerating with a faster release cycle.  </div>
            </div>
                                <p class="author-and-date" itemprop="author" itemscope="" itemtype="https://schema.org/Person"><span itemprop="name"><a href="/author/Sean-Kerner" itemprop="url">Sean Michael Kerner</a></span> | <span class="date-display-single">Jun 10, 2020</span></p>
                  </div>
      </div>

      
    </div>

              <div class="share-icons">
            <a href="/penton_modal/nojs/print/143369"
         class="print ctools-use-modal ctools-modal-modal-popup-basic"
         rel="nofollow">
        <i aria-label="print" class="fa fa-print"></i>
      </a>
          <a href="/penton_modal/nojs/forward/143369/0"
         class="envelope ctools-use-modal ctools-modal-modal-popup-basic-email"
         rel="nofollow">
        <i aria-label="email" class="fa fa-envelope"></i>
      </a>
                  <a href="https://www.facebook.com/sharer.php?u=https://www.itprotoday.com/programming-languages/java-language-25-write-once-run-anywhere-lives&amp;t=Java Language at 25: Write Once, Run Anywhere Lives On"
         class="facebook"
         target="_blank">
        <i aria-label="facebook" class="fa fa-facebook"></i>
      </a>
                <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.itprotoday.com/programming-languages/java-language-25-write-once-run-anywhere-lives&amp;title=Java Language at 25: Write Once, Run Anywhere Lives On&amp;summary=2020 marks a major milestone for the Java programming language as it celebrates its 25th birthday and continues to be among the most relevant and widely used development technologies.&amp;source=IT Pro"
         class="linkedin"
         target="_blank">
        <i aria-label="linkedin" class="fa fa-linkedin"></i>
      </a>
                <a href="https://twitter.com/share?url=https://www.itprotoday.com/programming-languages/java-language-25-write-once-run-anywhere-lives&amp;text=Java Language at 25: Write Once, Run Anywhere Lives On"
         class="twitter"
         target="_blank">
        <i aria-label="twitter" class="fa fa-twitter"></i>
      </a>
                <a href="https://pinterest.com/pin/create/button/?url=https://www.itprotoday.com/programming-languages/java-language-25-write-once-run-anywhere-lives&amp;description=2020 marks a major milestone for the Java programming language as it celebrates its 25th birthday and continues to be among the most relevant and widely used development technologies.&amp;media="
         class="pinterest"
         target="_blank">
        <i aria-label="pinterest" class="fa fa-pinterest"></i>
      </a>
              <a class="pinterest"
           target="_blank">
           <i aria-label="pinterest" class="fa fa-pinterest"></i>
        </a>
            </div>

              
    
    <div class="article-content-wrap">
      
      <div itemprop="articleBody" class="article-content ">
                  <div class="article-banner dfp-ad-hideempty hidden">
            <div data-dfp-position="inarticle1"></div>
          </div>
                
        <p><span style="color:black">2020 marks a major milestone for the <a href="https://www.itprotoday.com/devops-and-software-development/devops-2019-deeper-commitment-github-java-and-net" style="text-decoration:underline">Java programming language</a> as it celebrates its 25th birthday and continues to be among the most relevant and widely used <a href="https://www.itprotoday.com/devops/top-programming-languages-devops" style="text-decoration:underline">development technologies</a>.</span></p>

<p><span style="color:black">Sun Microsystems engineer James Gosling publicly announced the Java language on May 23, 1995, though the initial effort actually got started in June 1991. The <a href="https://www.itprotoday.com/devops-and-software-development/jive-java" style="text-decoration:underline">early promise of Java</a> was simple and yet profound, offering developers the opportunity to write once and then run anywhere. At the time, code was often tightly coupled with underlying hardware and the idea of code portability wasn't fully realized—until Java came along.</span></p>

<p><span style="color:black">Java has undergone significant technical and organizational challenges over the past 25 years. It moved from being entirely proprietary to open source in 2006, it transitioned from Sun to Oracle in 2010 as part of Oracle's acquisition of Sun, and, in 2017, its release cadence was accelerated.</span></p>

<h2><span style="color:black"><strong>Oracle Reflects on the Rise of Java</strong></span></h2>

<p><span style="color:black">In an online event hosted by Oracle celebrating 25 years of Java, Georges Saab, vice president of the Java Platform Group at Oracle and chair of the OpenJDK Governing Board, noted that Java found initial success because it solved a problem that developers had. The problem was code portability and the ability to write code that can run on any system.</span></p>

<p><span style="color:black">Mark Reinhold, chief architect of the Java Platform Group at Oracle, also reflected on how promising Java was in the beginning, though he admitted that there have been many surprises.</span></p>

<p><span style="color:black">"Probably the thing that surprised me the most is how long it's lasted," he said.</span></p>

<p><span style="color:black">Beyond the promise of portability, key tenets of the Java language are also stability and backward compatibility, such that code written a decade ago can still run today. Reinhold noted that early on, Java development struck a balance between adding new features while still maintaining stability.</span></p>

<p><span style="color:black">Over the years, it's been critical that Java has continued to innovate, added Brian Goetz, Java language architect at Oracle.</span></p>

<p><span style="color:black">"If we don't innovate, we're going to become irrelevant, and Java is not going to be interesting to people to program with," he said.</span></p>

<h2><span style="color:black"><strong>What's Wrong with Java</strong></span></h2>

<p><span style="color:black">While Java has many strengths, it isn't a perfect language.</span></p>

<p><span style="color:black">Pluralsight Java and Android development instructor Jim Wilson told <em>ITPro Today</em> that Java tends to be more verbose than other modern languages, which sometimes is difficult for beginners. That said, issues that beginning developers might have with Java can be overcome through a combination of education and tools, he added. </span></p>

<p><span style="color:black">"Education provides developers with the understanding to work effectively and enables developers to maximize the capabilities and power of the language," Wilson said.</span></p>

<p><span style="color:black">There is no one perfect language, he added, as every language has pluses and minuses. One language may be the one great language for performing Task A, but another may be the one great language for performing Task B, and yet another for performing Task C. </span></p>

<p><span style="color:black">A language alone does not constitute a solution. Wilson noted that ecosystem, APIs, tooling support, experience with a language, access to knowledgeable developers, available libraries of existing solutions, etc., all factor into determining the best language to work in when producing high-value, production software solutions. And when all of these issues are factored in, Java is a tough language to beat, Wilson said.</span></p>

<h2><span style="color:black"><strong>Java Success and Open Source</strong></span></h2>

<p><span style="color:black"><span style="background-color:white">"It</span><span style="background-color:white">’</span><span style="background-color:white">s hard to say there</span><span style="background-color:white">’</span><span style="background-color:white">s a lot wrong with any language that has literally stood the test of time," Mark Little, vice president of software engineering, Runtimes, at Red Hat, told <em>ITPro Today</em>. "In fact, there</span><span style="background-color:white">’</span><span style="background-color:white">s probably far more </span><span style="background-color:white">'</span><span style="background-color:white">right' with Java today than wrong, including the vibrant OpenJDK community, the fact it remains in the top 2 ranking of developer languages globally, is still used as a teaching language in many schools and colleges throughout the world, and is at the heart of one of the most popular multiplayer games in the world, Minecraft."</span></span></p>

<p><span style="color:black"><span style="background-color:white">Little noted that Java was popular even before it was open sourced through efforts such as <a href="https://openjdk.java.net/projects/icedtea/" style="text-decoration:underline target=_blank target=_blank" target="_blank">IcedTea</a> and then OpenJDK, which is an open source Java development kit that is at the core of Java development today.</span></span></p>

<p><span style="color:black"><span style="background-color:white">"However, the fact that OpenJDK came along and has grown to be an incredibly vibrant community, with participation from Red Hat, Oracle, Azul, Microsoft and others, helped developers to recognize that no one vendor is in charge of their programming language destiny," he said. "There</span><span style="background-color:white">’</span><span style="background-color:white">s been an explosion of open source frameworks, toolkits, IDEs, etc., over the past 10+ years, and whilst there are many different causes for this, I think one of them is the fact Java was open sourced."</span></span></p>

<p><span style="color:black"><span style="background-color:white">Little added that open source software efforts have fundamentally empowered the Java language to maintain its top-ranked status for large-scale application development and production.</span></span></p>

<h2><span style="color:black"><strong>The Next 25 Years of Java</strong></span></h2>

<p><span style="color:black">Java is likely to remain a cornerstone of enterprise application stacks for years to come.</span></p>

<p><span style="color:black">Although there have been many rivals, Java hasn't been displaced by any of them, according to Azul Systems CTO and co-founder Gil Tene.</span></p>

<p><span style="color:black">"When Java displaced C, <a href="https://www.jetbrains.com/research/devecosystem-2018/cpp/" style="text-decoration:underline target=_blank target=_blank" target="_blank">C++</a> and 4GL as the predominant means of building enterprise applications, that disruptive shift happened in a handful of years," Tene told <em>ITPro Today.</em> "We've seen multiple waves of&nbsp;presumptive&nbsp;Java killers since, but none have taken."</span></p>

<p><span style="color:black">Among the many reasons why Tene expects Java to remain widely used is the simple fact that there is a large pool of trained Java developers already for enterprises to draw from, making it possible to maintain code years after it was initially written.</span></p>

<p><span style="color:black">In addition, the rapid release cadence for Java that began in 2018 means that there are now two releases of Java each year. In the past, it could take three or more years for a new release. This year has seen one release thus far, <a href="https://www.itprotoday.com/programming-languages/java-14-improves-runtime-visibility-overall-performance" style="text-decoration:underline"><u>Java 14 </u></a>, providing a series of incremental improvements. </span></p>

<p><span style="color:black">Oracle's Goetz said the six-month release cycle has helped Java innovate faster, while still maintaining stability.</span></p>

<p><span style="color:black">"With the six-month cadence, we've been able to rotate our balance back to a good mix of big and small features, work on them side by side and deliver them as they're ready," he said. "If you look at the response to Java 14, people are all excited about the new features, and you know, we're going to keep them coming."</span></p>

        
                                        </div>

      
      
              
  <div class="comments-wrapper" id="comments-143369">
    <div class="comments">
      <a href="javascript:void(0)" class="comments--show hidden">0 comments</a>    </div>
    <div class="comments-container">
      <div class="fill-comments">
        <div class="comments-header"><span class="comments--hide">Hide comments</span></div>
                  <form class="comment-form" action="/comment/reply/143369" method="post" id="comment-form" accept-charset="UTF-8"><div><div class="user-comment-body">
  <div class="user-comment-field">
    <div class="user-photo">
      <img class="user-thumb-img" src="https://www.itprotoday.com/sites/all/themes/penton_core_theme/images/account-default-image.png" alt="" />    </div>
    <div class="user-content">
      <div class="user-name">
        <a href="/" class="js-penton-user-url-profile"></a>      </div>
      <div class="user-comment">
        <div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="comment_body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label class="element-invisible" for="edit-comment-body-143369">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full ckeditor-mod form-textarea required" placeholder="Be the first to comment..." id="edit-comment-body-143369" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
<a class="ckeditor_links" style="display:none" href="javascript:void(0);" onclick="javascript:Drupal.ckeditorToggle(['edit-comment-body-143369'],'Switch to plain text editor','Switch to rich text editor');" id="switch_edit-comment-body-143369">Switch to plain text editor</a><fieldset class="filter-wrapper element-invisible form-wrapper" id="edit-comment-body-und-0-format"><div class="fieldset-wrapper"><div class="filter-help form-wrapper" id="edit-comment-body-und-0-format-help"><p><a href="/filter/tips" target="_blank">More information about text formats</a></p></div><div class="form-item form-type-select form-item-comment-body-und-0-format">
  <label for="edit-comment-body-und-0-format--2">Text format </label>
 <select class="filter-list form-select" id="edit-comment-body-und-0-format--2" name="comment_body[und][0][format]"><option value="comments" selected="selected">Comments</option><option value="plain_text">Plain text</option></select>
</div>
<div class="filter-guidelines form-wrapper" id="edit-comment-body-und-0-format-guidelines"><div class="filter-guidelines-item filter-guidelines-comments"><h3>Comments</h3><ul class="tips"><li>Allowed HTML tags: &lt;em&gt; &lt;strong&gt; &lt;blockquote&gt; &lt;br&gt; &lt;p&gt;</li></ul></div><div class="filter-guidelines-item filter-guidelines-plain_text"><h3>Plain text</h3><ul class="tips"><li>No HTML tags allowed.</li><li>Web page addresses and e-mail addresses turn into links automatically.</li><li>Lines and paragraphs break automatically.</li></ul></div></div></div></fieldset>
</div>
<a href="#" class="publish js-publish user-comment__publishbtn">Publish</a><span class='comment-error'><a href="/penton_modal/nojs/login" class="ctools-use-modal ctools-modal-modal-popup-login" rel="nofollow">Log in or register to comment</a></span></div></div>      </div>
    </div>
  </div>
</div>
<input type="hidden" name="cid" value="" />
<input type="hidden" name="pid" value="" />
<input type="hidden" name="form_build_id" value="form-lu_SEmdShnDkga_3zcYU8xY1Cb9QScVbgG1Zf_cxgSs" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<input type="hidden" name="captcha_sid" value="117458441" />
<input type="hidden" name="captcha_token" value="22194a809912849e942eda70a3ee0621" />
<div class="element-invisible"><div class="form-actions form-wrapper" id="edit-actions"><button id="edit-submit-143369" name="op" value="Save" class="form-submit">Save</button>
</div></div><div class="url-textfield"><div class="form-item form-type-textfield form-item-url">
  <label for="edit-url">Leave this field blank </label>
 <input autocomplete="off" type="text" id="edit-url" name="url" value="" size="20" maxlength="128" class="form-text" />
</div>
</div></div></form>                <div class="comments-inner-container">
                  </div>
      </div>
    </div>
  </div>
      
    </div>

    
    <div class="row related-articles-row">
              <div class="related-articles-heading">Related</div><div class="related-articles-wrapper"><a href="/programming-languages/end-open-source-python-2-what-it-means-enterprises" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="lozad img-responsive js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/Python-code.jpg?itok=t2JCg5hC" data-src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/Python-code.jpg?itok=wO_4A01k" width="90" height="83" alt="Python found in code by magnifying glass" /></div><div class="small-article__inner"><div class="small-article__inner-title">The End of Open Source Python 2: What It Means for Enterprises</div><span>May 24, 2020</span></div></article></a><a href="/programming-languages/nodejs-14-accelerates-app-development-enhanced-features" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="lozad img-responsive js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/JavaScript-code_1.jpg?itok=gw0kZSHz" data-src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/JavaScript-code_1.jpg?itok=xgwxfQSi" width="90" height="83" alt="JavaScript code" /></div><div class="small-article__inner"><div class="small-article__inner-title">Node.js 14 Accelerates App Development with Enhanced Features</div><span>Apr 25, 2020</span></div></article></a><article class="dfp-ad-hideempty hidden n_hidden small-article" data-dfp-position="native_related"></article><a href="/programming-languages/java-14-improves-runtime-visibility-overall-performance" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="lozad img-responsive js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/java-logo.png?itok=YaTQZIRi" data-src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/java-logo.png?itok=QG1wpIjA" width="90" height="83" alt="Java logo" /></div><div class="small-article__inner"><div class="small-article__inner-title">Java 14 Improves Runtime Visibility, Overall Performance</div><span>Mar 20, 2020</span></div></article></a><a href="/programming-languages/ibm-ceases-work-server-side-swift-development" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="lozad img-responsive js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/swift-logo-hero_0.jpg?itok=5qEM3zQs" data-src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/swift-logo-hero_0.jpg?itok=qKxZGRDP" width="90" height="83" alt="Swift language logo" /></div><div class="small-article__inner"><div class="small-article__inner-title">IBM Ceases Work on Server-Side Swift Development</div><span>Jan 18, 2020</span></div></article></a></div>          </div>

    
    <div class="item-list"><ul class="lazy-pagination"><li class="read-more pagination-read-more next first"><a href="/programming-languages/end-open-source-python-2-what-it-means-enterprises?parent=143369&infscr=1" rel="nofollow">Load More</a></li>
<li class="last"><a href="/programming-languages/end-open-source-python-2-what-it-means-enterprises" rel="next">Next Article</a></li>
</ul></div>
    
  </article>

  
</section>
  </div>
</div>
  </div>

        </div>
                <div class="banner-bottom-wrapper">
          <div id="banner-bottom" class="dfp-ad-hideempty hidden">
            <div data-dfp-position="bottom_banner"></div>
          </div>
        </div>
                <!-- /Main Content Area -->
                  <!-- Footer -->
          <footer class="corporate l-footer l-footer-min">
  <div class="l-footer-inner">
    <div class="l-footer-info">
      <div class="footer-logo-min">
                  <a href="/"><img class="footer-logo-min__site_logo" src="/sites/all/themes/penton_subtheme_itprotoday/images/logos/footer.png" alt="Logo" /></a>                <div class="small-12 medium-5 columns">
          <div class="footer-links">
                      </div>
        </div>
      </div>
      <div class="footer-content">
        <ul class="footer-min-col">
          <li class="footer-min-col__item">
      <a href="/about-us" class="footer-min-col-link">About</a>    </li>
          <li class="footer-min-col__item">
      <a href="https://www.itprotoday.com/advertise-itprotodaycom" class="footer-min-col-link">Advertise</a>    </li>
          <li class="footer-min-col__item">
      <a href="/contact-us" class="footer-min-col-link">Contact Us</a>    </li>
          <li class="footer-min-col__item">
      <a href="/sitemap" class="footer-min-col-link">Sitemap</a>    </li>
          <li class="footer-min-col__item">
      <a href="http://www.penton.com/privacy-policy#ThirdPartyAdvertisingTech" class="footer-min-col-link">Ad Choices</a>    </li>
            </ul>
      <ul class="footer-min-col no-margin">
        <li class="footer-min-col__item">
      <a href="https://privacyportal-eu-cdn.onetrust.com/dsarwebform/c1f53e84-9f05-4169-a854-85052b63c50b/5f26b553-52cc-4973-a761-295d5634a6b6.html" class="footer-min-col-link">CCPA: Do not sell my personal info</a>    </li>
          <li class="footer-min-col__item">
      <a href="https://informa.com/privacy-policy" class="footer-min-col-link">Privacy Policy</a>    </li>
          <li class="footer-min-col__item">
      <a href="https://engage.informa.com/terms-of-service" class="footer-min-col-link">Terms of Service</a>    </li>
          <li class="footer-min-col__item">
      <a href="https://engage.informa.com/cp/cookie-policy/" class="footer-min-col-link">Cookie Policy</a>    </li>
  </ul>
<div class="social-min-col">
  <p class="social-min-col__label">Follow us:</p>
  <div class="social-icons"><a href="https://www.facebook.com/ITProToday/" title="" class="social-icons__link"><i aria-label="facebook" class="social-icons__icon fa fa-facebook"></i></a><a href="https://twitter.com/ITProToday" title="" class="social-icons__link"><i aria-label="twitter" class="social-icons__icon fa fa-twitter"></i></a><a href="https://www.linkedin.com/company/itpro-today/" title="" class="social-icons__link"><i aria-label="linkedin" class="social-icons__icon fa fa-linkedin"></i></a></div></div>
      </div>
    </div>
  </div>
  <div class="l-corporate-footer">
    <div class="l-corporate-footer-logo-copyrights-wrapper">
      <div class="l-corporate-footer-logo-copyrights">
        <div class="l-corporate-footer-logo">
          <a href="https://tech.informa.com/"><img src="/sites/all/themes/informa_midtheme_tech/images/corporate_footer_logo.png" alt="Informa Tech" /></a>        </div>
        <div class="l-coporate-footer-copyright">
          &#169; 2020 Informa USA, Inc., All rights reserved
        </div>
      </div>
    </div>
    <div class="l-corporate-footer-links-wrapper">
      <div class="l-coporate-footer-links">
        <ul class="links"><li class="menu-1804 first"><a href="https://informa.com/privacy-policy/" title="">Privacy Policy</a></li>
<li class="menu-1805"><a href="https://engage.informa.com/cp/cookie-policy/">Cookie Policy</a></li>
<li class="menu-1806 last"><a href="http://engage.informa.com/terms-of-service" title="">Terms of Use</a></li>
</ul>      </div>
    </div>
  </div>
</footer>
          <!-- /Footer -->
              </div>
    </div>
  </div>
</main>
<!-- /Page -->
<div id="hidden-dfp" class="dfp-ad-hideempty hidden">
  <div data-dfp-position="hidden" class="hidden-for-ads"></div>
</div>
      <script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_2MWCYVvM-5Pprylbgct4ZVgdikjpahMCPF4Yn42pc-8.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js__PiZuK2o4XAnDCWOhogiGF01gyHzeu7QxvOyfTe-YyM.js"></script>
<script type="text/javascript" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_ySyZkbOziT4GByLa86HPiLpGB0CKDqHGY5xhobIRRSY.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_jqnCeG1_d9epR-3piXLGGEj4ZKRW0wUq3e0IBpz1bsQ.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_oyPmjoXzZsox1uW00AXC6MNBBMFGGAPQTkJ8hnDMz38.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.CKEDITOR_BASEPATH = "/sites/all/modules/contrib/ckeditor/ckeditor/"
//--><!]]>
</script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_fy1xU2X7oZ4Yhv7hq2lsTUSulg0nEDLMdvWpknsYW7I.js"></script>
<script type="text/javascript" src="//video.limelight.com/player/embed.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_xht8E4BLA53oTxrfnKlXrB1kiW1yjdvRUnS5OTDFd_A.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
informaBouncexSettings = {"id":"1","property_name":"ITPro Today","colors_text_primary":"#ffffff","colors_text_secondary":"#ffffff","colors_bg_primary":"#004563","colors_bg_secondary":"#51bae6","brochure_url":"https:\/\/www.itprotoday.com","logo_url":"https:\/\/www.itprotoday.com\/sites\/all\/themes\/penton_subtheme_itprotoday\/images\/logos\/header.png","subscription_url":"https:\/\/www.itprotoday.com\/newsletters\/signup","gaViewID":"186866656","elqFormId":"1037","elqFormName":"INET_Promo_BounceXIntegration","eloquaInstance":"PentoniNET","elqSiteID":"1885539667","created":"1552499984"};
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
informaBouncexCmpgn = {"disengagement":{"step1":{"preheader":"ENTER YOUR EMAIL TO DOWNLOAD ","header":"TECHNOLOGY SALARY SURVEY FINDINGS: CURRENT COMPENSATION, FUTURE COMPENSATION","cta":"SEE SURVEY FINDINGS","ntb":"CONTINUE TO SITE"},"step2":{"preheader":"GREAT","header":"YOU NOW HAVE ACCESS TO THE FULL TECHNOLOGY SALARY SURVEY FINDINGS","cta":"SEE THE REPORT","ntb":""},"step3":{"preheader":"","header":"","cta":"","ntb":""},"offer":"ITPSalaryReport_disengagement"},"clickToCaptureDesktop":{"step1":{"preheader":"","header":"DO YOU WANT TO GET ANALYSIS AND PRO TIPS DAILY?","cta":"YES, KEEP ME UPDATED","ntb":""},"step2":{"preheader":"ENTER YOUR EMAIL TO RECEIVE","header":"INDUSTRY NEWS, PRODUCTS, FAQs, TIPS AND RESOURCES","cta":"SIGN ME UP","ntb":"CONTINUE TO SITE"},"step3":{"preheader":"GREAT","header":"YOU'LL NOW RECEIVE DAILY ANALYSIS AND PRO TIPS","cta":"CONTINUE TO SITE","ntb":""},"offer":"ITPNewsletter_Desktop"},"clickToCaptureMobile":{"step1":{"preheader":"","header":"DO YOU WANT TO GET ANALYSIS AND PRO TIPS DAILY?","cta":"YES, I WANT ACCESS","ntb":"NO, I DON'T WANT UPDATES"},"step2":{"preheader":"ENTER YOUR EMAIL TO RECEIVE","header":"INDUSTRY NEWS, PRODUCTS, FAQs, TIPS AND RESOURCES","cta":"SIGN ME UP","ntb":"CONTINUE TO SITE"},"step3":{"preheader":"GREAT","header":"YOU'LL NOW RECEIVE DAILY ANALYSIS AND PRO TIPS","cta":"CONTINUE TO SITE","ntb":""},"offer":"ITPNewsletter_Mobile"},"inlinezone":{"step1":{"preheader":"DO YOU WANT ACCESS TO","header":"2019 TECHNOLOGY SALARY SURVEY FINDINGS?","cta":"YES, UNLOCK ACCESS","ntb":"NO, NOT RIGHT NOW"},"step2":{"preheader":"ENTER YOUR EMAIL TO DOWNLOAD ","header":"TECHNOLOGY SALARY SURVEY FINDINGS: CURRENT COMPENSATION, FUTURE COMPENSATION","cta":"SEE SURVEY FINDINGS","ntb":"CONTINUE TO SITE"},"step3":{"preheader":"GREAT","header":"YOU NOW HAVE ACCESS TO THE FULL TECHNOLOGY SALARY SURVEY FINDINGS","cta":"SEE THE REPORT","ntb":""},"offer":"ITPSalaryReport_Inline"}};
//--><!]]>
</script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_Vv9NAoQ5qYRbmWv0m1HGfyHtXwChRwup7rlT_sAdeog.js"></script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_u1g3gbh6GgReBMKD_k1oMGxrQGmorRkk_tvmpqZ9HjM.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
Drupal.settings.penton_eloqua_api = {"fields":["nl","utm_rid"]};
//--><!]]>
</script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_yf2-725OwopKpdV62ovKjNnry28l9ptXrM0uCphnfoQ.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_Lj-5eVcjLMoFPN6ZEZbyb93wYzLERoGuWIhU3aIdoO8.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_Ev2a03hYfNqtDZW8vAZHfy3Nf4HzCwV9KR-zrDXM2_g.js"></script>
<script type="text/javascript">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</script>
      <script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_39wR4vuLCUZcIK_NsEhVLhl6834Dd3heLLFQ5DLVNsc.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/all/modules/contrib/ckeditor/ckeditor/ckeditor.js?qbqzon"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_9m_xgAjh9qFWglI6E8Q-86IKwJ03ylB2XoUSMu_LsNY.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_qj-GKdZLxl4IXsdVg0DKQScZYADgId6EIp1kg0dbKY4.js"></script>
    </div>
  </body>
</html>
