<!DOCTYPE html>
<html lang="en"
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#" class="html not-front not-logged-in no-sidebars page-node page-node- page-node-141420 node-type-article header-with-pillar article-article">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <meta charset="utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge, chrome=1" />
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_152x152.png" sizes="152x152" />
<link rel="shortcut icon" href="https://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_180x180.png" sizes="180x180" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_167x167.png" sizes="167x167" />
<meta name="title" content="OpenStack Foundation&#039;s StarlingX Expands Cloud Computing to the Edge" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_120x120.png" sizes="120x120" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch.png" />
<meta name="eloqua-tags" content="ITP-P-performance-management, , ITP-Journey-"/><link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_76x76.png" sizes="76x76" />
<meta name="description" content="Cloud computing resources are no long just about being at the core, as the OpenStack Foundation&#039;s StarlingX edge effort releases a major update." />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.itprotoday.com/performance-management/openstack-foundations-starlingx-20-expands-cloud-computing-edge" />
<link rel="shortlink" href="https://www.itprotoday.com/node/141420" />
<meta property="og:site_name" content="IT Pro" />
<meta property="og:type" content="article" />
<meta property="og:title" content="OpenStack Foundation&#039;s StarlingX 2.0 Expands Cloud Computing to the Edge" />
<meta property="og:description" content="Thanks to a major update to StarlingX, cloud computing resources are no longer just about being at the core." />
<meta property="og:updated_time" content="2019-09-11T18:50:02+00:00" />
<meta property="og:image" content="https://www.itprotoday.com/sites/itprotoday.com/files/cloud-computing-at-edge.jpg" />
<meta property="twitter:card" content="summary" />
<meta property="twitter:url" content="https://www.itprotoday.com/performance-management/openstack-foundations-starlingx-20-expands-cloud-computing-edge" />
<meta property="twitter:title" content="OpenStack Foundation&#039;s StarlingX 2.0 Expands Cloud Computing to the" />
<meta property="article:published_time" content="2019-09-11T18:12:35+00:00" />
<meta property="article:modified_time" content="2019-09-11T18:50:02+00:00" />
<meta property="og:audio" content="http://" />
<meta property="og:audio:secure_url" content="https://" />
<meta property="og:video:url" content="http://" />
<meta property="og:video:secure_url" content="https://" />
<meta property="og:video:type" content="text/html" />
    <title>OpenStack Foundation's StarlingX Expands Cloud Computing to the Edge | IT Pro</title>
    <link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_PpiQEI-azlEmknynFVbTW6pWwXhVPT_fbABYbBL6JWQ.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_DHcXHPYBSjIVaCQZEG4ZlpLkvslnFlBCnQUCzlbRBio.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_4GJdl2xvrwyZP8r03oU7AnszTtBYGy_ecYVYwmYoww4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_pZxsco4eNR4BBsE0WxA8VRuq3YpiLLEug_6PnA6UUQc.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_9ZJgsxVcrJK3ApK_vU9P9ZzczaRkb04dRsdUkQHuiB8.css" media="all" />

<!--[if lte IE 9]>
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_d5304rVRgE97dcoJVANw-HS6Cz-71UhME-UbNuFSgx8.css" media="all" />
<![endif]-->
    <!-- HTML5 element support for IE6-8 -->
    <!--[if lt IE 9]>
    <script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
    <![endif]-->
    <script>
      var gdpr_cookie = "off";
      // Check if cookies enabled in browser.
      var cookieEnabled = navigator.cookieEnabled;
      if (typeof navigator.cookieEnabled === 'undefined' && !cookieEnabled) {
        document.cookie = 'testCookie';
        cookieEnabled = (document.cookie.indexOf('testCookie') !== -1);
      }
      if (cookieEnabled) {
        var is_cookie = document.cookie.indexOf('penton_gdpr_cookie');
        if (is_cookie == -1) {
          console.log('gdpr cookie not set');
          // Cookie is not yet set - banner just served
          gdpr_cookie = "on";
        }
      }
      console.log('gdprCookie==>' + gdpr_cookie);
    </script>
        <script>
      var isblocked = "notblocked";
      console.log('lpage==>' + isblocked);
      var pathname = window.location.pathname;
      var adu = "/3834/itprotoday.home/article/cloud_computing/performance_management";
      var adblockOn = 1;
    </script>
    <script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
    <script>
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
    </script>
    <script>
      if (adu !== "" && (pathname.indexOf('/cart') < 0) && (pathname.indexOf('/store') < 0) && (pathname.indexOf('/products') < 0) && (pathname.indexOf('/product-types') < 0) && (pathname.indexOf('/store-topics') < 0) && ((pathname.indexOf('/gallery')) !== (pathname.length - 8)) && (pathname.indexOf('/user/login') < 0) && (isblocked == "notblocked") && (pathname.indexOf('penton_ur_thank_you') < 0)) {
        var targ_arr = JSON.parse('[{"target":"pos","value":"728_1_a"},{"target":"combo","value":"wrap"},{"target":"ptype","value":"Article"},{"target":"nid","value":"141420"},{"target":"pterm","value":"performance_management"},{"target":"author","value":"sean_michael_kerner"},{"target":"reg","value":"anonymous"}]');
        googletag.cmd.push(function() {
          if (gdpr_cookie == "off") {
            googletag.pubads().setRequestNonPersonalizedAds(0);
          } else if (gdpr_cookie == "on") {
            googletag.pubads().setRequestNonPersonalizedAds(1);
          }
          var welcome_ad = googletag.defineSlot(adu, [1, 1], "div-interstitial");
          welcome_ad.addService(googletag.pubads());
          welcome_ad.setTargeting("pos", "interstitial_a");
          welcome_ad.setTargeting("gdpr_banner", gdpr_cookie);
          for (var i=0; i<targ_arr.length; i++) {
            var targ = targ_arr[i]['target'];
            var val = targ_arr[i]['value'].split(',');
            if (targ !== 'pos' && targ !== 'combo') {
              welcome_ad.setTargeting(targ, val);
            }
          }

          setTimeout(function() {
            console.log('adblockval');console.log(adblockOn);
            if(adblockOn == 1) {
              var bDiv = document.getElementById("body-wrapper");
              window.scrollTo(0, 0);
              if(bDiv.style.removeProperty) {
                bDiv.style.removeProperty('opacity');
              } else {
                bDiv.style.removeAttribute('opacity');
              }
            }
          }, 2000);

          googletag.pubads().addEventListener('slotRenderEnded', function(event) {
            adblockOn = 0;
            if(event.slot.getSlotElementId() == "div-interstitial") {
              if(event.isEmpty) {
                console.log('emptyInterstitial');
                var bDiv = document.getElementById("body-wrapper");
                window.scrollTo(0, 0);
                if(bDiv.style.removeProperty) {
                  bDiv.style.removeProperty('opacity');
                } else {
                  bDiv.style.removeAttribute('opacity');
                }
              } else {
                console.log('notemptyInterstitial');
              }

              var dfplogpatt = new RegExp('dfp_log');
              var isDebug = dfplogpatt.test(location.search);
              if(isDebug) {
                console.log('%c********DFPTag: Interstitial********', 'font-size:medium;font-style:bold');
                console.log('adunit: '+adu);
                if (gdpr_cookie == "off") {
                  console.log('nonpersonalized ads: 0');
                } else if (gdpr_cookie == "on") {
                  console.log('nonpersonalized ads: 1');
                }
                console.log('targetingpair==> pos:interstitial_a');
                console.log('targetingpair==> gdpr_banner:'+gdpr_cookie);
                for(var i=0; i<targ_arr.length; i++) {
                  var targ = targ_arr[i]['target'];
                  var val = targ_arr[i]['value'].split(',');
                  if(targ !== 'pos' && targ !== 'combo') {
                    console.log('targetingpair==> '+targ+':'+val);
                  }
                }
                console.log('adsize: [1, 1]');
                console.log('oop: false');
                console.log('%c************************************', 'font-size:medium;font-style:bold');
              }
            }
          });
          googletag.enableServices();
        });
      }
    </script>
      </head>
  <body>
        <div id="wl_flogop_div" class="hidden">https://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/footer.png</div>
    <div id="div-interstitial">
      <script>
        if(adu !== "" && (pathname.indexOf('/cart') < 0) && (pathname.indexOf('/store') < 0) && (pathname.indexOf('/products') < 0) && (pathname.indexOf('/product-types') < 0) && (pathname.indexOf('/store-topics') < 0) && ((pathname.indexOf('/gallery')) !== (pathname.length - 8)) && (pathname.indexOf('/user/login') < 0) && (isblocked == "notblocked") && (pathname.indexOf('penton_ur_thank_you') < 0)  ) {
          googletag.cmd.push(function() {
            googletag.display("div-interstitial");
          });
        }
      </script>
    </div>
        <div id="body-wrapper"  style="opacity:0;" >
            <header class="header js-header">
  <a id="skip-navigation" href="#main_content">Skip navigation</a>
  <!-- Pillar Navigation region -->
<nav class="pillar-nav">
<div id="block-penton-informa-banner-penton-informa-banner" class="block block-penton-informa-banner">

    
  <div class="content">
    <div id="iribbon-container">
    <button id="iribbon-title" title="show/hide">Informa</button>
    <div id="iribbon-detail" class="ribbon-hide">
        <div id="iribbon-left">
            <p>IT Pro Today is part of the Informa Tech Division of Informa PLC</p>
            <ul>
                <li class="iribbon-mainlink"><a href="http://informa.com/">Informa PLC</a></li>
                <li><a href="http://informa.com/About-Us/">About us</a></li>
                <li><a href="http://informa.com/Investors/">Investor relations</a></li>
                <li><a href="http://informa.com/Talent/">Talent</a></li>
            </ul>
        </div>
        <div id="iribbon-right">
            <p>This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them. Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.</p>
        </div>
    </div>
</div>  </div>
</div>
<div id="block-menu-menu-pillar-navigation" class="pillar-nav__inner l-content clearfix">
  <div class="pillar-nav__header">Discover:</div>
  <ul class="pillar-nav__items js-menumore-discover"><li class="pillar-nav__item js-menumore-item-text  "><a href="https://www.blackhat.com/">Black Hat</a></li>
<li class="pillar-nav__item js-menumore-item-text  "><a href="https://www.interop.com/?_mc=hsad_x_itpro_le_aud_intplv_x_x-itpro-discbar">Interop</a></li>
<li class="pillar-nav__item js-menumore-item-text pillar-nav__item--event "><a href="https://tmt.knect365.com/iot-world/?utm_source=ITPMedia&amp;utm_medium=website&amp;utm_campaign=eyebrow-link">IoT World</a></li>
<li class="pillar-nav__item js-menumore-item-text  "><a href="https://afcom.com/Public/Leaders_Labs/Public/Leaders_Labs/About_Leaders_Labs/Leaders_Labs.aspx?hkey=842624e7-2596-4ceb-ba12-9f2ee91469a7">AFCOM Leaders Lab</a></li>
<li class="pillar-nav__item js-menumore-item-text pillar-nav__item--event "><a href="https://afcom.com/Public/Leaders_Labs/Public/Leaders_Labs/About_Leaders_Labs/Leaders_Labs.aspx?hkey=842624e7-2596-4ceb-ba12-9f2ee91469a7">Leaders lab</a></li>

    <li class="pillar-nav__item pillar-more js-menumore-more-item">
      <a class="pillar-more-btn">More<i class="fa fa-caret-down"></i></a>
      <ul class="pillar-list-nested js-menumore-sub"></ul>
    </li>
  </ul></div>
</nav>
<!-- /Pillar Navigation region -->
  <!-- Header -->
  <div class="header-inner l-content">
    <!-- Hamburger menu -->
<div class="menu-toggler js-ham-menu-toggler">
  <a href="#menu" class="menu-toggler-img-wrap js-menu-toggler">
    <div class="menu-toggler-hamburger">
      <div class="hamburger-text">Menu</div>
      <div class="hamburger-line"></div>
      <div class="hamburger-line"></div>
      <div class="hamburger-line"></div>
    </div>
  </a>
  <aside class="hamburger-menu">
    <div class="hamburger-menu-inner clearfix js-toggle-menu js-sticky-ham-menu">
      <div class="hamburger-menu-container">
                  <div class="user-thumb-text">
            <a href="/penton_modal/nojs/login" class="ctools-use-modal sattelite-event-caller sattelite-event-caller__hamburger-clicked ctools-modal-modal-popup-login" rel="nofollow">Log In</a> or <a href="/penton_modal/nojs/register/basic" class="ctools-use-modal sattelite-event-caller sattelite-event-caller__hamburger-clicked ctools-modal-modal-popup-medium" rel="nofollow">Register</a>          </div>
                <ul class="hamburger-menu-nav"><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/next-gen" title="">Next Gen</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/collaboration" title="">Collaboration</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/cloud-computing-0" title="">Cloud Computing</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/compute-engines" title="">Compute Engines</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/data-analytics-and-data-management" title="">Data Analytics and Data Management</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/data-center" title="">Data Center</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/devops-and-software-development" title="">DevOps and Software Development</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/mobility" title="">Mobility</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/security" title="">Security</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/storage" title="">Storage</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/windows-and-user-productivity" title="">Windows and User Productivity</a></li></ul><ul class="hamburger-menu-sub-nav"><li class="hamburger-menu-sub-nav__item"><a href="/industry-perspectives" title="">Industry Perspectives</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://www.itprotoday.com/it-buyers-guides" title="">Buyer’s guides</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://www.itprotoday.com/it-top-10-reports" title="">Top 10 reports</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://www.itprotoday.com/special-reports-it-tech-shaping-tomorrow" title="">Special reports</a></li><li class="hamburger-menu-sub-nav__item"><a href="/webinar-0" title="">Webinars</a></li><li class="hamburger-menu-sub-nav__item"><a href="/whitepapers" title="">Whitepapers</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://www.itprotoday.com/business-resources/technology-providers-company-profiles" title="">Technology Provider</a></li><li class="hamburger-menu-sub-nav__item"><a href="/business-resources" title="">Business Resources</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://afcom.com/Public/Leaders_Labs/Public/Leaders_Labs/About_Leaders_Labs/Leaders_Labs.aspx?hkey=842624e7-2596-4ceb-ba12-9f2ee91469a7" title="">AFCOM Leaders Lab</a></li><li class="hamburger-menu-sub-nav__item"><a href="/newsletters/signup" title="">Newsletter Preference</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://www.itprotoday.com/advertise-itprotodaycom" title="">Advertise</a></li><li class="hamburger-menu-sub-nav__item"><a href="/about-us" title="">About Us</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://knect365.com/privacy-policy" title="">Privacy Policy</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://www.penton.com/terms-of-service/" title="">Terms of Service</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://corporate.knect365.com/privacy-centre/our-cookie-policy/" title="">Cookie Policy</a></li></ul><div class="social-icons"><a href="https://www.facebook.com/ITProToday/" title="" class="social-icons__link"><i aria-label="facebook" class="social-icons__icon fa fa-facebook"></i></a><a href="https://twitter.com/ITProToday" title="" class="social-icons__link"><i aria-label="twitter" class="social-icons__icon fa fa-twitter"></i></a><a href="https://www.linkedin.com/company/itpro-today/" title="" class="social-icons__link"><i aria-label="linkedin" class="social-icons__icon fa fa-linkedin"></i></a></div>              </div>
    </div>
  </aside>
</div>
<!-- /Hamburger menu -->
    <!-- Header Logo -->
    <div class="header-logo">
                      <a href="/" class="header-logo__link"><img src="https://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/header.png" alt="IT Pro" title="IT Pro" /></a>                  </div>
    <!-- /Header Logo -->
          <!-- Header User links -->
      <ul class="header-nav">
                  <li class="header-nav__item header-nav__item__search">
            <a href="/search" class="header-nav-link"><i class="fa fa-search"></i>Search</a>          </li>
                          <li class="header-nav__item no-mobile">
            <a href="/penton_modal/nojs/login" class="ctools-use-modal ctools-modal-modal-popup-login header-nav-link" rel="nofollow">Log In</a>          </li>
          <li class="header-nav__item no-mobile last">
            <a href="/penton_modal/nojs/register/basic" class="ctools-use-modal ctools-modal-modal-popup-medium header-nav-link sattelite-event-caller sattelite-event-caller__header-clicked" rel="nofollow">Register</a>          </li>
                <!-- Cart -->
                <!-- /Cart -->
      </ul>
      </div>

  <!-- legal communication alert -->
  <div class="js-penton-legal-comm-ajax-output-alert">
      </div>
  <!-- /legal communication alert -->
<!-- /Header -->
</header>
<!-- Page -->
<main>
  <div id="page-wraper">
    <!-- Header Adv -->
    <div class="banner-top-wrapper">
      <div id="banner-top" class="dfp-ad-hideempty hidden">
        <div data-dfp-position="top_banner"></div>
      </div>
    </div>
        <!-- Admin Tabs -->
          <section id="admin-tabs" class="l-content">
              </section>
        <!-- /Admin Tabs -->
    <!-- /Header Adv -->
    <div class="wrapper l-content">
                                <!-- Sidebar -->
        <aside id="sidebar" class="l-sidebar sidebar">
            <div class="region region-left-col">
          <div class="slide-out-sidebar-button js-expand-sidebar">
        <span class="slide-out-recent">Recent</span>
      </div>
        <div class="sidebar-wrapper sidebar-scrollable js-sticky-leftcol">
      <section id="penton_recent_content_block">
  <aside>
    <div class="r-a-header">Recent</div>
                
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/uptime/can-data-center-outage-database-help-prevent-outages">
            Can a Data Center Outage Database Help Prevent Outages?            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Sep 12, 2019</span>        </span>
          </div>
  </div>
</article>
                  <div data-dfp-position="native_leftrail_1" class="dfp-ad-hideempty hidden n_hidden n_leftrail1_2"></div>
            
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/edge-computing/edge-computing-where-s-edge-moving-now-nokia-offers-clues">
            Edge Computing: Where’s the Edge Moving to Now? Nokia Offers Clues            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Sep 12, 2019</span>        </span>
          </div>
  </div>
</article>
            <div class="banner-aside-wrapper dfp-ad-hideempty">
      <div class="banner-aside js-sticky-banner dfp-ad-hideempty hidden">
        <div data-dfp-position="left_rail_rect"></div>
      </div>
    </div>
    <hr>
                    
<article class="article-teaser article-teaser__icon__gallery article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/windows-10/windows-10-20h1-software-development-kit-sdk-build-tracker">
            Windows 10 20H1 Software Development Kit (SDK) Build Tracker            <i class="fa fa-camera"></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Sep 11, 2019</span>        </span>
          </div>
  </div>
</article>
                  <div data-dfp-position="native_leftrail_2" class="dfp-ad-hideempty hidden n_hidden n_leftrail1_2"></div>
            
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/programming-languages/enterprise-java-evolves-release-jakarta-ee-8-specs">
            Enterprise Java Evolves With Release of Jakarta EE 8 Specs            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Sep 10, 2019</span>        </span>
          </div>
  </div>
</article>
                
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/threat-management/latest-data-center-network-security-strategies-revolve-around-intelligence">
            Latest Data Center Network Security Strategies Revolve Around Intelligence            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Sep 10, 2019</span>        </span>
          </div>
  </div>
</article>
      </aside>
</section>


<section id="penton_featured_content_block">
  <aside>
    <div class="r-a-header">Featured</div>
          
<article class="article-teaser article-teaser__no-img article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/windows-78/windows-7-10-migration-tools-buyer-s-guide">
            Windows 7 to 10 Migration Tools Buyer’s Guide            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jun 17, 2019</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/devops-and-software-development/5-key-it-skills-new-decade">
            5 Key IT Skills for the New Decade            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jun 27, 2019</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/nassan/spectra-logic-promises-better-storage-inactive-data">
            Spectra Logic Promises Better Storage for Inactive Data            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Sep 10, 2019</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__gallery article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/windows-server/windows-server-vnext-20h1-build-tracker">
            Windows Server vNext (20H1) Build Tracker            <i class="fa fa-camera"></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Sep 10, 2019</span>        </span>
          </div>
  </div>
</article>
      </aside>
</section>
    </div>
  </div>
        </aside>
        <!-- /Sidebar -->
            <!-- Main Content Area -->
      <div class="page main-area l-main-area">
        <div id="main_content" class="clearfix" tabindex="-1">
          
            <div class="region region-main-col">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <section class="main-articles-container js-lazy-pager-wrapper">

    <article itemscope itemtype="http://schema.org/NewsArticle" class=" big-article article-type-article article-141420 node-type-article with-feat-img article-standalone js-lazy-pager-content"  data-nid="141420" data-url="/performance-management/openstack-foundations-starlingx-20-expands-cloud-computing-edge" data-title="OpenStack Foundation&#039;s StarlingX 2.0 Expands Cloud Computing to the Edge" data-seo-title="OpenStack Foundation&#039;s StarlingX Expands Cloud Computing to the Edge" data-type="article" data-terms="cloud_computing/performance_management" data-ptermhier="Cloud Computing &gt; Performance Management" data-pterm="Performance Management" data-sterm="" data-program="" data-tax="Performance Management" data-buyersjourney="Purchase / Intent" data-ext="" data-author="Sean Michael Kerner" data-pub="Sep 11, 2019" data-visibility="visible" data-perm="public" data-pid="3af9c170-a8d6-45b0-8651-89744afedb4b" data-contentSponsor="" data-content="">
    <meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.itprotoday.com/performance-management/openstack-foundations-starlingx-20-expands-cloud-computing-edge"/>
    <meta itemprop="datePublished" content="2019-09-11T18:04:00+00:00"/>    <meta itemprop="dateModified" content="2019-09-11T18:50:02+00:00"/>
              <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
          <meta itemprop="url" content="https://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/header.png">
          <meta itemprop="width" content="980">
          <meta itemprop="height" content="173">
        </div>
        <meta itemprop="name" content="IT Pro">
      </div>
    
    
    <div class="big-article__top">

      
              <div class="big-article__image" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
          <img class="medium js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_featured_retina/public/cloud-computing-at-edge.jpg?itok=q5Jiqhof" src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_featured_standard/public/cloud-computing-at-edge.jpg?itok=PNj52s_b" width="770" height="400" alt="cloud computing at the edge" title="cloud computing at the edge" />          <meta itemprop="url" content="https://www.itprotoday.com/sites/itprotoday.com/files/cloud-computing-at-edge.jpg">
          <meta itemprop="width" content="1540">
          <meta itemprop="height" content="802">

                      <span class="text-to-image">Getty Images</span>
                  </div>
              
      <div class="big-article__head row">
        <div class="heading ">
                    <div class="breadcrumbs"><span class="parent-category"><a href="/cloud-computing-0">Cloud Computing</a><span>&gt;</span></span><a href="/cloud-computing/performance-management">Performance Management</a></div>          <h1 itemprop="headline">OpenStack Foundation&#039;s StarlingX 2.0 Expands Cloud Computing to the Edge</h1>
                      <div itemprop="description">
              
  <div class="field field-name-field-penton-content-summary field-type-text-long field-label-hidden">
    Thanks to a major update to StarlingX, cloud computing resources are no longer just about being at the core.  </div>
            </div>
                                <p class="author-and-date" itemprop="author" itemscope="" itemtype="https://schema.org/Person"><span itemprop="name"><a href="/author/Sean-Kerner" itemprop="url">Sean Michael Kerner</a></span> | <span class="date-display-single">Sep 11, 2019</span></p>
                  </div>
      </div>

      
    </div>

              <div class="share-icons">
            <a href="/penton_modal/nojs/print/141420"
         class="print ctools-use-modal ctools-modal-modal-popup-basic"
         rel="nofollow">
        <i aria-label="print" class="fa fa-print"></i>
      </a>
          <a href="/penton_modal/nojs/forward/141420/0"
         class="envelope ctools-use-modal ctools-modal-modal-popup-basic-email"
         rel="nofollow">
        <i aria-label="email" class="fa fa-envelope"></i>
      </a>
                  <a href="https://www.facebook.com/sharer.php?u=https://www.itprotoday.com/performance-management/openstack-foundations-starlingx-20-expands-cloud-computing-edge&amp;t=OpenStack Foundation's StarlingX 2.0 Expands Cloud Computing to the Edge"
         class="facebook"
         target="_blank">
        <i aria-label="facebook" class="fa fa-facebook"></i>
      </a>
                <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.itprotoday.com/performance-management/openstack-foundations-starlingx-20-expands-cloud-computing-edge&amp;title=OpenStack Foundation's StarlingX 2.0 Expands Cloud Computing to the Edge&amp;summary=The OpenStack Foundation's StarlingX has reached another major milestone, with the 2.0 release of the edge computing platform project.&amp;source=IT Pro"
         class="linkedin"
         target="_blank">
        <i aria-label="linkedin" class="fa fa-linkedin"></i>
      </a>
                <a href="https://twitter.com/share?url=https://www.itprotoday.com/performance-management/openstack-foundations-starlingx-20-expands-cloud-computing-edge&amp;text=OpenStack Foundation's StarlingX 2.0 Expands Cloud Computing to the Edge"
         class="twitter"
         target="_blank">
        <i aria-label="twitter" class="fa fa-twitter"></i>
      </a>
                <a href="https://pinterest.com/pin/create/button/?url=https://www.itprotoday.com/performance-management/openstack-foundations-starlingx-20-expands-cloud-computing-edge&amp;description=The OpenStack Foundation's StarlingX has reached another major milestone, with the 2.0 release of the edge computing platform project.&amp;media="
         class="pinterest"
         target="_blank">
        <i aria-label="pinterest" class="fa fa-pinterest"></i>
      </a>
              <a class="pinterest"
           target="_blank">
           <i aria-label="pinterest" class="fa fa-pinterest"></i>
        </a>
            </div>

              
    
    <div class="article-content-wrap">
      
      <div itemprop="articleBody" class="article-content ">
                  <div class="article-banner dfp-ad-hideempty hidden">
            <div data-dfp-position="inarticle1"></div>
          </div>
                
        <p><span style="color:black">The OpenStack Foundation's StarlingX has reached another major milestone, with the 2.0 release of the edge computing platform project.</span></p>

<p><span style="color:black">Based on code contribution from Wind River Systems, StarlingX <a href="https://www.itprotoday.com/linux/openstack-foundation-says-its-open-source-edge-platform-starlingx-ready-fly" style="text-decoration:underline"><u>debuted</u></a> in late 2018 to enable the development and deployment of edge computing cloud software infrastructure. The basic premise behind <a href="https://www.itprotoday.com/edge-computing/edge-computing-att-says-edge-isn-t-where-you-think-it" style="text-decoration:underline">edge computing</a> is that compute power is deployed at the edges of the network, be that a 5G cellular base station, remote location or small branch. With the StarlingX 2.0 update, a key new addition is the integration of the <a href="https://www.itprotoday.com/containers/ibms-new-open-source-kabanero-promises-simplify-kubernetes-devops" style="text-decoration:underline">Kubernetes</a> container orchestration engine, making it easier for users to use containers in edge deployments.</span></p>

<p><span style="color:black">"The platform went through a drastic change with the transformation to leverage the benefits of using container technologies," Ildiko Vancsa, ecosystem technical lead at the OpenStack Foundation, told ITPro Today. "The community has been working hard since the 1.0 release to build an open infrastructure solution for edge and IoT [internet of things] use cases … utilizing multiple well-known open-source components."</span></p>

<p><span style="color:black">With version 2.0, the platform integrates OpenStack and Kubernetes components using services from <a href="https://www.airshipit.org/" style="text-decoration:underline target=_blank target=_blank" target="_blank"><u>Airship</u></a> to achieve flexibility as well as robustness and to be an instrumental part of the evolution of cloud computing toward the edge, according to Vancsa. Airship, another OpenStack Foundation effort, is enables automated cloud provisioning. The OpenStack cloud computing services themselves are also running in containers starting from the 2.0 release, to further ease deployment and improve manageability of the control plane services, she added. </span></p>

<p><span style="color:black">While the main focus of the latest release cycle is containerization, the community also added new functionality and improvements to the platform—for example, support for Trusted Platform Module (TPM) devices to store secrets as well as UEFI secure boot capability for enhanced security, Vancsa said. AIso added was support for Precision Time Protocol (PTP) to provide a way to distribute and align a highly accurate clock around a factory or a telecom network area where Network Time Protocol (NTP) is not accurate enough.</span></p>

<p><span style="color:black">Glenn Seiler, vice president of open source strategy at Wind River Systems, told ITPro Today that the other big effort in StarlingX 2.0 was to upgrade to the Stein release <a href="https://www.openstack.org/software/stein/" style="text-decoration:underline">Stein release</a> of OpenStack, which was announced in April. He noted that the previous release of StarlingX was on the OpenStack Pike release and carried a lot of technical debt and patches to Pike. With StarlingX 2.0, the project now uses a “vanilla” OpenStack without the technical debt of patches.</span></p>

<h2><span style="color:black"><strong>OpenStack No Longer Required?</strong></span></h2>

<p><span style="color:black">While StarlingX is part of the OpenStack Foundation, with the 2.0 release, OpenStack as a cloud platform is no longer a required component for deployment. Organizations can deploy container workloads on bare metal without OpenStack, Seiler said. If someone wants to run virtual machines (VMs), StarlingX puts the OpenStack services and VMs in containers, he added.</span></p>

<p><span style="color:black">"That said, there are some OpenStack-based services that remain on the controller—such as Keystone for security keys, Horizon is used for the admin interface," Seiler said. "But there isn’t any OpenStack dependency on container workloads."</span></p>

<h2><span style="color:black"><strong>Edge Computing</strong></span></h2>

<p><span style="color:black">The number of edge computing efforts for cloud is growing as different groups try to carve out a position in the nascent space. According to Seiler, one of the big differentiators with StarlingX is that it is preintegrated and all dependencies, versioning and testing are already performed. He noted that a lot of projects define or provide “reference platforms,” and they may do some integration testing/validation. But those projects typically leave a lot of the details of configuration of components up to the user.</span></p>

<p><span style="color:black">"StarlingX takes preintegrated to the point where it truly is deployment-ready,” he said.</span></p>

<p><span style="color:black">Looking forward, StarlingX will at some point become the basis of a commercial offering that Wind River is developing.</span></p>

<h2><span style="color:black"><strong>What's Next for StarlingX?</strong></span></h2>

<p><span style="color:black">With the 2.0 release available, attention now turns to the future development of StarlingX. One key future development is that the next set of StarlingX releases will come out in shorter time frames.</span></p>

<p><span style="color:black">Vancsa said that the StarlingX community is working on making the 3.0 release available later this year. After 3.0, she said the StarlingX community will have two releases per year, following a cycle-trailing model relative to the OpenStack release cycle. </span></p>

<p><span style="color:black">"The community is also putting a lot of emphasis on thorough testing, including sanity and robustness testing, and looking into performance testing options too," she said. "StarlingX is a very friendly and open community which is still growing and looking for participation and feedback from anyone who is interested in the platform or the use cases it is designed to provide a solution for."</span></p>

        
                                        </div>

      
      
              
  <div class="comments-wrapper" id="comments-141420">
    <div class="comments">
      <a href="javascript:void(0)" class="comments--show hidden">0 comments</a>    </div>
    <div class="comments-container">
      <div class="fill-comments">
        <div class="comments-header"><span class="comments--hide">Hide comments</span></div>
                  <form class="comment-form" action="/comment/reply/141420" method="post" id="comment-form" accept-charset="UTF-8"><div><div class="user-comment-body">
  <div class="user-comment-field">
    <div class="user-photo">
      <img class="user-thumb-img" src="https://www.itprotoday.com/sites/all/themes/penton_core_theme/images/account-default-image.png" alt="" />    </div>
    <div class="user-content">
      <div class="user-name">
        <a href="/" class="js-penton-user-url-profile"></a>      </div>
      <div class="user-comment">
        <div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="comment_body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label class="element-invisible" for="edit-comment-body-141420">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full ckeditor-mod form-textarea required" placeholder="Be the first to comment..." id="edit-comment-body-141420" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
<a class="ckeditor_links" style="display:none" href="javascript:void(0);" onclick="javascript:Drupal.ckeditorToggle(['edit-comment-body-141420'],'Switch to plain text editor','Switch to rich text editor');" id="switch_edit-comment-body-141420">Switch to plain text editor</a><fieldset class="filter-wrapper element-invisible form-wrapper" id="edit-comment-body-und-0-format"><div class="fieldset-wrapper"><div class="filter-help form-wrapper" id="edit-comment-body-und-0-format-help"><p><a href="/filter/tips" target="_blank">More information about text formats</a></p></div><div class="form-item form-type-select form-item-comment-body-und-0-format">
  <label for="edit-comment-body-und-0-format--2">Text format </label>
 <select class="filter-list form-select" id="edit-comment-body-und-0-format--2" name="comment_body[und][0][format]"><option value="comments" selected="selected">Comments</option><option value="plain_text">Plain text</option></select>
</div>
<div class="filter-guidelines form-wrapper" id="edit-comment-body-und-0-format-guidelines"><div class="filter-guidelines-item filter-guidelines-comments"><h3>Comments</h3><ul class="tips"><li>Allowed HTML tags: &lt;em&gt; &lt;strong&gt; &lt;blockquote&gt; &lt;br&gt; &lt;p&gt;</li></ul></div><div class="filter-guidelines-item filter-guidelines-plain_text"><h3>Plain text</h3><ul class="tips"><li>No HTML tags allowed.</li><li>Web page addresses and e-mail addresses turn into links automatically.</li><li>Lines and paragraphs break automatically.</li></ul></div></div></div></fieldset>
</div>
<a href="#" class="publish js-publish user-comment__publishbtn">Publish</a><span class='comment-error'><a href="/penton_modal/nojs/login" class="ctools-use-modal ctools-modal-modal-popup-login" rel="nofollow">Log in or register to comment</a></span></div></div>      </div>
    </div>
  </div>
</div>
<input type="hidden" name="cid" value="" />
<input type="hidden" name="pid" value="" />
<input type="hidden" name="form_build_id" value="form-dK8TF-CDcKBCs9FbvTuKXnSnaxvHrA2ExFKtUZJhV6U" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<input type="hidden" name="captcha_sid" value="91981548" />
<input type="hidden" name="captcha_token" value="3835ba430291a440cc923c2acc011263" />
<div class="element-invisible"><div class="form-actions form-wrapper" id="edit-actions"><button id="edit-submit-141420" name="op" value="Save" class="form-submit">Save</button>
</div></div><div class="url-textfield"><div class="form-item form-type-textfield form-item-url">
  <label for="edit-url">Leave this field blank </label>
 <input autocomplete="off" type="text" id="edit-url" name="url" value="" size="20" maxlength="128" class="form-text" />
</div>
</div></div></form>                <div class="comments-inner-container">
                  </div>
      </div>
    </div>
  </div>
      
    </div>

    
    <div class="row related-articles-row">
              <div class="related-articles-heading">Related</div><div class="related-articles-wrapper"><a href="/iaaspaas/aws-summit-nyc-observability-developer-productivity-highlighted" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/Werner-Vogels-AWS-Summit-NYC-3_0.jpg?itok=JL0XAlK8" src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/Werner-Vogels-AWS-Summit-NYC-3_0.jpg?itok=anYCHaZ3" width="90" height="83" alt="AWS Chief Technology Officer Werner Vogels speaking on stage at AWS Summit NYC 2019" /></div><div class="small-article__inner"><div class="small-article__inner-title">AWS Summit NYC: Observability, Developer Productivity Highlighted</div><span>Jul 12, 2019</span></div></article></a><a href="/performance-management/top-10-cloud-management-platforms-0" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/Cloud-management-conceptual.jpg?itok=TjnE3s7I" src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/Cloud-management-conceptual.jpg?itok=iQHxDXQ3" width="90" height="83" alt="Cloud computing concept art" /></div><div class="small-article__inner"><div class="small-article__inner-title">Top 10 Cloud Management Platforms</div><span>Jun 28, 2019</span></div></article></a><article class="dfp-ad-hideempty hidden n_hidden small-article" data-dfp-position="native_related"></article><a href="/performance-management/top-10-cloud-management-platforms" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/Cloud-management-conceptual.jpg?itok=TjnE3s7I" src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/Cloud-management-conceptual.jpg?itok=iQHxDXQ3" width="90" height="83" alt="Cloud computing concept art" /></div><div class="small-article__inner"><div class="small-article__inner-title">The Top 10 Cloud Management Platforms</div><span>Jun 26, 2019</span></div></article></a><a href="/performance-management/9-cloud-dashboards-check-when-your-cloud-goes-down" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/GettyImages-912000448.jpg?itok=AcAeuor8" src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/GettyImages-912000448.jpg?itok=8C9jOeVM" width="90" height="83" alt="A dimly lit data center representing an outage" /></div><div class="small-article__inner"><div class="small-article__inner-title">9 Cloud Dashboards to Check When Your Cloud Goes Down</div><span>Jun 05, 2019</span></div></article></a></div>          </div>

    
    <div class="item-list"><ul class="lazy-pagination"><li class="read-more pagination-read-more next first"><a href="/performance-management/top-10-cloud-management-platforms-0?parent=141420&infscr=1" rel="nofollow">Load More</a></li>
<li class="last"><a href="/performance-management/top-10-cloud-management-platforms-0" rel="next">Next Article</a></li>
</ul></div>
    
  </article>

  
</section>
  </div>
</div>
  </div>

        </div>
                <div class="banner-bottom-wrapper">
          <div id="banner-bottom" class="dfp-ad-hideempty hidden">
            <div data-dfp-position="bottom_banner"></div>
          </div>
        </div>
                <!-- /Main Content Area -->
                  <!-- Footer -->
          <!-- Check to see if we are in the store -->
  <footer class="l-footer l-footer-min ">
    <div class="l-footer-inner">
      <div class="l-footer-info">
        <div class="footer-logo-min">
                      <a href="/"><img class="footer-logo-min__site_logo" src="https://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/footer.png" alt="Logo" /></a>                    <div class="small-12 medium-5 columns">
            <div class="footer-links">
                            <a href="https://informa.com/"><img src="/sites/all/themes/penton_core_theme/images/powered_by_informa_businessline.png" alt="Powered by Informa" /></a>            </div>
          </div>
        </div>
        <ul class="footer-min-col">
          <li class="footer-min-col__item">
      <a href="/about-us" class="footer-min-col-link">About</a>    </li>
          <li class="footer-min-col__item">
      <a href="https://www.itprotoday.com/advertise-itprotodaycom" class="footer-min-col-link">Advertise</a>    </li>
          <li class="footer-min-col__item">
      <a href="/contact-us" class="footer-min-col-link">Contact Us</a>    </li>
          <li class="footer-min-col__item">
      <a href="/sitemap" class="footer-min-col-link">Sitemap</a>    </li>
            </ul>
      <ul class="footer-min-col no-margin">
        <li class="footer-min-col__item">
      <a href="http://www.penton.com/privacy-policy#ThirdPartyAdvertisingTech" class="footer-min-col-link">Ad Choices</a>    </li>
          <li class="footer-min-col__item">
      <a href="https://informa.com/privacy-policy/" class="footer-min-col-link">Privacy Policy</a>    </li>
          <li class="footer-min-col__item">
      <a href="http://engage.informa.com/terms-of-service" class="footer-min-col-link">Terms of Service</a>    </li>
          <li class="footer-min-col__item">
      <a href="https://engage.informa.com/cp/cookie-policy/" class="footer-min-col-link">Cookie Policy</a>    </li>
  </ul>
<div class="social-min-col">
  <p class="social-min-col__label">Follow us:</p>
  <div class="social-icons"><a href="https://www.facebook.com/ITProToday/" title="" class="social-icons__link"><i aria-label="facebook" class="social-icons__icon fa fa-facebook"></i></a><a href="https://twitter.com/ITProToday" title="" class="social-icons__link"><i aria-label="twitter" class="social-icons__icon fa fa-twitter"></i></a><a href="https://www.linkedin.com/company/itpro-today/" title="" class="social-icons__link"><i aria-label="linkedin" class="social-icons__icon fa fa-linkedin"></i></a></div></div>
      </div>
      <div class="l-footer-rights">
        <span class="copyrights">
          &#169; 2019 Informa USA, Inc., All Rights Reserved
        </span>
      </div>
    </div>
  </footer>
          <!-- /Footer -->
              </div>
    </div>
  </div>
</main>
<!-- /Page -->
<div id="hidden-dfp" class="dfp-ad-hideempty hidden">
  <div data-dfp-position="hidden" class="hidden-for-ads"></div>
</div>
      <script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js__PiZuK2o4XAnDCWOhogiGF01gyHzeu7QxvOyfTe-YyM.js"></script>
<script type="text/javascript" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_s3L_uC35AiN5EGYY533su-jccnLRp2aKpOnjgPLbo34.js"></script>
<script type="text/javascript" src="//assets.adobedtm.com/2ebe67d2ca0193084439038012c34f9112a85c00/satelliteLib-48191dfa1509ee2d203e3f6eb4bc8a3de3320ce9.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_aqDLL_44zBARAgd_FTblZWchUi73E-YeDLd8oMO1dX0.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_IWtAbZDjS48PA0DidE1pvGP-2jegwgb_jS2CEiOsTt0.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.CKEDITOR_BASEPATH = "/sites/all/modules/contrib/ckeditor/ckeditor/"
//--><!]]>
</script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_fy1xU2X7oZ4Yhv7hq2lsTUSulg0nEDLMdvWpknsYW7I.js"></script>
<script type="text/javascript" src="//video.limelight.com/player/embed.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_xht8E4BLA53oTxrfnKlXrB1kiW1yjdvRUnS5OTDFd_A.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
informaBouncexSettings = {"id":"1","property_name":"ITPro Today","colors_text_primary":"#ffffff","colors_text_secondary":"#ffffff","colors_bg_primary":"#004563","colors_bg_secondary":"#51bae6","brochure_url":"https:\/\/www.itprotoday.com","logo_url":"https:\/\/www.itprotoday.com\/sites\/all\/themes\/penton_subtheme_itprotoday\/images\/logos\/header.png","subscription_url":"https:\/\/www.itprotoday.com\/newsletters\/signup","gaViewID":"186866656","elqFormId":"1037","elqFormName":"INET_Promo_BounceXIntegration","eloquaInstance":"PentoniNET","elqSiteID":"1885539667","created":"1552499984"};
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
informaBouncexCmpgn = {"disengagement":{"step1":{"preheader":"ENTER YOUR EMAIL TO DOWNLOAD ","header":"TECHNOLOGY SALARY SURVEY FINDINGS: CURRENT COMPENSATION, FUTURE COMPENSATION","cta":"SEE SURVEY FINDINGS","ntb":"CONTINUE TO SITE"},"step2":{"preheader":"GREAT","header":"YOU NOW HAVE ACCESS TO THE FULL TECHNOLOGY SALARY SURVEY FINDINGS","cta":"SEE THE REPORT","ntb":""},"step3":{"preheader":"","header":"","cta":"","ntb":""},"offer":"ITPSalaryReport_disengagement"},"clickToCaptureDesktop":{"step1":{"preheader":"","header":"DO YOU WANT TO GET ANALYSIS AND PRO TIPS DAILY?","cta":"YES, KEEP ME UPDATED","ntb":""},"step2":{"preheader":"ENTER YOUR EMAIL TO RECEIVE","header":"INDUSTRY NEWS, PRODUCTS, FAQs, TIPS AND RESOURCES","cta":"SIGN ME UP","ntb":"CONTINUE TO SITE"},"step3":{"preheader":"GREAT","header":"YOU'LL NOW RECEIVE DAILY ANALYSIS AND PRO TIPS","cta":"CONTINUE TO SITE","ntb":""},"offer":"ITPNewsletter_Desktop"},"clickToCaptureMobile":{"step1":{"preheader":"","header":"DO YOU WANT TO GET ANALYSIS AND PRO TIPS DAILY?","cta":"YES, I WANT ACCESS","ntb":"NO, I DON'T WANT UPDATES"},"step2":{"preheader":"ENTER YOUR EMAIL TO RECEIVE","header":"INDUSTRY NEWS, PRODUCTS, FAQs, TIPS AND RESOURCES","cta":"SIGN ME UP","ntb":"CONTINUE TO SITE"},"step3":{"preheader":"GREAT","header":"YOU'LL NOW RECEIVE DAILY ANALYSIS AND PRO TIPS","cta":"CONTINUE TO SITE","ntb":""},"offer":"ITPNewsletter_Mobile"},"inlinezone":{"step1":{"preheader":"DO YOU WANT ACCESS TO","header":"2019 TECHNOLOGY SALARY SURVEY FINDINGS?","cta":"YES, UNLOCK ACCESS","ntb":"NO, NOT RIGHT NOW"},"step2":{"preheader":"ENTER YOUR EMAIL TO DOWNLOAD ","header":"TECHNOLOGY SALARY SURVEY FINDINGS: CURRENT COMPENSATION, FUTURE COMPENSATION","cta":"SEE SURVEY FINDINGS","ntb":"CONTINUE TO SITE"},"step3":{"preheader":"GREAT","header":"YOU NOW HAVE ACCESS TO THE FULL TECHNOLOGY SALARY SURVEY FINDINGS","cta":"SEE THE REPORT","ntb":""},"offer":"ITPSalaryReport_Inline"}};
//--><!]]>
</script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_VvSlYoodLAf6CoZ1-kQ6MDC-Fvy22ighqZW1xFo6HqA.js"></script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_L6OZG5KXpK9TmHNSbl24vOE0yJf48VytacfkHRBNEVc.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
Drupal.settings.penton_eloqua_api = {"fields":["nl","utm_rid"]};
//--><!]]>
</script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_qekzEEdO6OYK9JDfHY1d86k3s6DkdpDGSrJKG4vEaz4.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_oji9_B8MxovI2pqQCxnUfSPWUa28Na17Ef-5MSc-XF8.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_Ev2a03hYfNqtDZW8vAZHfy3Nf4HzCwV9KR-zrDXM2_g.js"></script>
<script type="text/javascript">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</script>
      <script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_39wR4vuLCUZcIK_NsEhVLhl6834Dd3heLLFQ5DLVNsc.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/all/modules/contrib/ckeditor/ckeditor/ckeditor.js?pxmhs8"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_hTvEvnr-CSP0ayePYXq_lDVR4Xlir2rUBDh7jP_21fI.js"></script>
    </div>
  </body>
</html>
