<!DOCTYPE html>
<html lang="en"
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#" class="html not-front not-logged-in no-sidebars page-node page-node- page-node-143011 node-type-article header-with-pillar article-article">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <meta charset="utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge, chrome=1" />
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_152x152.png" sizes="152x152" />
<link rel="shortcut icon" href="https://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_180x180.png" sizes="180x180" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_167x167.png" sizes="167x167" />
<meta name="title" content="Eclipse Theia 1.0 Advances Open-Source IDE as VS Code Alternative" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_120x120.png" sizes="120x120" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch.png" />
<meta name="eloqua-tags" content="ITP-P-microsoft-visual-studio, , ITP-Journey-discover"/><link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_76x76.png" sizes="76x76" />
<meta name="description" content="Eclipse Theia hits a major milestone, as the Eclipse Foundation takes aim at providing a stable competitive alternative to Visual Studio Code." />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.itprotoday.com/microsoft-visual-studio/eclipse-theia-10-emerges-vs-code-alternative" />
<link rel="shortlink" href="https://www.itprotoday.com/node/143011" />
<meta property="og:site_name" content="IT Pro" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Eclipse Theia 1.0 Emerges as VS Code Alternative" />
<meta property="og:description" content="The open-source effort hits a major milestone, as the Eclipse Foundation takes aim at providing a stable competitive alternative to Visual Studio Code." />
<meta property="og:updated_time" content="2020-04-09T02:24:38+00:00" />
<meta property="og:image" content="https://www.itprotoday.com/sites/itprotoday.com/files/Theia.jpg" />
<meta property="twitter:card" content="summary" />
<meta property="twitter:url" content="https://www.itprotoday.com/microsoft-visual-studio/eclipse-theia-10-emerges-vs-code-alternative" />
<meta property="twitter:title" content="Eclipse Theia 1.0 Emerges as VS Code Alternative" />
<meta property="article:published_time" content="2020-04-09T01:20:21+00:00" />
<meta property="article:modified_time" content="2020-04-09T02:24:38+00:00" />
<meta property="og:audio" content="http://" />
<meta property="og:audio:secure_url" content="https://" />
<meta property="og:video:url" content="http://" />
<meta property="og:video:secure_url" content="https://" />
<meta property="og:video:type" content="text/html" />
    <title>Eclipse Theia 1.0 Advances Open-Source IDE as VS Code Alternative | IT Pro</title>
    <link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_PpiQEI-azlEmknynFVbTW6pWwXhVPT_fbABYbBL6JWQ.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_DHcXHPYBSjIVaCQZEG4ZlpLkvslnFlBCnQUCzlbRBio.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_4GJdl2xvrwyZP8r03oU7AnszTtBYGy_ecYVYwmYoww4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_pZxsco4eNR4BBsE0WxA8VRuq3YpiLLEug_6PnA6UUQc.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_9ZJgsxVcrJK3ApK_vU9P9ZzczaRkb04dRsdUkQHuiB8.css" media="all" />

<!--[if lte IE 9]>
<link type="text/css" rel="stylesheet" href="https://www.itprotoday.com/sites/itprotoday.com/files/css/css_d5304rVRgE97dcoJVANw-HS6Cz-71UhME-UbNuFSgx8.css" media="all" />
<![endif]-->
    <!-- HTML5 element support for IE6-8 -->
    <!--[if lt IE 9]>
    <script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
    <![endif]-->
    <script>
      var gdpr_cookie = "off";
      // Check if cookies enabled in browser.
      var cookieEnabled = navigator.cookieEnabled;
      if (typeof navigator.cookieEnabled === 'undefined' && !cookieEnabled) {
        document.cookie = 'testCookie';
        cookieEnabled = (document.cookie.indexOf('testCookie') !== -1);
      }
      if (cookieEnabled) {
        var is_cookie = document.cookie.indexOf('penton_gdpr_cookie');
        if (is_cookie == -1) {
          console.log('gdpr cookie not set');
          // Cookie is not yet set - banner just served
          gdpr_cookie = "on";
        }
      }
      console.log('gdprCookie==>' + gdpr_cookie);
    </script>
        <script>
      var isblocked = "notblocked";
      console.log('lpage==>' + isblocked);
      var pathname = window.location.pathname;
      var adu = "/3834/itprotoday.home/article/devops_and_software_development/microsoft_visual_studio";
      var adblockOn = 1;
    </script>
    <script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
    <script>
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
    </script>
    <script>
      if (adu !== "" && (pathname.indexOf('/cart') < 0) && (pathname.indexOf('/store') < 0) && (pathname.indexOf('/products') < 0) && (pathname.indexOf('/product-types') < 0) && (pathname.indexOf('/store-topics') < 0) && ((pathname.indexOf('/gallery')) !== (pathname.length - 8)) && (pathname.indexOf('/user/login') < 0) && (isblocked == "notblocked") && (pathname.indexOf('penton_ur_thank_you') < 0)) {
        var targ_arr = JSON.parse('[{"target":"pos","value":"728_1_a"},{"target":"combo","value":"wrap"},{"target":"ptype","value":"Article"},{"target":"nid","value":"143011"},{"target":"pterm","value":"microsoft_visual_studio"},{"target":"author","value":"sean_michael_kerner"},{"target":"reg","value":"anonymous"}]');
        googletag.cmd.push(function() {
          if (gdpr_cookie == "off" && typeof googletag !== 'undefined' && typeof googletag.pubads !== 'undefined'  && googletag.apiReady) {
            googletag.pubads().setRequestNonPersonalizedAds(0);
          } else if (gdpr_cookie == "on" && typeof googletag !== 'undefined' && typeof googletag.pubads !== 'undefined'  && googletag.apiReady) {
            googletag.pubads().setRequestNonPersonalizedAds(1);
          }
          var welcome_ad = googletag.defineSlot(adu, [1, 1], "div-interstitial");
          welcome_ad.addService(googletag.pubads());
          welcome_ad.setTargeting("pos", "interstitial_a");
          welcome_ad.setTargeting("gdpr_banner", gdpr_cookie);
          for (var i=0; i<targ_arr.length; i++) {
            var targ = targ_arr[i]['target'];
            var val = targ_arr[i]['value'].split(',');
            if (targ !== 'pos' && targ !== 'combo') {
              welcome_ad.setTargeting(targ, val);
            }
          }

          setTimeout(function() {
            console.log('adblockval');console.log(adblockOn);
            if(adblockOn == 1) {
              var bDiv = document.getElementById("body-wrapper");
              window.scrollTo(0, 0);
              if(bDiv.style.removeProperty) {
                bDiv.style.removeProperty('opacity');
              } else {
                bDiv.style.removeAttribute('opacity');
              }
            }
          }, 2000);

          if (typeof googletag !== 'undefined' && typeof googletag.pubads !== 'undefined'  && googletag.apiReady) {
            googletag.pubads().addEventListener('slotRenderEnded', function(event) {
              adblockOn = 0;
              if(event.slot.getSlotElementId() == "div-interstitial") {
                if(event.isEmpty) {
                  console.log('emptyInterstitial');
                  var bDiv = document.getElementById("body-wrapper");
                  window.scrollTo(0, 0);
                  if(bDiv.style.removeProperty) {
                    bDiv.style.removeProperty('opacity');
                  } else {
                    bDiv.style.removeAttribute('opacity');
                  }
                } else {
                  console.log('notemptyInterstitial');
                }

                var dfplogpatt = new RegExp('dfp_log');
                var isDebug = dfplogpatt.test(location.search);
                if(isDebug) {
                  console.log('%c********DFPTag: Interstitial********', 'font-size:medium;font-style:bold');
                  console.log('adunit: '+adu);
                  if (gdpr_cookie == "off") {
                    console.log('nonpersonalized ads: 0');
                  } else if (gdpr_cookie == "on") {
                    console.log('nonpersonalized ads: 1');
                  }
                  console.log('targetingpair==> pos:interstitial_a');
                  console.log('targetingpair==> gdpr_banner:'+gdpr_cookie);
                  for(var i=0; i<targ_arr.length; i++) {
                    var targ = targ_arr[i]['target'];
                    var val = targ_arr[i]['value'].split(',');
                    if(targ !== 'pos' && targ !== 'combo') {
                      console.log('targetingpair==> '+targ+':'+val);
                    }
                  }
                  console.log('adsize: [1, 1]');
                  console.log('oop: false');
                  console.log('%c************************************', 'font-size:medium;font-style:bold');
                }
              }
            });
            googletag.enableServices();
          }
        });
      }
    </script>
      </head>
  <body>
        <div id="wl_flogop_div" class="hidden">https://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/footer.png</div>
    <div id="div-interstitial">
      <script>
        if(adu !== "" && (pathname.indexOf('/cart') < 0) && (pathname.indexOf('/store') < 0) && (pathname.indexOf('/products') < 0) && (pathname.indexOf('/product-types') < 0) && (pathname.indexOf('/store-topics') < 0) && ((pathname.indexOf('/gallery')) !== (pathname.length - 8)) && (pathname.indexOf('/user/login') < 0) && (isblocked == "notblocked") && (pathname.indexOf('penton_ur_thank_you') < 0)  ) {
          googletag.cmd.push(function() {
            googletag.display("div-interstitial");
          });
        }
      </script>
    </div>
        <div id="body-wrapper"  style="opacity:0;" >
      <noscript aria-hidden="true"><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KQFKXN4" height="0" width="0" style="display:none;visibility:hidden" title="Google Tag Manager">Google Tag Manager</iframe></noscript>      <header class="header js-header">
  <a id="skip-navigation" href="#main_content">Skip navigation</a>
  <!-- Pillar Navigation region -->
<nav class="pillar-nav">
<div id="block-penton-informa-banner-penton-informa-banner" class="block block-penton-informa-banner">

    
  <div class="content">
    <div id="iribbon-container">
    <button id="iribbon-title" title="show/hide">Informa</button>
    <div id="iribbon-detail" class="ribbon-hide">
        <div id="iribbon-left">
            <p>IT Pro Today is part of the Informa Tech Division of Informa PLC</p>
            <ul>
                <li class="iribbon-mainlink"><a href="https://informa.com/">Informa PLC</a></li>
                <li><a href="https://informa.com/About-Us/">About us</a></li>
                <li><a href="https://informa.com/Investors/">Investor relations</a></li>
                <li><a href="https://informa.com/Talent/">Talent</a></li>
            </ul>
        </div>
        <div id="iribbon-right">
            <p>This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them. Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.</p>
        </div>
    </div>
</div>
  </div>
</div>
<div id="block-menu-menu-pillar-navigation" class="pillar-nav__inner l-content clearfix">
  <div class="pillar-nav__header">Discover:</div>
  <ul class="pillar-nav__items js-menumore-discover"><li class="pillar-nav__item js-menumore-item-text  "><a href="https://www.blackhat.com/">Black Hat</a></li>
<li class="pillar-nav__item js-menumore-item-text  "><a href="https://www.interop.com/?_mc=hsad_x_itpro_le_aud_intplv_x_x-itpro-discbar">Interop</a></li>
<li class="pillar-nav__item js-menumore-item-text pillar-nav__item--event "><a href="https://tmt.knect365.com/iot-world/?utm_source=ITPMedia&amp;utm_medium=website&amp;utm_campaign=eyebrow-link">IoT World</a></li>
<li class="pillar-nav__item js-menumore-item-text  "><a href="https://afcom.com/Public/Leaders_Labs/Public/Leaders_Labs/About_Leaders_Labs/Leaders_Labs.aspx?hkey=842624e7-2596-4ceb-ba12-9f2ee91469a7">AFCOM Leaders Lab</a></li>
<li class="pillar-nav__item js-menumore-item-text pillar-nav__item--event "><a href="https://afcom.com/Public/Leaders_Labs/Public/Leaders_Labs/About_Leaders_Labs/Leaders_Labs.aspx?hkey=842624e7-2596-4ceb-ba12-9f2ee91469a7">Leaders lab</a></li>

    <li class="pillar-nav__item pillar-more js-menumore-more-item">
      <a class="pillar-more-btn">More<i class="fa fa-caret-down"></i></a>
      <ul class="pillar-list-nested js-menumore-sub"></ul>
    </li>
  </ul></div>
</nav>
<!-- /Pillar Navigation region -->
  <!-- Header -->
  <div class="header-inner l-content">
    <!-- Hamburger menu -->
<div class="menu-toggler js-ham-menu-toggler">
  <a href="#menu" class="menu-toggler-img-wrap js-menu-toggler">
    <div class="menu-toggler-hamburger">
      <div class="hamburger-text">Menu</div>
      <div class="hamburger-line"></div>
      <div class="hamburger-line"></div>
      <div class="hamburger-line"></div>
    </div>
  </a>
  <aside class="hamburger-menu">
    <div class="hamburger-menu-inner clearfix js-toggle-menu js-sticky-ham-menu">
      <div class="hamburger-menu-container">
                  <div class="user-thumb-text">
            <a href="/penton_modal/nojs/login" class="ctools-use-modal sattelite-event-caller sattelite-event-caller__hamburger-clicked ctools-modal-modal-popup-login" rel="nofollow">Log In</a> or <a href="/penton_modal/nojs/register/basic" class="ctools-use-modal sattelite-event-caller sattelite-event-caller__hamburger-clicked ctools-modal-modal-popup-medium" rel="nofollow">Register</a>          </div>
                <ul class="hamburger-menu-nav"><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/next-gen" title="">Next Gen</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/collaboration" title="">Collaboration</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/cloud-computing-0" title="">Cloud Computing</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/compute-engines" title="">Compute Engines</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/data-analytics-and-data-management" title="">Data Analytics and Data Management</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/data-center" title="">Data Center</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/devops-and-software-development" title="">DevOps and Software Development</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/mobility" title="">Mobility</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/security" title="">Security</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/storage" title="">Storage</a></li><li class="hamburger-menu-nav__item"><a href="https://www.itprotoday.com/windows-and-user-productivity" title="">Windows and User Productivity</a></li></ul><ul class="hamburger-menu-sub-nav"><li class="hamburger-menu-sub-nav__item"><a href="/industry-perspectives" title="">Industry Perspectives</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://www.itprotoday.com/it-buyers-guides" title="">Buyer’s guides</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://www.itprotoday.com/it-top-10-reports" title="">Top 10 reports</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://www.itprotoday.com/special-reports-it-tech-shaping-tomorrow" title="">Special reports</a></li><li class="hamburger-menu-sub-nav__item"><a href="/webinar-0" title="">Webinars</a></li><li class="hamburger-menu-sub-nav__item"><a href="/whitepapers" title="">Whitepapers</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://www.itprotoday.com/business-resources/technology-providers-company-profiles" title="">Technology Provider</a></li><li class="hamburger-menu-sub-nav__item"><a href="/business-resources" title="">Business Resources</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://afcom.com/Public/Leaders_Labs/Public/Leaders_Labs/About_Leaders_Labs/Leaders_Labs.aspx?hkey=842624e7-2596-4ceb-ba12-9f2ee91469a7" title="">AFCOM Leaders Lab</a></li><li class="hamburger-menu-sub-nav__item"><a href="/newsletters/signup" title="">Newsletter Preference</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://www.itprotoday.com/advertise-itprotodaycom" title="">Advertise</a></li><li class="hamburger-menu-sub-nav__item"><a href="/about-us" title="">About Us</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://knect365.com/privacy-policy" title="">Privacy Policy</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://www.penton.com/terms-of-service/" title="">Terms of Service</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://corporate.knect365.com/privacy-centre/our-cookie-policy/" title="">Cookie Policy</a></li></ul><div class="social-icons"><a href="https://www.facebook.com/ITProToday/" title="" class="social-icons__link"><i aria-label="facebook" class="social-icons__icon fa fa-facebook"></i></a><a href="https://twitter.com/ITProToday" title="" class="social-icons__link"><i aria-label="twitter" class="social-icons__icon fa fa-twitter"></i></a><a href="https://www.linkedin.com/company/itpro-today/" title="" class="social-icons__link"><i aria-label="linkedin" class="social-icons__icon fa fa-linkedin"></i></a></div>              </div>
    </div>
  </aside>
</div>
<!-- /Hamburger menu -->
    <!-- Header Logo -->
    <div class="header-logo">
                      <a href="/" class="header-logo__link"><img src="https://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/header.png" alt="IT Pro" title="IT Pro" /></a>                  </div>
    <!-- /Header Logo -->
          <!-- Header User links -->
      <ul class="header-nav">
                  <li class="header-nav__item header-nav__item__search">
            <a href="/search" class="header-nav-link"><i class="fa fa-search"></i>Search</a>          </li>
                          <li class="header-nav__item no-mobile">
            <a href="/penton_modal/nojs/login" class="ctools-use-modal ctools-modal-modal-popup-login header-nav-link" rel="nofollow">Log In</a>          </li>
          <li class="header-nav__item no-mobile last">
            <a href="/penton_modal/nojs/register/basic" class="ctools-use-modal ctools-modal-modal-popup-medium header-nav-link sattelite-event-caller sattelite-event-caller__header-clicked" rel="nofollow">Register</a>          </li>
                <!-- Cart -->
                <!-- /Cart -->
      </ul>
      </div>

  <!-- legal communication alert -->
  <div class="js-penton-legal-comm-ajax-output-alert">
      </div>
  <!-- /legal communication alert -->
<!-- /Header -->
</header>
<!-- Page -->
<main>
  <div id="page-wraper">
    <!-- Header Adv -->
    <div class="banner-top-wrapper">
      <div id="banner-top" class="dfp-ad-hideempty hidden">
        <div data-dfp-position="top_banner"></div>
      </div>
    </div>
        <!-- Admin Tabs -->
          <section id="admin-tabs" class="l-content">
              </section>
        <!-- /Admin Tabs -->
    <!-- /Header Adv -->
    <div class="wrapper l-content">
                                <!-- Sidebar -->
        <aside id="sidebar" class="l-sidebar sidebar">
            <div class="region region-left-col">
          <div class="slide-out-sidebar-button js-expand-sidebar">
        <span class="slide-out-recent">Recent</span>
      </div>
        <div class="sidebar-wrapper sidebar-scrollable js-sticky-leftcol">
      <section id="penton_recent_content_block">
  <aside>
    <div class="r-a-header">Recent</div>
                
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/uptime/data-center-providers-adjust-doing-business-remotely">
            Data Center Providers Adjust to Doing Business Remotely            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Apr 09, 2020</span>        </span>
          </div>
  </div>
</article>
                  <div data-dfp-position="native_leftrail_1" class="dfp-ad-hideempty hidden n_hidden n_leftrail1_2"></div>
            
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/microsoft-visual-studio/eclipse-theia-10-emerges-vs-code-alternative">
            Eclipse Theia 1.0 Emerges as VS Code Alternative            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Apr 09, 2020</span>        </span>
          </div>
  </div>
</article>
            <div class="banner-aside-wrapper dfp-ad-hideempty">
      <div class="banner-aside js-sticky-banner dfp-ad-hideempty hidden">
        <div data-dfp-position="left_rail_rect"></div>
      </div>
    </div>
    <hr>
                    
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/collaboration/zoom-says-platform-safe-peers-boosts-privacy-tools">
            Zoom Says Platform Is as Safe as Peers, Boosts Privacy Tools            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Apr 09, 2020</span>        </span>
          </div>
  </div>
</article>
                  <div data-dfp-position="native_leftrail_2" class="dfp-ad-hideempty hidden n_hidden n_leftrail1_2"></div>
            
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/windows-and-user-productivity/are-you-finally-thankful-your-it-person-now">
            Are You Finally Thankful for Your IT Person Now?            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Apr 08, 2020</span>        </span>
          </div>
  </div>
</article>
                
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/uptime/rules-rewritten-managing-data-centers-through-pandemic">
            Rules Rewritten: Managing Data Centers Through the Pandemic            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Apr 07, 2020</span>        </span>
          </div>
  </div>
</article>
      </aside>
</section>


<section id="penton_featured_content_block">
  <aside>
    <div class="r-a-header">Featured</div>
          
<article class="article-teaser article-teaser__icon__white-paper article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/collaboration/make-remote-working-work-enterprise">
            Make Remote Working Work for the Enterprise            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Oct 09, 2019</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__no-img article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/windows-78/windows-7-10-migration-tools-buyer-s-guide">
            Windows 7 to 10 Migration Tools Buyer’s Guide            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jun 17, 2019</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/devops-and-software-development/5-key-it-skills-new-decade">
            5 Key IT Skills for the New Decade            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Jun 27, 2019</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/uptime/data-center-interconnection-platforms-pitch-help-it-scale-during-crisis">
            Data Center Interconnection Platforms Pitch in to Help IT Scale During the Crisis            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Apr 06, 2020</span>        </span>
          </div>
  </div>
</article>
      </aside>
</section>
    </div>
  </div>
        </aside>
        <!-- /Sidebar -->
            <!-- Main Content Area -->
      <div class="page main-area l-main-area">
        <div id="main_content" class="clearfix" tabindex="-1">
          
            <div class="region region-main-col">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <section class="main-articles-container js-lazy-pager-wrapper">

    <article itemscope itemtype="http://schema.org/NewsArticle" class=" big-article article-type-article article-143011 node-type-article with-feat-img article-standalone js-lazy-pager-content"  data-nid="143011" data-url="/microsoft-visual-studio/eclipse-theia-10-emerges-vs-code-alternative" data-title="Eclipse Theia 1.0 Emerges as VS Code Alternative" data-seo-title="Eclipse Theia 1.0 Advances Open-Source IDE as VS Code Alternative" data-type="article" data-terms="devops_and_software_development/microsoft_visual_studio" data-ptermhier="DevOps and Software Development &gt; Microsoft Visual Studio" data-pterm="Microsoft Visual Studio" data-sterm="" data-program="" data-tax="Microsoft Visual Studio" data-buyersjourney="Discover" data-ext="" data-author="Sean Michael Kerner" data-pub="Apr 09, 2020" data-visibility="visible" data-perm="public" data-pid="45ef0aa2-fb33-43f5-a3b8-b1ee5de4daab" data-contentSponsor="" data-content="">
    <meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.itprotoday.com/microsoft-visual-studio/eclipse-theia-10-emerges-vs-code-alternative"/>
    <meta itemprop="datePublished" content="2020-04-09T01:16:00+00:00"/>    <meta itemprop="dateModified" content="2020-04-09T02:24:38+00:00"/>
              <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
          <meta itemprop="url" content="https://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/header.png">
          <meta itemprop="width" content="980">
          <meta itemprop="height" content="173">
        </div>
        <meta itemprop="name" content="IT Pro">
      </div>
    
    
    <div class="big-article__top">

      
              <div class="big-article__image" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
          <img class="medium js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_featured_retina/public/Theia.jpg?itok=CU375w2_" src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_featured_standard/public/Theia.jpg?itok=DtU_RzEy" width="770" height="400" alt="Theia IDE" title="Theia IDE" />          <meta itemprop="url" content="https://www.itprotoday.com/sites/itprotoday.com/files/Theia.jpg">
          <meta itemprop="width" content="1550">
          <meta itemprop="height" content="1058">

                  </div>
              
      <div class="big-article__head row">
        <div class="heading ">
                    <div class="breadcrumbs"><span class="parent-category"><a href="/devops-and-software-development">DevOps and Software Development</a><span>&gt;</span></span><a href="/software-development/microsoft-visual-studio">Microsoft Visual Studio</a></div>          <h1 itemprop="headline">Eclipse Theia 1.0 Emerges as VS Code Alternative</h1>
                      <div itemprop="description">
              
  <div class="field field-name-field-penton-content-summary field-type-text-long field-label-hidden">
    The open-source effort hits a major milestone, as the Eclipse Foundation takes aim at providing a stable competitive alternative to Visual Studio Code.  </div>
            </div>
                                <p class="author-and-date" itemprop="author" itemscope="" itemtype="https://schema.org/Person"><span itemprop="name"><a href="/author/Sean-Kerner" itemprop="url">Sean Michael Kerner</a></span> | <span class="date-display-single">Apr 09, 2020</span></p>
                  </div>
      </div>

      
    </div>

              <div class="share-icons">
            <a href="/penton_modal/nojs/print/143011"
         class="print ctools-use-modal ctools-modal-modal-popup-basic"
         rel="nofollow">
        <i aria-label="print" class="fa fa-print"></i>
      </a>
          <a href="/penton_modal/nojs/forward/143011/0"
         class="envelope ctools-use-modal ctools-modal-modal-popup-basic-email"
         rel="nofollow">
        <i aria-label="email" class="fa fa-envelope"></i>
      </a>
                  <a href="https://www.facebook.com/sharer.php?u=https://www.itprotoday.com/microsoft-visual-studio/eclipse-theia-10-emerges-vs-code-alternative&amp;t=Eclipse Theia 1.0 Emerges as VS Code Alternative"
         class="facebook"
         target="_blank">
        <i aria-label="facebook" class="fa fa-facebook"></i>
      </a>
                <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.itprotoday.com/microsoft-visual-studio/eclipse-theia-10-emerges-vs-code-alternative&amp;title=Eclipse Theia 1.0 Emerges as VS Code Alternative&amp;summary=Then Eclipse Foundation was founded with the Eclipse integrated development environment (IDE) at its core but over the years has added other IDEs and developer tools. The newest stable tool to emerge from the Eclipse Foundation is the Theia cloud and desktop IDE, which hit its 1.0 milestone on March 31.&amp;source=IT Pro"
         class="linkedin"
         target="_blank">
        <i aria-label="linkedin" class="fa fa-linkedin"></i>
      </a>
                <a href="https://twitter.com/share?url=https://www.itprotoday.com/microsoft-visual-studio/eclipse-theia-10-emerges-vs-code-alternative&amp;text=Eclipse Theia 1.0 Emerges as VS Code Alternative"
         class="twitter"
         target="_blank">
        <i aria-label="twitter" class="fa fa-twitter"></i>
      </a>
                <a href="https://pinterest.com/pin/create/button/?url=https://www.itprotoday.com/microsoft-visual-studio/eclipse-theia-10-emerges-vs-code-alternative&amp;description=Then Eclipse Foundation was founded with the Eclipse integrated development environment (IDE) at its core but over the years has added other IDEs and developer tools. The newest stable tool to emerge from the Eclipse Foundation is the Theia cloud and desktop IDE, which hit its 1.0 milestone on March 31.&amp;media="
         class="pinterest"
         target="_blank">
        <i aria-label="pinterest" class="fa fa-pinterest"></i>
      </a>
              <a class="pinterest"
           target="_blank">
           <i aria-label="pinterest" class="fa fa-pinterest"></i>
        </a>
            </div>

              
    
    <div class="article-content-wrap">
      
      <div itemprop="articleBody" class="article-content ">
                  <div class="article-banner dfp-ad-hideempty hidden">
            <div data-dfp-position="inarticle1"></div>
          </div>
                
        <p><span style="color:black">Then Eclipse Foundation was founded with the Eclipse integrated development environment (IDE) at its core but over the years has added other IDEs and developer tools. The newest stable tool to emerge from the Eclipse Foundation is the Theia cloud and desktop IDE, which hit its 1.0 milestone on March 31.</span></p>

<p><span style="color:black">Started by <a href="https://www.itprotoday.com/cloud-computing/ericsson-ceo-says-cloud-capability-key-capturing-5g-market" style="text-decoration:underline">Ericsson</a> and <u><a href="https://www.typefox.io/" style="text-decoration:underline target=_blank target=_blank" target="_blank">TypeFox</a></u>, Eclipse Theia has been in development since 2016. The goal of the project is to have an extensible platform to enable both cloud and desktop IDE tooling. Theia is already at the core of multiple IDEs, including the cloud-native <u><a href="https://www.eclipse.org/che/" style="text-decoration:underline target=_blank target=_blank" target="_blank">Eclipse Che</a></u> IDE, the <u><a href="https://www.arduino.cc/en/main/software" style="text-decoration:underline target=_blank target=_blank" target="_blank">Arduino</a></u> IDE, and the online <u><a href="https://www.gitpod.io/" style="text-decoration:underline target=_blank target=_blank" target="_blank">Gitpod</a></u> IDE for GitHub and GitLab.</span></p>

<p><span style="color:black">"In some ways, we look at the potential impact on the industry of Theia as being absolutely akin to what the Eclipse desktop IDE did almost 20 years ago, in terms of launching a vendor-neutral, open-source platform built for tool developers that is coming from a vendor-neutral, open-source foundation," Mike Milinkovich, executive director of the Eclipse Foundation, told<em> ITPro Today</em>. </span></p>

<h2><span style="color:black"><strong>Inside the Eclipse Theia IDE</strong></span></h2>

<p><span style="color:black">Theia is inherently extensible by design, enabling <a href="https://www.itprotoday.com/devops/5-underappreciated-roles-and-responsibilities-software-developers" style="text-decoration:underline">developers</a> and other tool vendors to build on top of it, according to Milinkovich. With the 1.0 release, Theia also gains support for the Microsoft <u><a href="https://code.visualstudio.com/" style="text-decoration:underline target=_blank target=_blank" target="_blank">Visual Studio Code</a></u> (VS code) extension mode.</span></p>

<p><span style="color:black">Visual Studio Code is an open-source-based IDE from Microsoft that hit its <u><a href="https://www.itprotoday.com/microsoft-visual-studio/microsoft-releases-visual-studio-code-version-10" style="text-decoration:underline">1.0 milestone</a></u> in 2016. Although the Eclipse Foundation is positioning Theia as an alternative to Visual Studio Code, it's actually making use of several open-source components that come from Microsoft. Among the VS code components reused in Theia are the <u><a href="https://github.com/microsoft/monaco-editor" style="text-decoration:underline target=_blank target=_blank" target="_blank">Monaco editor</a></u> and the <u><a href="https://github.com/Microsoft/vscode-debugadapter-node" style="text-decoration:underline target=_blank target=_blank" target="_blank">debug adapter protocol </a></u>(DAP) project.</span></p>

<p><span style="color:black">"What we're delivering is something that provides even more flexibility for folks who want to build out their own products based on these technologies," Milinkovich said.</span></p>

<p><span style="color:black">While Milinkovich said he finds VS code to be an amazing product, Eclipse Theia is tackling a different market segment: enabling the creation of third-party white label products that are based on an open-source technology stack from a vendor-neutral foundation. </span></p>

<p><span style="color:black">"There are a lot of similarities between the way Theia looks and the way VS code works, and we certainly aspire to being able to offer a development experience that is on par with VS code," he said.</span></p>

<h2><span style="color:black"><strong>Theia Getting More Visual</strong></span></h2>

<p><span style="color:black">Theia currently has a look that is largely the same as what is available in VS code.</span></p>

<p><span style="color:black">Sven Efftinge, co-founder and CEO of TypeFox and Gitpod, told<em> ITPro Today</em> that he likes the VS code model that provides a very terminal-centric look. He noted that there is also an extension model that allows developers to add more graphics-intensive user interfaces if needed. Efftinge is also one of the project leaders for Eclipse Theia.</span></p>

<p><span style="color:black">While Efftinge likes the way VS code looks for the most part, he said there is still a lot of room for user interface improvements. There is a plan to enable a multi-window mode in Theia where developers can make better use of multiple monitors with the IDE, he said. </span></p>

<p><span style="color:black">"What we plan to do, and have done to some extent, is to make the core workbench a bit better," Efftinge said. "For instance, in Theia developers can easily drag panels anywhere, which is something you cannot easily do in VS code."</span></p>

        
                                        </div>

      
      
              
  <div class="comments-wrapper" id="comments-143011">
    <div class="comments">
      <a href="javascript:void(0)" class="comments--show hidden">0 comments</a>    </div>
    <div class="comments-container">
      <div class="fill-comments">
        <div class="comments-header"><span class="comments--hide">Hide comments</span></div>
                  <form class="comment-form" action="/comment/reply/143011" method="post" id="comment-form" accept-charset="UTF-8"><div><div class="user-comment-body">
  <div class="user-comment-field">
    <div class="user-photo">
      <img class="user-thumb-img" src="https://www.itprotoday.com/sites/all/themes/penton_core_theme/images/account-default-image.png" alt="" />    </div>
    <div class="user-content">
      <div class="user-name">
        <a href="/" class="js-penton-user-url-profile"></a>      </div>
      <div class="user-comment">
        <div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="comment_body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label class="element-invisible" for="edit-comment-body-143011">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full ckeditor-mod form-textarea required" placeholder="Be the first to comment..." id="edit-comment-body-143011" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
<a class="ckeditor_links" style="display:none" href="javascript:void(0);" onclick="javascript:Drupal.ckeditorToggle(['edit-comment-body-143011'],'Switch to plain text editor','Switch to rich text editor');" id="switch_edit-comment-body-143011">Switch to plain text editor</a><fieldset class="filter-wrapper element-invisible form-wrapper" id="edit-comment-body-und-0-format"><div class="fieldset-wrapper"><div class="filter-help form-wrapper" id="edit-comment-body-und-0-format-help"><p><a href="/filter/tips" target="_blank">More information about text formats</a></p></div><div class="form-item form-type-select form-item-comment-body-und-0-format">
  <label for="edit-comment-body-und-0-format--2">Text format </label>
 <select class="filter-list form-select" id="edit-comment-body-und-0-format--2" name="comment_body[und][0][format]"><option value="comments" selected="selected">Comments</option><option value="plain_text">Plain text</option></select>
</div>
<div class="filter-guidelines form-wrapper" id="edit-comment-body-und-0-format-guidelines"><div class="filter-guidelines-item filter-guidelines-comments"><h3>Comments</h3><ul class="tips"><li>Allowed HTML tags: &lt;em&gt; &lt;strong&gt; &lt;blockquote&gt; &lt;br&gt; &lt;p&gt;</li></ul></div><div class="filter-guidelines-item filter-guidelines-plain_text"><h3>Plain text</h3><ul class="tips"><li>No HTML tags allowed.</li><li>Web page addresses and e-mail addresses turn into links automatically.</li><li>Lines and paragraphs break automatically.</li></ul></div></div></div></fieldset>
</div>
<a href="#" class="publish js-publish user-comment__publishbtn">Publish</a><span class='comment-error'><a href="/penton_modal/nojs/login" class="ctools-use-modal ctools-modal-modal-popup-login" rel="nofollow">Log in or register to comment</a></span></div></div>      </div>
    </div>
  </div>
</div>
<input type="hidden" name="cid" value="" />
<input type="hidden" name="pid" value="" />
<input type="hidden" name="form_build_id" value="form-cLXX77eSbvq474fYu-jiR7EFLvdI1DkNThcts_3mQAI" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<input type="hidden" name="captcha_sid" value="112018611" />
<input type="hidden" name="captcha_token" value="e438271a2031ae37a5e556ae7a38fc84" />
<div class="element-invisible"><div class="form-actions form-wrapper" id="edit-actions"><button id="edit-submit-143011" name="op" value="Save" class="form-submit">Save</button>
</div></div><div class="url-textfield"><div class="form-item form-type-textfield form-item-url">
  <label for="edit-url">Leave this field blank </label>
 <input autocomplete="off" type="text" id="edit-url" name="url" value="" size="20" maxlength="128" class="form-text" />
</div>
</div></div></form>                <div class="comments-inner-container">
                  </div>
      </div>
    </div>
  </div>
      
    </div>

    
    <div class="row related-articles-row">
              <div class="related-articles-heading">Related</div><div class="related-articles-wrapper"><a href="/iaaspaas/aws-summit-nyc-observability-developer-productivity-highlighted" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/Werner-Vogels-AWS-Summit-NYC-3_0.jpg?itok=JL0XAlK8" src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/Werner-Vogels-AWS-Summit-NYC-3_0.jpg?itok=anYCHaZ3" width="90" height="83" alt="AWS Chief Technology Officer Werner Vogels speaking on stage at AWS Summit NYC 2019" /></div><div class="small-article__inner"><div class="small-article__inner-title">AWS Summit NYC: Observability, Developer Productivity Highlighted</div><span>Jul 12, 2019</span></div></article></a><a href="/microsoft-visual-studio/itpro-snapshot-what-else-happened-week-june-1-8-2018" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/sunrise-1756274_640_5.jpg?itok=uc014L5m" src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/sunrise-1756274_640_5.jpg?itok=Tfcfiw1l" width="90" height="83" alt="ITPro SnapShot Hero" /></div><div class="small-article__inner"><div class="small-article__inner-title">ITPro SnapShot: What Else Happened This Week? (June 1 - 8, 2018)</div><span>Jun 08, 2018</span></div></article></a><article class="dfp-ad-hideempty hidden n_hidden small-article" data-dfp-position="native_related"></article><a href="/devops-and-software-development/what-expect-microsoft-build-2018" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/satyanadellabuildstagekeynote_4.jpg?itok=ywffcI6e" src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/satyanadellabuildstagekeynote_4.jpg?itok=FxOz9ZLc" width="90" height="83" alt="Microsoft CEO Satya Nadella Delivers a keynote at BUILD 2017." /></div><div class="small-article__inner"><div class="small-article__inner-title">What to Expect From Microsoft BUILD 2018</div><span>May 03, 2018</span></div></article></a><a href="/microsoft-visual-studio/resource-open-extensions-visual-studio" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/uploads/2017/07/openinextensionshero_0.png?itok=8o6y4xAW" src="https://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/uploads/2017/07/openinextensionshero_0.png?itok=q7gVLBsZ" width="90" height="83" alt="Resource: Open In Extensions for Visual Studio" /></div><div class="small-article__inner"><div class="small-article__inner-title">Resource: Open In Extensions for Visual Studio</div><span>Jul 13, 2017</span></div></article></a></div>          </div>

    
    <div class="item-list"><ul class="lazy-pagination"><li class="read-more pagination-read-more next first"><a href="/microsoft-visual-studio/itpro-snapshot-what-else-happened-week-june-1-8-2018?parent=143011&infscr=1" rel="nofollow">Load More</a></li>
<li class="last"><a href="/microsoft-visual-studio/itpro-snapshot-what-else-happened-week-june-1-8-2018" rel="next">Next Article</a></li>
</ul></div>
    
  </article>

  
</section>
  </div>
</div>
  </div>

        </div>
                <div class="banner-bottom-wrapper">
          <div id="banner-bottom" class="dfp-ad-hideempty hidden">
            <div data-dfp-position="bottom_banner"></div>
          </div>
        </div>
                <!-- /Main Content Area -->
                  <!-- Footer -->
          <footer class="corporate l-footer l-footer-min">
  <div class="l-footer-inner">
    <div class="l-footer-info">
      <div class="footer-logo-min">
                  <a href="/"><img class="footer-logo-min__site_logo" src="https://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/footer.png" alt="Logo" /></a>                <div class="small-12 medium-5 columns">
          <div class="footer-links">
                      </div>
        </div>
      </div>
      <div class="footer-content">
        <ul class="footer-min-col">
          <li class="footer-min-col__item">
      <a href="/about-us" class="footer-min-col-link">About</a>    </li>
          <li class="footer-min-col__item">
      <a href="https://www.itprotoday.com/advertise-itprotodaycom" class="footer-min-col-link">Advertise</a>    </li>
          <li class="footer-min-col__item">
      <a href="/contact-us" class="footer-min-col-link">Contact Us</a>    </li>
          <li class="footer-min-col__item">
      <a href="/sitemap" class="footer-min-col-link">Sitemap</a>    </li>
          <li class="footer-min-col__item">
      <a href="http://www.penton.com/privacy-policy#ThirdPartyAdvertisingTech" class="footer-min-col-link">Ad Choices</a>    </li>
            </ul>
      <ul class="footer-min-col no-margin">
        <li class="footer-min-col__item">
      <a href="https://privacyportal-eu-cdn.onetrust.com/dsarwebform/c1f53e84-9f05-4169-a854-85052b63c50b/5f26b553-52cc-4973-a761-295d5634a6b6.html" class="footer-min-col-link">CCPA: Do not sell my personal info</a>    </li>
          <li class="footer-min-col__item">
      <a href="https://informa.com/privacy-policy" class="footer-min-col-link">Privacy Policy</a>    </li>
          <li class="footer-min-col__item">
      <a href="https://engage.informa.com/terms-of-service" class="footer-min-col-link">Terms of Service</a>    </li>
          <li class="footer-min-col__item">
      <a href="https://engage.informa.com/cp/cookie-policy/" class="footer-min-col-link">Cookie Policy</a>    </li>
  </ul>
<div class="social-min-col">
  <p class="social-min-col__label">Follow us:</p>
  <div class="social-icons"><a href="https://www.facebook.com/ITProToday/" title="" class="social-icons__link"><i aria-label="facebook" class="social-icons__icon fa fa-facebook"></i></a><a href="https://twitter.com/ITProToday" title="" class="social-icons__link"><i aria-label="twitter" class="social-icons__icon fa fa-twitter"></i></a><a href="https://www.linkedin.com/company/itpro-today/" title="" class="social-icons__link"><i aria-label="linkedin" class="social-icons__icon fa fa-linkedin"></i></a></div></div>
      </div>
    </div>
  </div>
  <div class="l-corporate-footer">
    <div class="l-corporate-footer-logo-copyrights-wrapper">
      <div class="l-corporate-footer-logo-copyrights">
        <div class="l-corporate-footer-logo">
          <a href="https://tech.informa.com/"><img src="/sites/all/themes/informa_midtheme_tech/images/corporate_footer_logo.png" alt="Informa Tech" /></a>        </div>
        <div class="l-coporate-footer-copyright">
          &#169; 2020 Informa USA, Inc., All rights reserved
        </div>
      </div>
    </div>
    <div class="l-corporate-footer-links-wrapper">
      <div class="l-coporate-footer-links">
        <ul class="links"><li class="menu-1804 first"><a href="https://informa.com/privacy-policy/" title="">Privacy Policy</a></li>
<li class="menu-1805"><a href="https://engage.informa.com/cp/cookie-policy/">Cookie Policy</a></li>
<li class="menu-1806 last"><a href="http://engage.informa.com/terms-of-service" title="">Terms of Use</a></li>
</ul>      </div>
    </div>
  </div>
</footer>
          <!-- /Footer -->
              </div>
    </div>
  </div>
</main>
<!-- /Page -->
<div id="hidden-dfp" class="dfp-ad-hideempty hidden">
  <div data-dfp-position="hidden" class="hidden-for-ads"></div>
</div>
      <script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_2MWCYVvM-5Pprylbgct4ZVgdikjpahMCPF4Yn42pc-8.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js__PiZuK2o4XAnDCWOhogiGF01gyHzeu7QxvOyfTe-YyM.js"></script>
<script type="text/javascript" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_ySyZkbOziT4GByLa86HPiLpGB0CKDqHGY5xhobIRRSY.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_jqnCeG1_d9epR-3piXLGGEj4ZKRW0wUq3e0IBpz1bsQ.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_oyPmjoXzZsox1uW00AXC6MNBBMFGGAPQTkJ8hnDMz38.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.CKEDITOR_BASEPATH = "/sites/all/modules/contrib/ckeditor/ckeditor/"
//--><!]]>
</script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_fy1xU2X7oZ4Yhv7hq2lsTUSulg0nEDLMdvWpknsYW7I.js"></script>
<script type="text/javascript" src="//video.limelight.com/player/embed.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_xht8E4BLA53oTxrfnKlXrB1kiW1yjdvRUnS5OTDFd_A.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
informaBouncexSettings = {"id":"1","property_name":"ITPro Today","colors_text_primary":"#ffffff","colors_text_secondary":"#ffffff","colors_bg_primary":"#004563","colors_bg_secondary":"#51bae6","brochure_url":"https:\/\/www.itprotoday.com","logo_url":"https:\/\/www.itprotoday.com\/sites\/all\/themes\/penton_subtheme_itprotoday\/images\/logos\/header.png","subscription_url":"https:\/\/www.itprotoday.com\/newsletters\/signup","gaViewID":"186866656","elqFormId":"1037","elqFormName":"INET_Promo_BounceXIntegration","eloquaInstance":"PentoniNET","elqSiteID":"1885539667","created":"1552499984"};
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
informaBouncexCmpgn = {"disengagement":{"step1":{"preheader":"ENTER YOUR EMAIL TO DOWNLOAD ","header":"TECHNOLOGY SALARY SURVEY FINDINGS: CURRENT COMPENSATION, FUTURE COMPENSATION","cta":"SEE SURVEY FINDINGS","ntb":"CONTINUE TO SITE"},"step2":{"preheader":"GREAT","header":"YOU NOW HAVE ACCESS TO THE FULL TECHNOLOGY SALARY SURVEY FINDINGS","cta":"SEE THE REPORT","ntb":""},"step3":{"preheader":"","header":"","cta":"","ntb":""},"offer":"ITPSalaryReport_disengagement"},"clickToCaptureDesktop":{"step1":{"preheader":"","header":"DO YOU WANT TO GET ANALYSIS AND PRO TIPS DAILY?","cta":"YES, KEEP ME UPDATED","ntb":""},"step2":{"preheader":"ENTER YOUR EMAIL TO RECEIVE","header":"INDUSTRY NEWS, PRODUCTS, FAQs, TIPS AND RESOURCES","cta":"SIGN ME UP","ntb":"CONTINUE TO SITE"},"step3":{"preheader":"GREAT","header":"YOU'LL NOW RECEIVE DAILY ANALYSIS AND PRO TIPS","cta":"CONTINUE TO SITE","ntb":""},"offer":"ITPNewsletter_Desktop"},"clickToCaptureMobile":{"step1":{"preheader":"","header":"DO YOU WANT TO GET ANALYSIS AND PRO TIPS DAILY?","cta":"YES, I WANT ACCESS","ntb":"NO, I DON'T WANT UPDATES"},"step2":{"preheader":"ENTER YOUR EMAIL TO RECEIVE","header":"INDUSTRY NEWS, PRODUCTS, FAQs, TIPS AND RESOURCES","cta":"SIGN ME UP","ntb":"CONTINUE TO SITE"},"step3":{"preheader":"GREAT","header":"YOU'LL NOW RECEIVE DAILY ANALYSIS AND PRO TIPS","cta":"CONTINUE TO SITE","ntb":""},"offer":"ITPNewsletter_Mobile"},"inlinezone":{"step1":{"preheader":"DO YOU WANT ACCESS TO","header":"2019 TECHNOLOGY SALARY SURVEY FINDINGS?","cta":"YES, UNLOCK ACCESS","ntb":"NO, NOT RIGHT NOW"},"step2":{"preheader":"ENTER YOUR EMAIL TO DOWNLOAD ","header":"TECHNOLOGY SALARY SURVEY FINDINGS: CURRENT COMPENSATION, FUTURE COMPENSATION","cta":"SEE SURVEY FINDINGS","ntb":"CONTINUE TO SITE"},"step3":{"preheader":"GREAT","header":"YOU NOW HAVE ACCESS TO THE FULL TECHNOLOGY SALARY SURVEY FINDINGS","cta":"SEE THE REPORT","ntb":""},"offer":"ITPSalaryReport_Inline"}};
//--><!]]>
</script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_Vv9NAoQ5qYRbmWv0m1HGfyHtXwChRwup7rlT_sAdeog.js"></script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_L6OZG5KXpK9TmHNSbl24vOE0yJf48VytacfkHRBNEVc.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
Drupal.settings.penton_eloqua_api = {"fields":["nl","utm_rid"]};
//--><!]]>
</script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_qekzEEdO6OYK9JDfHY1d86k3s6DkdpDGSrJKG4vEaz4.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_DP2cI11mGjVo0QwXLQsZAucGqkSA05cxO9BA0g96opM.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_Ev2a03hYfNqtDZW8vAZHfy3Nf4HzCwV9KR-zrDXM2_g.js"></script>
<script type="text/javascript">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</script>
      <script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_39wR4vuLCUZcIK_NsEhVLhl6834Dd3heLLFQ5DLVNsc.js"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/all/modules/contrib/ckeditor/ckeditor/ckeditor.js?q8iw9x"></script>
<script type="text/javascript" src="https://www.itprotoday.com/sites/itprotoday.com/files/js/js_qj-GKdZLxl4IXsdVg0DKQScZYADgId6EIp1kg0dbKY4.js"></script>
    </div>
  </body>
</html>
