From the Forums: SMS Distribution Points Pool Stopped

From the Forums: SMS Distribution Points Pool Stopped

We have some mighty-fantastic web-based forums. Running for well over a decade, the forum site is full of answers covering a huge variety of technology topics. You can search the forums without an account, but if you want to ask questions or solve problems, you'll need to register for an account (if you don't have one already).

Periodically we highlight some additionally valuable threads where the solutions could help solve a burning issue.

In a recent thread, forum "super member" msutliff was having a problem where, after installing a new System Center Configuration Manager Distribution Point, the "SMS Distribution Points Pool" in IIS would just stop completely. Here's how it transpired…

The Problem

Msutliff: I added a 2008 r2 sp1 Distribution Point yesterday. I installed IIS then the 2012 client then made it a DP. Clients could not download today.  I noticed in IIS that the “SMS Distribution Points Pool” was stopped.  Starting it causes faulting application in the event log for w3wp.exe, module smsfileisapi.dll.   

I removed the DP role, watched SCCM uninstall it and then I put it back.  Same problem persisted.    

I removed the DP, uninstalled IIS, reinstalled IIS, reinstalled the DP role.  Problem persisted.

I changed the application pool “SMS Distribution Points Pool” property “enable 32-bit applications” to True.  Magically it starts without any errors but clients are receiving 500 and 401 errors (in IIS log).  If I browse to the URL I see clients request in the IIS Logs I get the IIS HTTP Error 500 page.   

I can browse the path in explorer using my regular user account. 

I’m at a loss as to what I should do here.  In process explorer I see w3wp.exe 32-bit and 64-bit processes.  If I change it back to 64-bit where it should be I see it start then crash.

The Solution

Mark ended up working with Microsoft product support and the following solution was given…

Msutliff: Product Support called me and said they have seen this before:

  1. Run Regedt32

  2. View permissions on the key HKLM\SOFTWARE\Microsoft\Sms\DP

  3. We had System and Administrators set to Full Control already, which was fine.

  4. We added Users with Read.

  5. Started it and the IIS log started filling up.

I hope this helps someone else.

Hide comments


  • Allowed HTML tags: <em> <strong> <blockquote> <br> <p>

Plain text

  • No HTML tags allowed.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Lines and paragraphs break automatically.