<!DOCTYPE html>
<html
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#" class="html not-front not-logged-in no-sidebars page-node page-node- page-node-124188 node-type-article header-with-pillar article-article">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <meta charset="utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge, chrome=1" />
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_167x167.png" sizes="167x167" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_180x180.png" sizes="180x180" />
<link rel="shortcut icon" href="http://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="title" content="Bitnami Introduces Kubeapps for Click and Deploy Kubernetes Containers" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_152x152.png" sizes="152x152" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_76x76.png" sizes="76x76" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch.png" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_120x120.png" sizes="120x120" />
<meta name="description" content="At KubeCon, Bitnami demonstrated a tool for deploying pre-packaged Kubernetes containers with the click of a mouse." />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="http://www.itprotoday.com/software-development/bitnami-introduces-kubeapps-click-and-deploy-kubernetes-containers" />
<link rel="shortlink" href="http://www.itprotoday.com/node/124188" />
<meta property="og:site_name" content="IT Pro" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Bitnami Introduces Kubeapps for Click and Deploy Kubernetes Containers" />
<meta property="og:url" content="http://www.itprotoday.com/software-development/bitnami-introduces-kubeapps-click-and-deploy-kubernetes-containers" />
<meta property="og:description" content="At KubeCon, Bitnami demonstrated a tool for deploying pre-packaged Kubernetes containers with the click of a mouse.
" />
<meta property="og:updated_time" content="2017-12-05T18:23:25-05:00" />
<meta property="og:image" content="http://www.itprotoday.com/sites/itprotoday.com/files/ThinkstockPhotos-641149660.jpg" />
<meta property="twitter:card" content="summary" />
<meta property="twitter:url" content="http://www.itprotoday.com/software-development/bitnami-introduces-kubeapps-click-and-deploy-kubernetes-containers" />
<meta property="twitter:title" content="Bitnami Introduces Kubeapps for Click and Deploy Kubernetes Containers" />
<meta property="article:published_time" content="2017-12-05T17:29:06-05:00" />
<meta property="article:modified_time" content="2017-12-05T18:23:25-05:00" />
<meta property="og:audio" content="http://" />
<meta property="og:audio:secure_url" content="https://" />
<meta property="og:video:url" content="http://" />
<meta property="og:video:secure_url" content="https://" />
<meta property="og:video:type" content="text/html" />
    <title>Bitnami Introduces Kubeapps for Click and Deploy Kubernetes Containers | IT Pro</title>
    <link type="text/css" rel="stylesheet" href="http://www.itprotoday.com/sites/itprotoday.com/files/css/css_PpiQEI-azlEmknynFVbTW6pWwXhVPT_fbABYbBL6JWQ.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.itprotoday.com/sites/itprotoday.com/files/css/css_DHcXHPYBSjIVaCQZEG4ZlpLkvslnFlBCnQUCzlbRBio.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.itprotoday.com/sites/itprotoday.com/files/css/css_5s97c60f3VRpsAX_L14fh1vAVHgak1sY-HQSBRlCRrc.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.itprotoday.com/sites/itprotoday.com/files/css/css_72btEBg3iDMahiLBBkAo2OFEgxDsl1EMDCzCSjAAFwY.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.itprotoday.com/sites/itprotoday.com/files/css/css_4q0aX3eX1tBplTEIM2hPpkeTVp4F3ExjOXFxg4XQcqw.css" media="all" />

<!--[if lte IE 9]>
<link type="text/css" rel="stylesheet" href="http://www.itprotoday.com/sites/itprotoday.com/files/css/css_9wlfiD8oXTbaPtNZgtEQpGROzLEj2b7PKL2hqYQntyI.css" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://embed.calculoid.com/styles/main.css" media="all" />
    <!-- HTML5 element support for IE6-8 -->
    <!--[if lt IE 9]>
    <script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
    <![endif]-->
  </head>
  <body>
    <div id="body-wrapper">
            <header class="header js-header">
  <!-- Pillar Navigation region -->
<nav class="pillar-nav">
<div id="block-menu-menu-pillar-navigation" class="pillar-nav__inner l-content clearfix">
  <div class="pillar-nav__header">Discover:</div>
  <ul class="pillar-nav__items js-menumore-discover"><li class="pillar-nav__item js-menumore-item-text  "><a href="/software-development">Dev Pro</a></li>
<li class="pillar-nav__item js-menumore-item-text  "><a href="/collaboration/microsoft-sharepoint">SharePoint Pro</a></li>
<li class="pillar-nav__item js-menumore-item-text  "><a href="/business-intelligence/microsoft-sql-server">SQL Server Pro</a></li>
<li class="pillar-nav__item js-menumore-item-text  "><a href="http://www.devconnections.com/">IT/Dev Connections</a></li>
<li class="pillar-nav__item js-menumore-item-text  "><a href="https://education.pentontechnology.com/">Online Training</a></li>

    <li class="pillar-nav__item pillar-more js-menumore-more-item">
      <a class="pillar-more-btn">More<i class="fa fa-caret-down"></i></a>
      <ul class="pillar-list-nested js-menumore-sub"></ul>
    </li>
  </ul></div>
</nav>
<!-- /Pillar Navigation region -->
  <!-- Header -->
  <div class="header-inner l-content">
    <!-- Hamburger menu -->
<div class="menu-toggler js-ham-menu-toggler">
  <div class="menu-toggler-img-wrap js-menu-toggler">
    <div class="menu-toggler-hamburger" class="active">
      <div class="hamburger-text">Menu</div>
      <div class="hamburger-line"></div>
      <div class="hamburger-line"></div>
      <div class="hamburger-line"></div>
    </div>
  </div>
  <aside class="hamburger-menu">
    <div class="hamburger-menu-inner clearfix js-toggle-menu js-sticky-ham-menu">
      <div class="hamburger-menu-container">
                  <div class="user-thumb-text">
            <a href="/penton_modal/nojs/login" class="ctools-use-modal sattelite-event-caller sattelite-event-caller__hamburger-clicked ctools-modal-modal-popup-login" rel="nofollow">Log In</a> or <a href="/penton_modal/nojs/register/basic" class="ctools-use-modal sattelite-event-caller sattelite-event-caller__hamburger-clicked ctools-modal-modal-popup-medium" rel="nofollow">Register</a>          </div>
                <ul class="hamburger-menu-nav"><li class="hamburger-menu-nav__item"><a href="/cloud-data-center" title="">Cloud &amp; Data Center</a></li><li class="hamburger-menu-nav__item"><a href="/business-intelligence" title="">Business Intelligence</a></li><li class="hamburger-menu-nav__item"><a href="/collaboration" title="">Collaboration</a></li><li class="hamburger-menu-nav__item"><a href="/management-mobility" title="">Management and Mobility</a></li><li class="hamburger-menu-nav__item"><a href="/software-development" title="">Software Development</a></li><li class="hamburger-menu-nav__item"><a href="/security" title="">Security</a></li><li class="hamburger-menu-nav__item"><a href="/internet-things-iot" title="">Internet of Things (IoT)</a></li><li class="hamburger-menu-nav__item"><a href="/podcasts" title="">Podcasts</a></li></ul><ul class="hamburger-menu-sub-nav"><li class="hamburger-menu-sub-nav__item"><a href="/business-resources" title="">Business Resources</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://education.pentontechnology.com/" title="">e-Learning</a></li><li class="hamburger-menu-sub-nav__item"><a href="/webcasts" title="">Webcasts</a></li><li class="hamburger-menu-sub-nav__item"><a href="/industry-perspectives" title="">Industry Perspectives</a></li><li class="hamburger-menu-sub-nav__item"><a href="/whitepapers" title="">Whitepapers</a></li><li class="hamburger-menu-sub-nav__item"><a href="/newsletters/signup" title="">Subscribe</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://technology.penton.com/itpro/" title="">Advertise</a></li><li class="hamburger-menu-sub-nav__item"><a href="/about-us" title="">About Us</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://www.penton.com/privacy-policy/" title="">Privacy Policy</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://www.penton.com/terms-of-service/" title="">Terms of Service</a></li></ul><div class="social-icons"><a href="https://www.facebook.com/ITProToday/" title="" class="social-icons__link"><i class="social-icons__icon fa fa-facebook"></i></a><a href="https://twitter.com/ITProToday" title="" class="social-icons__link"><i class="social-icons__icon fa fa-twitter"></i></a><a href="https://plus.google.com/115563256559407060026 " title="" class="social-icons__link"><i class="social-icons__icon fa fa-google-plus"></i></a><a href="https://www.linkedin.com/groups/1163947" title="" class="social-icons__link"><i class="social-icons__icon fa fa-linkedin"></i></a></div>              </div>
    </div>
  </aside>
</div>
<!-- /Hamburger menu -->
    <!-- Header Logo -->
    <div class="header-logo">
                      <a href="/" class="header-logo__link"><img src="http://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/header.png" alt="IT Pro" title="IT Pro" /></a>                  </div>
    <!-- /Header Logo -->
          <!-- Header User links -->
      <ul class="header-nav">
                  <li class="header-nav__item header-nav__item__search">
            <a href="/search" class="header-nav-link"><i class="fa fa-search"></i>Search</a>          </li>
                          <li class="header-nav__item no-mobile">
            <a href="/penton_modal/nojs/login" class="ctools-use-modal ctools-modal-modal-popup-login header-nav-link" rel="nofollow">Log In</a>          </li>
          <li class="header-nav__item no-mobile last">
            <a href="/penton_modal/nojs/register/basic" class="ctools-use-modal ctools-modal-modal-popup-medium header-nav-link sattelite-event-caller sattelite-event-caller__header-clicked" rel="nofollow">Register</a>          </li>
                <!-- Cart -->
                <!-- /Cart -->
      </ul>
      </div>

  <!-- legal communication alert -->
  <div class="js-penton-legal-comm-ajax-output-alert">
      </div>
  <!-- /legal communication alert -->
<!-- /Header -->
</header>
<!-- Page -->
<main>
  <div id="page-wraper">
    <!-- Header Adv -->
    <div class="banner-top-wrapper">
      <div id="banner-top" class="dfp-ad-hideempty hidden">
        <div data-dfp-position="top_banner"></div>
      </div>
    </div>
        <!-- Admin Tabs -->
          <section id="admin-tabs" class="l-content">
              </section>
        <!-- /Admin Tabs -->
    <!-- /Header Adv -->
    <div class="wrapper l-content">
                                <!-- Sidebar -->
        <aside id="sidebar" class="l-sidebar sidebar">
            <div class="region region-left-col">
          <div class="slide-out-sidebar-button js-expand-sidebar">
        <span class="slide-out-recent">Recent</span>
      </div>
        <div class="sidebar-scrollable js-sticky-leftcol">
      <section id="penton_recent_content_block">
  <aside>
    <div class="r-a-header">Recent</div>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/machine-learning/demand-ai-talent-turns-once-staid-conference-draft-day">
            Demand for AI Talent Turns Once-Staid Conference Into Draft Day            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Dec 06, 2017</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/microsoft-exchange/using-delivery-reports-microsoft-exchange-server-2016">
            Using Delivery Reports in Microsoft Exchange Server 2016            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Dec 04, 2017</span>        </span>
          </div>
  </div>
</article>
            <div class="banner-aside-wrapper dfp-ad-hideempty">
      <div class="banner-aside js-sticky-banner dfp-ad-hideempty hidden"">
        <div data-dfp-position="left_rail_rect"></div>
      </div>
    </div>
    <hr>
              
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/machine-learning/researchers-combat-gender-and-racial-bias-artificial-intelligence">
            Researchers Combat Gender and Racial Bias in Artificial Intelligence            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Dec 04, 2017</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/amazon-web-services-aws/supported-kubernetes-coming-aws">
            Supported Kubernetes Coming to AWS            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Dec 01, 2017</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/microsoft-azure/savills-faqs-how-powershell-accesses-remote-files">
            Savill&#039;s FAQs: How PowerShell accesses remote files            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Dec 01, 2017</span>        </span>
          </div>
  </div>
</article>
      </aside>
</section>


<section id="penton_featured_content_block">
  <aside>
    <div class="r-a-header">Featured</div>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/management-mobility/welcome-new-itpro">
            Welcome to the New ITPro            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Nov 02, 2017</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/business-resources/it-pros-skip-training-certification-miss-out-salary-increases">
            IT Pros That Skip Training, Certification Miss Out on Salary Increases            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Oct 10, 2017</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/internet-things-iot/windows-10-fall-creators-update-internet-things-devices">
            The Windows 10 Fall Creators Update for Internet of Things Devices            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Nov 02, 2017</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/security/checklist-select-most-secure-hardware-use-windows-10">
            Checklist: Select the Most Secure Hardware to Use with Windows 10            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Nov 08, 2017</span>        </span>
          </div>
  </div>
</article>
      </aside>
</section>
    </div>
  </div>
        </aside>
        <!-- /Sidebar -->
            <!-- Main Content Area -->
      <div class="page main-area l-main-area">
        <div id="main_content" class="clearfix">
          
            <div class="region region-main-col">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <section class="main-articles-container js-lazy-pager-wrapper">

  
  <article itemscope itemtype="http://schema.org/NewsArticle" class="big-article article-type-article article-124188 node-type-article with-feat-img article-standalone js-lazy-pager-content"  data-nid="124188" data-url="/software-development/bitnami-introduces-kubeapps-click-and-deploy-kubernetes-containers" data-title="Bitnami Introduces Kubeapps for Click and Deploy Kubernetes Containers" data-seo-title="Bitnami Introduces Kubeapps for Click and Deploy Kubernetes Containers" data-type="article" data-terms="software_development" data-ptermhier="Software Development" data-pterm="Software Development" data-sterm="Containers" data-program="" data-tax="Software Development|Containers" data-ext="" data-author="" data-pub="Dec 06, 2017" data-visibility="visible" data-perm="public" data-pid="3bb59e6d-c499-468b-863f-8be0c3494325" data-content="">
    <meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="http://www.itprotoday.com/software-development/bitnami-introduces-kubeapps-click-and-deploy-kubernetes-containers"/>
    <meta itemprop="datePublished" content="2017-12-06T03:29:00-05:00"/>    <meta itemprop="dateModified" content="2017-12-05T18:23:25-05:00"/>
              <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
          <meta itemprop="url" content="http://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/header.png">
          <meta itemprop="width" content="435">
          <meta itemprop="height" content="130">
        </div>
        <meta itemprop="name" content="IT Pro">
      </div>
    
    <div class="big-article__top">

      
              <div class="big-article__image" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
          <img class="medium js-imgpxr" data-x2src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_featured_retina/public/ThinkstockPhotos-641149660.jpg?itok=Tcv3RXlJ" src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_featured_standard/public/ThinkstockPhotos-641149660.jpg?itok=o_tl-55X" width="770" height="400" alt="kubeapps" title="641149660" />          <meta itemprop="url" content="http://www.itprotoday.com/sites/itprotoday.com/files/ThinkstockPhotos-641149660.jpg">
          <meta itemprop="width" content="788">
          <meta itemprop="height" content="443">

                  </div>
              
      <div class="big-article__head row">
        <div class="heading ">
                    <div class="breadcrumbs"><a href="/software-development">Software Development</a></div>          <h1 itemprop="headline">Bitnami Introduces Kubeapps for Click and Deploy Kubernetes Containers</h1>
                      <div itemprop="description">
              
  <div class="field field-name-field-penton-content-summary field-type-text-long field-label-hidden">
    At KubeCon, Bitnami demonstrated a tool for deploying pre-packaged Kubernetes containers with the click of a mouse.
  </div>
            </div>
                                <p class="author-and-date" itemprop="author" itemscope="" itemtype="https://schema.org/Person"><span class="date-display-single">Dec 05, 2017</span></p>
                  </div>
      </div>

      
    </div>

          <div class="share-icons">
            <a href="/penton_modal/nojs/print/124188"
         class="print ctools-use-modal ctools-modal-modal-popup-basic"
         rel="nofollow">
        <i class="fa fa-print"></i>
      </a>
          <a href="/penton_modal/nojs/forward/124188/0"
         class="envelope ctools-use-modal ctools-modal-modal-popup-basic-email"
         rel="nofollow">
        <i class="fa fa-envelope"></i>
      </a>
                  <a href="http://www.facebook.com/sharer.php?u=http://www.itprotoday.com/software-development/bitnami-introduces-kubeapps-click-and-deploy-kubernetes-containers&amp;t=Bitnami Introduces Kubeapps for Click and Deploy Kubernetes Containers"
         class="facebook"
         target="_blank">
        <i class="fa fa-facebook"></i>
      </a>
                <a href="https://plus.google.com/share?url=http://www.itprotoday.com/software-development/bitnami-introduces-kubeapps-click-and-deploy-kubernetes-containers"
         class="google-plus"
         target="_blank">
        <i class="fa fa-google-plus"></i>
      </a>
                <a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http://www.itprotoday.com/software-development/bitnami-introduces-kubeapps-click-and-deploy-kubernetes-containers&amp;title=Bitnami Introduces Kubeapps for Click and Deploy Kubernetes Containers&amp;summary=At KubeCon on Monday, packaged server applications provider Bitnami demonstrated its latest and greatest, Kubeapps, an application deployment environment that launches and manages pre-packaged Kubernetes-ready applications and developer tools from within a Kubernetes cluster.&amp;source=IT Pro"
         class="linkedin"
         target="_blank">
        <i class="fa fa-linkedin"></i>
      </a>
                <a href="http://twitter.com/share?url=http://www.itprotoday.com/software-development/bitnami-introduces-kubeapps-click-and-deploy-kubernetes-containers&amp;text=Bitnami Introduces Kubeapps for Click and Deploy Kubernetes Containers"
         class="twitter"
         target="_blank">
        <i class="fa fa-twitter"></i>
      </a>
                <a href="http://pinterest.com/pin/create/button/?url=http://www.itprotoday.com/software-development/bitnami-introduces-kubeapps-click-and-deploy-kubernetes-containers&amp;description=At KubeCon on Monday, packaged server applications provider Bitnami demonstrated its latest and greatest, Kubeapps, an application deployment environment that launches and manages pre-packaged Kubernetes-ready applications and developer tools from within a Kubernetes cluster.&amp;media="
         class="pinterest"
         target="_blank">
        <i class="fa fa-pinterest"></i>
      </a>
              <a class="pinterest"
           target="_blank">
           <i class="fa fa-pinterest"></i>
        </a>
            </div>

          
    <div class="article-content-wrap">
      <div itemprop="articleBody" class="article-content ">
                  <div class="article-banner dfp-ad-hideempty hidden">
            <div data-dfp-position="inarticle1"></div>
          </div>
        
        <p>At KubeCon on Monday, packaged server applications provider Bitnami demonstrated its latest and greatest, Kubeapps, an application deployment environment that launches and manages pre-packaged Kubernetes-ready applications and developer tools from within a Kubernetes cluster.</p>
<p>The company hedged it's bet a bit with this unveiling. At the same time it was demoing the product at the Kubernetes containers conference being held inside the Austin Texas city limits, it was officially launching the product at its headquarters in San Francisco. Evidently the folks at Bitnami wanted to make sure the folks in Silicon Valley took note.</p>
<p class="inline-related"><b>Related:</b> <a href="/amazon-web-services-aws/supported-kubernetes-coming-aws">Supported Kubernetes Coming to AWS</a></p><p>For a couple of reasons, this should be a big hit with the DevOps crowd. To begin with, it's free, released as open source under the Apache 2.0 license, and what DevOps worth his or her salt doesn't like a free tool, especially if it's useful and works as advertised.</p>
<p>Although I haven't had any hands-on experience, the latter should be a given. Bitnami is the company that creates and maintains open source software packages for <a href="http://www.itprotoday.com/cloud-data-center/aws-no-longer-holdout-joins-kubernetes-group" target="_blank">Amazon Web Services</a>, Google Cloud Platform, Microsoft Azure, Oracle Cloud and others. In other words, if you spin up Hadoop on AWS, the package came from Bitnami. The company claims its flagship application automation platform is responsible for over a million deployments per month.</p>
<p class="inline-related"><b>Related:</b> <a href="/cloud-data-center/cncf-wants-you-use-certified-kubernetes">CNCF Wants You to Use 'Certified Kubernetes'</a></p><p>But enough about Bitnami. Let's look at Kubeapps.</p>
<p>The app has three major components, starting with Kubeapps CLI, a command line interface to bootstrap all required tools onto a Kubernetes cluster. There's an Application Dashboard, an in-cluster console for discovery and deployment of Helm charts and Kubeless serverless functions, and a community hub to discover, rate and review pre-packaged Kubernetes applications.</p>
<p> <img src="http://www.itprotoday.com/sites/itprotoday.com/files/kubeapps_0.png" alt="" data-caption="" data-credit="" data-noderef="workspace://SpacesStore/133afe26-a39b-4a07-81c9-c340395b21ca" class="old-inline-image"></p>
<p>The pre-packaged applications part is Kubeapps sweet spot. The app gives access to about 150 pre-packaged applications that are ready to click and deploy as Kubernetes containers. If you need a quick deployment of WordPress, for instance, with a click the container is created, along with a containerized version of MariaDB, which is required by WordPress.</p>
<p>And yes, Bitnami's pre-packaged applications are continuously updated and secure. AWS, GCP and the like would have it no other way.</p>
<p>Users of Kubeapps also won't be pressured into purchasing an "enterprise" or "professional" version of the product. Why? Because there isn't one.</p>
<p>"Most of the Kubernetes Bitnami apps are not monetized at all," Bitnami's VP of marketing, Tom McCafferty, told ITPro. "In a way, we're betting on the future."</p>
<p>The company might eventually monetize the Kubernetes tools it's developing, he said, but when that day comes it will be done in a way that will keep them open source, fully functional and freely available to non-paying users.</p>
<p>For more information, or to download or contribute to to the project, visit Bitnami's <a href="https://kubeapps.com/">Kubeapps web page.</a></p>
        
                                        </div>

      
                <div class="secondary-tags">
      TAGS:              <a href="/software-development/containers" class="secondary-tag">Containers</a>        </div>
      
              
  <div class="comments-wrapper" id="comments-124188">
    <div class="comments">
      <a href="javascript:void(0)" class="comments--show hidden">0 comments</a>    </div>
    <div class="comments-container">
      <div class="fill-comments">
        <div class="comments-header"><span class="comments--hide">Hide comments</span></div>
                  <form class="comment-form" action="/comment/reply/124188" method="post" id="comment-form" accept-charset="UTF-8"><div><div class="user-comment-body">
  <div class="user-comment-field">
    <div class="user-photo">
      <img class="user-thumb-img" src="http://www.itprotoday.com/sites/all/themes/penton_core_theme/images/account-default-image.png" alt="" />    </div>
    <div class="user-content">
      <div class="user-name">
        <a href="/" class="js-penton-user-url-profile"></a>      </div>
      <div class="user-comment">
        <div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="comment_body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label class="element-invisible" for="edit-comment-body-124188">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full ckeditor-mod form-textarea required" placeholder="Be the first to comment..." id="edit-comment-body-124188" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
<fieldset class="filter-wrapper element-invisible form-wrapper" id="edit-comment-body-und-0-format"><div class="fieldset-wrapper"><div class="filter-help form-wrapper" id="edit-comment-body-und-0-format-help"><p><a href="/filter/tips" target="_blank">More information about text formats</a></p></div><div class="form-item form-type-select form-item-comment-body-und-0-format">
  <label for="edit-comment-body-und-0-format--2">Text format </label>
 <select class="filter-list form-select" id="edit-comment-body-und-0-format--2" name="comment_body[und][0][format]"><option value="comments" selected="selected">Comments</option><option value="plain_text">Plain text</option></select>
</div>
<div class="filter-guidelines form-wrapper" id="edit-comment-body-und-0-format-guidelines"><div class="filter-guidelines-item filter-guidelines-comments"><h3>Comments</h3><ul class="tips"><li>Allowed HTML tags: &lt;em&gt; &lt;strong&gt; &lt;blockquote&gt; &lt;br&gt; &lt;p&gt;</li></ul></div><div class="filter-guidelines-item filter-guidelines-plain_text"><h3>Plain text</h3><ul class="tips"><li>No HTML tags allowed.</li><li>Web page addresses and e-mail addresses turn into links automatically.</li><li>Lines and paragraphs break automatically.</li></ul></div></div></div></fieldset>
</div>
<a href="#" class="element-invisible publish js-publish user-comment__publishbtn">Publish</a><span class='comment-error'><a href="/penton_modal/nojs/login" class="ctools-use-modal ctools-modal-modal-popup-login" rel="nofollow">Log in or register to comment</a></span></div></div>      </div>
    </div>
  </div>
</div>
<input type="hidden" name="cid" value="" />
<input type="hidden" name="pid" value="" />
<input type="hidden" name="form_build_id" value="form-TaS0Dm02H0wTcddczKd5RiXe_t8mc_4ink0r-sRV_C8" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<input type="hidden" name="captcha_sid" value="6865439" />
<input type="hidden" name="captcha_token" value="bf93fc0f46a8719812465ca84fcb75d9" />
<input class="mollom-content-id" type="hidden" name="mollom[contentId]" value="" />
<input class="mollom-captcha-id" type="hidden" name="mollom[captchaId]" value="" />
<div style="display: none;"><div class="form-item form-type-textfield form-item-mollom-homepage">
  <label for="edit-mollom-homepage">Home page </label>
 <input autocomplete="off" type="text" id="edit-mollom-homepage" name="mollom[homepage]" value="" size="60" maxlength="128" class="form-text" />
</div>
</div><div class="element-invisible"><div class="form-actions form-wrapper" id="edit-actions"><button id="edit-submit-124188" name="op" value="Save" class="form-submit">Save</button>
</div></div></div></form>                <div class="comments-inner-container">
                  </div>
      </div>
    </div>
  </div>
      
    </div>

    
    <div class="row related-articles-row">
      <div class="related-articles-heading">Related</div><div class="related-articles-wrapper"><a href="/software-development/intuit-acquire-startup-tsheets-deal-valued-340-million" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/GettyImages-495515234.jpg?itok=cZzI_Buu" src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/GettyImages-495515234.jpg?itok=Z5Gry99d" width="90" height="83" alt="Intuit CEO" /></div><div class="small-article__inner"><div class="small-article__inner-title">Intuit to Acquire Startup TSheets in Deal Valued at $340 Million</div><span>Dec 05, 2017</span></div></article></a><a href="/software-development/aws-launches-cloud9-integrated-developer-environment" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/cloud9_collab-1_0.png?itok=Tq8oy7rl" src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/cloud9_collab-1_0.png?itok=t_itvke8" width="90" height="83" alt="cloud9" /></div><div class="small-article__inner"><div class="small-article__inner-title">AWS Launches Cloud9 Integrated Developer Environment</div><span>Dec 04, 2017</span></div></article></a><a href="/software-development/microsoft-releases-windows-10-software-development-kit-sdk-preview-build-17040" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/computer-2557299_640_3.jpg?itok=W_A41Fll" src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/computer-2557299_640_3.jpg?itok=9pKymve7" width="90" height="83" alt="Computer and Worker at Desk Hero Image" /></div><div class="small-article__inner"><div class="small-article__inner-title">Microsoft releases Windows 10 Software Development Kit (SDK) Preview Build 17040</div><span>Nov 28, 2017</span></div></article></a><a href="/software-development/metavine-go-helps-enterprise-users-build-apps-no-coding-skills-necessary" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/ThinkstockPhotos-832109374_1.jpg?itok=Hx9nYLSC" src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/ThinkstockPhotos-832109374_1.jpg?itok=hkOOSbnU" width="90" height="83" alt="app development" /></div><div class="small-article__inner"><div class="small-article__inner-title">Metavine GO Helps Enterprise Users Build Apps, No Coding Skills Necessary</div><span>Nov 22, 2017</span></div></article></a></div>    </div>

    <div class="item-list"><ul class="lazy-pagination"><li class="read-more pagination-read-more next first"><a href="/windows-10/always-connected-pcs-laptops-long-battery-life?parent=124188&infscr=1" rel="nofollow">Load More</a></li>
<li><a href="/security/wall-street-teams-help-save-client-data-cyber-attack" rel="next">Next Article</a></li>
<li class="last"><a href="/machine-learning/demand-ai-talent-turns-once-staid-conference-draft-day" rel="prev">Previous Article</a></li>
</ul></div>
    
  </article>

  
</section>
  </div>
</div>
  </div>

        </div>
                <div class="banner-bottom-wrapper">
          <div id="banner-bottom" class="dfp-ad-hideempty hidden">
            <div data-dfp-position="bottom_banner"></div>
          </div>
        </div>
                <!-- /Main Content Area -->
                  <!-- Footer -->
          <!-- Check to see if we are in the store -->
  <footer class="l-footer l-footer-min ">
    <div class="l-footer-inner">
      <div class="l-footer-info">
        <div class="footer-logo-min">
                      <a href="/"><img class="footer-logo-min__site_logo" src="http://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/footer.png" alt="Logo" /></a>                    <a href="http://www.penton.com/"><img class="footer-logo-min__penton_logo" src="http://www.itprotoday.com/sites/all/themes/penton_core_theme/images/powered_by_penton_360.png" alt="Logo" /></a>        </div>
        <ul class="footer-min-col">
          <li class="footer-min-col__item">
      <a href="/about-us" class="footer-min-col-link">About</a>    </li>
          <li class="footer-min-col__item">
      <a href="http://technology.penton.com/itpro/" class="footer-min-col-link">Advertise</a>    </li>
          <li class="footer-min-col__item">
      <a href="/contact-us" class="footer-min-col-link">Contact Us</a>    </li>
          <li class="footer-min-col__item">
      <a href="/sitemap" class="footer-min-col-link">Sitemap</a>    </li>
            </ul>
      <ul class="footer-min-col no-margin">
        <li class="footer-min-col__item">
      <a href="http://www.penton.com/privacy-policy" class="footer-min-col-link">Privacy Policy</a>    </li>
          <li class="footer-min-col__item">
      <a href="http://www.penton.com/terms-of-service" class="footer-min-col-link">Terms of Service</a>    </li>
          <li class="footer-min-col__item">
      <a href="http://www.penton.com/privacy-policy#ThirdPartyAdvertisingTech" class="footer-min-col-link">Ad Choices</a>    </li>
  </ul>
<div class="social-min-col">
  <p class="social-min-col__label">Follow us:</p>
  <div class="social-icons"><a href="https://www.facebook.com/ITProToday/" title="" class="social-icons__link"><i class="social-icons__icon fa fa-facebook"></i></a><a href="https://twitter.com/ITProToday" title="" class="social-icons__link"><i class="social-icons__icon fa fa-twitter"></i></a><a href="https://plus.google.com/115563256559407060026 " title="" class="social-icons__link"><i class="social-icons__icon fa fa-google-plus"></i></a><a href="https://www.linkedin.com/groups/1163947" title="" class="social-icons__link"><i class="social-icons__icon fa fa-linkedin"></i></a></div></div>
      </div>
      <div class="l-footer-rights">
        <span class="copyrights">
          Copyright&nbsp;&#169; 2017 Penton
        </span>
      </div>
    </div>
  </footer>
          <!-- /Footer -->
              </div>
    </div>
  </div>
</main>
<!-- /Page -->
<div id="hidden-dfp" class="dfp-ad-hideempty hidden">
  <div data-dfp-position="hidden" class="hidden-for-ads"></div>
</div>
      <script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_KUtWmy_QP6atnDjXwpDAH183eelDuv-2PY5ksEFKvNQ.js"></script>
<script type="text/javascript" src="http://www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_8pEoWnUr8ijKw1SExt7kT6gNr85MGL-IZJyQGXvJRP0.js"></script>
<script type="text/javascript" src="//assets.adobedtm.com/2ebe67d2ca0193084439038012c34f9112a85c00/satelliteLib-48191dfa1509ee2d203e3f6eb4bc8a3de3320ce9.js"></script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_eOe-hGqK6-bRjj7DQYO_Y-oCu3MIoF2vYxLUbQbtu4I.js"></script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_3Uw33PZgsGuP7FMg-z8p_cxrG5AL4S5leWudlYRn04E.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.CKEDITOR_BASEPATH = "/sites/all/modules/contrib/ckeditor/ckeditor/"
//--><!]]>
</script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_FloLC-L2hL--gn7qKaXXBNWxL6qI_-SL4q2_WBFL5X4.js"></script>
<script type="text/javascript" src="//video.limelight.com/player/embed.js"></script>
<script type="text/javascript" src="https://embed.calculoid.com/scripts/combined.min.js"></script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_m4Cfw_k95I6kgJagMEdxPTh-eHH8uO3Vg7qfEma7zgI.js"></script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_m0Qm7ZLBa0Us5bK_pvZ1T3hMtRZOtWiklopETCWH6Qk.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
Drupal.settings.penton_eloqua_api = {"fields":["nl","utm_rid"]};
//--><!]]>
</script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_EtdtXxRiphKw3AU6vL8cSYAizvnfl78aifsOby2rJ0U.js"></script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_zAhDpBC1fJmto3nVn5lj_f8L3b2h1VMtdC-bAQuRwDg.js"></script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_KIwLxGMqoJtHLuCU1tBsjwRtZcXqJAAPjkc5R7V3izE.js"></script>
<script type="text/javascript">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</script>
      <script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_yBfMcJqDRqllnqGw9cUCSpLi8jJ_zCvz8eaES44X4xo.js"></script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/all/modules/contrib/ckeditor/ckeditor/ckeditor.js?p03dia"></script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_hTvEvnr-CSP0ayePYXq_lDVR4Xlir2rUBDh7jP_21fI.js"></script>
    </div>
  </body>
</html>
