Windows Server 2003 Needs At Least One Service Pack

If you're running Windows Server 2003 without any service packs then you can no longer install security updates - you need to at least have SP1 installed. Support for Windows Server 2003 without any service pack ended April 10, 2007. So you might have noticed that you can't load the latest security updates issued this month. FYI: Support for SP1 will end April 14, 2009.

A similar situation exists for people still running Windows Vista beta releases. You'll have to load an official release or you won't get any security updates. Nor can you manually download updates and install them. When you try that you'll see a message that tells you the update doesn't apply to your version of Windows.

Hide comments

Comments

  • Allowed HTML tags: <em> <strong> <blockquote> <br> <p>

Plain text

  • No HTML tags allowed.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Lines and paragraphs break automatically.
Publish