JSI Tip 5105. Removing Windows 2000 SP1 or SP2 prompts you to reinstall some programs?

If you remove Windows 2000 Service Pack 1, or Windows 2000 Service Pack 2, after installing Windows Installer version 2.0, you will be prompted to reinstall any program that used the Windows Installer?

Removing the Service Pack in the above situation restores the Windows Installer files to version 1.1. Version 1.1 files can NOT read the version 2.0 database, causing the prompt.

To resolve this issue:

1. Press Cancel when you are prompted to reinstall. 

2. Install Windows Installer 2.0 Redistributable for Windows NT 4.0 and Windows 2000.

NOTE: If the version of Msi.dll file is Version number 2.0.2526.0 or later, you have Windows Installer 2.0 installed.

NOTE: See Released Versions of Windows Installer.



Hide comments

Comments

  • Allowed HTML tags: <em> <strong> <blockquote> <br> <p>

Plain text

  • No HTML tags allowed.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Lines and paragraphs break automatically.
Publish