<!DOCTYPE html>
<html
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#" class="html not-front not-logged-in no-sidebars page-node page-node- page-node-126478 node-type-article header-with-pillar article-article">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <meta charset="utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge, chrome=1" />
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_167x167.png" sizes="167x167" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_180x180.png" sizes="180x180" />
<link rel="shortcut icon" href="http://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="title" content="Heptio Launches Kubernetes Load Balancing Application" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_152x152.png" sizes="152x152" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_76x76.png" sizes="76x76" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch.png" />
<link rel="apple-touch-icon" href="sites/all/themes/penton_subtheme_itprotoday/images/apple-touch-icons/apple-touch_120x120.png" sizes="120x120" />
<meta name="description" content="Container centered startup Heptio has announced the alpha launch of an open source Kubernetes load balancing system that&#039;s legacy friendly." />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="http://www.itprotoday.com/containers/heptio-launches-kubernetes-load-balancing-application" />
<link rel="shortlink" href="http://www.itprotoday.com/node/126478" />
<meta property="og:site_name" content="IT Pro" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Heptio Launches Kubernetes Load Balancing Application" />
<meta property="og:url" content="http://www.itprotoday.com/containers/heptio-launches-kubernetes-load-balancing-application" />
<meta property="og:description" content="Container centered startup Heptio has announced the alpha launch of an open source Kubernetes load balancing system that&#039;s legacy friendly.
" />
<meta property="og:updated_time" content="2018-04-25T13:30:15-04:00" />
<meta property="og:image" content="http://www.itprotoday.com/sites/itprotoday.com/files/see-saw-339506_640_0.jpg" />
<meta property="twitter:card" content="summary" />
<meta property="twitter:url" content="http://www.itprotoday.com/containers/heptio-launches-kubernetes-load-balancing-application" />
<meta property="twitter:title" content="Heptio Launches Kubernetes Load Balancing Application" />
<meta property="article:published_time" content="2018-04-25T09:27:11-04:00" />
<meta property="article:modified_time" content="2018-04-25T13:30:15-04:00" />
<meta property="og:audio" content="http://" />
<meta property="og:audio:secure_url" content="https://" />
<meta property="og:video:url" content="http://" />
<meta property="og:video:secure_url" content="https://" />
<meta property="og:video:type" content="text/html" />
    <title>Heptio Launches Kubernetes Load Balancing Application | IT Pro</title>
    <link type="text/css" rel="stylesheet" href="http://www.itprotoday.com/sites/itprotoday.com/files/css/css_PpiQEI-azlEmknynFVbTW6pWwXhVPT_fbABYbBL6JWQ.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.itprotoday.com/sites/itprotoday.com/files/css/css_DHcXHPYBSjIVaCQZEG4ZlpLkvslnFlBCnQUCzlbRBio.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.itprotoday.com/sites/itprotoday.com/files/css/css_inMHdOMnX3W6U-rjaV-JSK3Nb6lEO-pYEnqH0CBAamM.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.itprotoday.com/sites/itprotoday.com/files/css/css_Jv8M3_6DhmaMxzHrGxifQD16_eNlmYAQ7vIImIbV9Fg.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.itprotoday.com/sites/itprotoday.com/files/css/css_XfX0Zp0iaB6gR6gUEJU2uViEwZbuu_hrLqMUzdpFwG8.css" media="all" />

<!--[if lte IE 9]>
<link type="text/css" rel="stylesheet" href="http://www.itprotoday.com/sites/itprotoday.com/files/css/css_9wlfiD8oXTbaPtNZgtEQpGROzLEj2b7PKL2hqYQntyI.css" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://embed.calculoid.com/styles/main.css" media="all" />
    <!-- HTML5 element support for IE6-8 -->
    <!--[if lt IE 9]>
    <script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
    <![endif]-->
        <script>
      var isblocked = "notblocked";
      console.log('lpage==>' + isblocked);
      var pathname = window.location.pathname;
      var adu = "/3834/itprotoday.home/article/software_development/containers";
      var adblockOn = 1;
    </script>
    <script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
    <script>
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
    </script>
    <script>
      if(adu !== "" && (pathname.indexOf('/cart') < 0) && (pathname.indexOf('/store') < 0) && (pathname.indexOf('/products') < 0) && (pathname.indexOf('/product-types') < 0) && (pathname.indexOf('/store-topics') < 0) && ((pathname.indexOf('/gallery')) !== (pathname.length - 8)) && (pathname.indexOf('/user/login') < 0) && (isblocked == "notblocked") && (pathname.indexOf('penton_ur_thank_you') < 0)  ) {
        var targ_arr = JSON.parse('[{"target":"pos","value":"728_1_a"},{"target":"combo","value":"wrap"},{"target":"ptype","value":"Article"},{"target":"nid","value":"126478"},{"target":"pterm","value":"containers"},{"target":"author","value":"christine_hall"},{"target":"reg","value":"anonymous"}]');
        googletag.cmd.push(function() {
          var welcome_ad = googletag.defineSlot(adu, [1, 1], "div-interstitial");
          welcome_ad.addService(googletag.pubads());
          welcome_ad.setTargeting("pos", "interstitial_a");
          for(var i=0; i<targ_arr.length; i++) {
            var targ = targ_arr[i]['target'];
            var val = targ_arr[i]['value'].split(',');
            if(targ !== 'pos' && targ !== 'combo') {
              welcome_ad.setTargeting(targ, val);
            }
          }

          setTimeout(function() {
            console.log('adblockval');console.log(adblockOn);
            if(adblockOn == 1) {
              var bDiv = document.getElementById("body-wrapper");
              window.scrollTo(0, 0);
              if(bDiv.style.removeProperty) {
                bDiv.style.removeProperty('opacity');
              } else {
                bDiv.style.removeAttribute('opacity');
              }
            }
          }, 2000);

          googletag.pubads().addEventListener('slotRenderEnded', function(event) {
            adblockOn = 0;
            if(event.slot.getSlotElementId() == "div-interstitial") {
              if(event.isEmpty) {
                console.log('emptyInterstitial');
                var bDiv = document.getElementById("body-wrapper");
                window.scrollTo(0, 0);
                if(bDiv.style.removeProperty) {
                  bDiv.style.removeProperty('opacity');
                } else {
                  bDiv.style.removeAttribute('opacity');
                }
              } else {
                console.log('notemptyInterstitial');
              }

              var dfplogpatt = new RegExp('dfp_log');
              var isDebug = dfplogpatt.test(location.search);
              if(isDebug) {
                console.log('%c********DFPTag: Interstitial********', 'font-size:medium;font-style:bold');
                console.log('adunit: '+adu);
                console.log('targetingpair==> pos:interstitial_a');
                for(var i=0; i<targ_arr.length; i++) {
                  var targ = targ_arr[i]['target'];
                  var val = targ_arr[i]['value'].split(',');
                  if(targ !== 'pos' && targ !== 'combo') {
                    console.log('targetingpair==> '+targ+':'+val);
                  }
                }
                console.log('adsize: [1, 1]');
                console.log('oop: false');
                console.log('%c************************************', 'font-size:medium;font-style:bold');
              }
            }
          });
          googletag.enableServices();
        });
      }
    </script>
      </head>
  <body>
        <div id="wl_flogop_div" class="hidden">http://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/footer.png</div>
    <div id="div-interstitial">
      <script>
        if(adu !== "" && (pathname.indexOf('/cart') < 0) && (pathname.indexOf('/store') < 0) && (pathname.indexOf('/products') < 0) && (pathname.indexOf('/product-types') < 0) && (pathname.indexOf('/store-topics') < 0) && ((pathname.indexOf('/gallery')) !== (pathname.length - 8)) && (pathname.indexOf('/user/login') < 0) && (isblocked == "notblocked") && (pathname.indexOf('penton_ur_thank_you') < 0)  ) {
          googletag.cmd.push(function() {
            googletag.display("div-interstitial");
          });
        }
      </script>
    </div>
        <div id="body-wrapper"  style="opacity:0;" >
            <header class="header js-header">
  <!-- Pillar Navigation region -->
<nav class="pillar-nav">
<div id="block-menu-menu-pillar-navigation" class="pillar-nav__inner l-content clearfix">
  <div class="pillar-nav__header">Discover:</div>
  <ul class="pillar-nav__items js-menumore-discover"><li class="pillar-nav__item js-menumore-item-text  "><a href="/software-development">Dev Pro</a></li>
<li class="pillar-nav__item js-menumore-item-text  "><a href="/collaboration/microsoft-sharepoint">SharePoint Pro</a></li>
<li class="pillar-nav__item js-menumore-item-text  "><a href="/business-intelligence/microsoft-sql-server">SQL Server Pro</a></li>
<li class="pillar-nav__item js-menumore-item-text  "><a href="http://www.devconnections.com/">IT/Dev Connections</a></li>
<li class="pillar-nav__item js-menumore-item-text  "><a href="http://www.itprotoday.com/itdev-connections-ondemand">IT/Dev Connections OnDemand</a></li>
<li class="pillar-nav__item js-menumore-item-text  "><a href="https://tmt.knect365.com/container-world/">Container World</a></li>
<li class="pillar-nav__item js-menumore-item-text  "><a href="https://tmt.knect365.com/iot-world/">IoT World</a></li>

    <li class="pillar-nav__item pillar-more js-menumore-more-item">
      <a class="pillar-more-btn">More<i class="fa fa-caret-down"></i></a>
      <ul class="pillar-list-nested js-menumore-sub"></ul>
    </li>
  </ul></div>
</nav>
<!-- /Pillar Navigation region -->
  <!-- Header -->
  <div class="header-inner l-content">
    <!-- Hamburger menu -->
<div class="menu-toggler js-ham-menu-toggler">
  <div class="menu-toggler-img-wrap js-menu-toggler">
    <div class="menu-toggler-hamburger active">
      <div class="hamburger-text">Menu</div>
      <div class="hamburger-line"></div>
      <div class="hamburger-line"></div>
      <div class="hamburger-line"></div>
    </div>
  </div>
  <aside class="hamburger-menu">
    <div class="hamburger-menu-inner clearfix js-toggle-menu js-sticky-ham-menu">
      <div class="hamburger-menu-container">
                  <div class="user-thumb-text">
            <a href="/penton_modal/nojs/login" class="ctools-use-modal sattelite-event-caller sattelite-event-caller__hamburger-clicked ctools-modal-modal-popup-login" rel="nofollow">Log In</a> or <a href="/penton_modal/nojs/register/basic" class="ctools-use-modal sattelite-event-caller sattelite-event-caller__hamburger-clicked ctools-modal-modal-popup-medium" rel="nofollow">Register</a>          </div>
                <ul class="hamburger-menu-nav"><li class="hamburger-menu-nav__item"><a href="/cloud-data-center" title="">Cloud &amp; Data Center</a></li><li class="hamburger-menu-nav__item"><a href="/business-intelligence" title="">Business Intelligence</a></li><li class="hamburger-menu-nav__item"><a href="/collaboration" title="">Collaboration</a></li><li class="hamburger-menu-nav__item"><a href="/management-mobility" title="">Management and Mobility</a></li><li class="hamburger-menu-nav__item"><a href="/software-development" title="">Software Development</a></li><li class="hamburger-menu-nav__item"><a href="/security" title="">Security</a></li><li class="hamburger-menu-nav__item"><a href="/next-gen/iot" title="">Internet of Things (IoT)</a></li><li class="hamburger-menu-nav__item"><a href="/podcasts" title="">Podcasts</a></li></ul><ul class="hamburger-menu-sub-nav"><li class="hamburger-menu-sub-nav__item"><a href="/business-resources" title="">Business Resources</a></li><li class="hamburger-menu-sub-nav__item"><a href="https://itdevconnections.com/dc18/Public/Enter.aspx" title="">IT/Dev Connections</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://www.itprotoday.com/itdev-connections-ondemand" title="">IT/Dev Connections OnDemand</a></li><li class="hamburger-menu-sub-nav__item"><a href="/webcasts" title="">Webcasts</a></li><li class="hamburger-menu-sub-nav__item"><a href="/industry-perspectives" title="">Industry Perspectives</a></li><li class="hamburger-menu-sub-nav__item"><a href="/whitepapers" title="">Whitepapers</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://www.itprotoday.com/business-resources/technology-providers-company-profiles" title="">Technology Provider</a></li><li class="hamburger-menu-sub-nav__item"><a href="/newsletters/signup" title="">Newsletter Preference</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://www.itprotoday.com/advertise-itpro-today" title="">Advertise</a></li><li class="hamburger-menu-sub-nav__item"><a href="/about-us" title="">About Us</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://engage.informa.com/privacy-statement" title="">Privacy Statement</a></li><li class="hamburger-menu-sub-nav__item"><a href="http://www.penton.com/terms-of-service/" title="">Terms of Service</a></li></ul><div class="social-icons"><a href="https://www.facebook.com/ITProToday/" title="" class="social-icons__link"><i class="social-icons__icon fa fa-facebook"></i></a><a href="https://twitter.com/ITProToday" title="" class="social-icons__link"><i class="social-icons__icon fa fa-twitter"></i></a><a href="https://plus.google.com/115563256559407060026 " title="" class="social-icons__link"><i class="social-icons__icon fa fa-google-plus"></i></a><a href="https://www.linkedin.com/groups/1163947" title="" class="social-icons__link"><i class="social-icons__icon fa fa-linkedin"></i></a></div>              </div>
    </div>
  </aside>
</div>
<!-- /Hamburger menu -->
    <!-- Header Logo -->
    <div class="header-logo">
                      <a href="/" class="header-logo__link"><img src="http://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/header.png" alt="IT Pro" title="IT Pro" /></a>                  </div>
    <!-- /Header Logo -->
          <!-- Header User links -->
      <ul class="header-nav">
                  <li class="header-nav__item header-nav__item__search">
            <a href="/search" class="header-nav-link"><i class="fa fa-search"></i>Search</a>          </li>
                          <li class="header-nav__item no-mobile">
            <a href="/penton_modal/nojs/login" class="ctools-use-modal ctools-modal-modal-popup-login header-nav-link" rel="nofollow">Log In</a>          </li>
          <li class="header-nav__item no-mobile last">
            <a href="/penton_modal/nojs/register/basic" class="ctools-use-modal ctools-modal-modal-popup-medium header-nav-link sattelite-event-caller sattelite-event-caller__header-clicked" rel="nofollow">Register</a>          </li>
                <!-- Cart -->
                <!-- /Cart -->
      </ul>
      </div>

  <!-- legal communication alert -->
  <div class="js-penton-legal-comm-ajax-output-alert">
      </div>
  <!-- /legal communication alert -->
<!-- /Header -->
</header>
<!-- Page -->
<main>
  <div id="page-wraper">
    <!-- Header Adv -->
    <div class="banner-top-wrapper">
      <div id="banner-top" class="dfp-ad-hideempty hidden">
        <div data-dfp-position="top_banner"></div>
      </div>
    </div>
        <!-- Admin Tabs -->
          <section id="admin-tabs" class="l-content">
              </section>
        <!-- /Admin Tabs -->
    <!-- /Header Adv -->
    <div class="wrapper l-content">
                                <!-- Sidebar -->
        <aside id="sidebar" class="l-sidebar sidebar">
            <div class="region region-left-col">
          <div class="slide-out-sidebar-button js-expand-sidebar">
        <span class="slide-out-recent">Recent</span>
      </div>
        <div class="sidebar-scrollable js-sticky-leftcol">
      <section id="penton_recent_content_block">
  <aside>
    <div class="r-a-header">Recent</div>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/iot/american-cities-fight-losing-battle-over-wireless-internet">
            American Cities Fight Losing Battle Over Wireless Internet            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Apr 25, 2018</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/machine-learning/why-microsoft-has-bet-fpgas-infuse-its-cloud-ai">
            Why Microsoft Has Bet on FPGAs to Infuse Its Cloud With AI            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Apr 25, 2018</span>        </span>
          </div>
  </div>
</article>
            <div class="banner-aside-wrapper dfp-ad-hideempty">
      <div class="banner-aside js-sticky-banner dfp-ad-hideempty hidden"">
        <div data-dfp-position="left_rail_rect"></div>
      </div>
    </div>
    <hr>
              
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/premisecloud/googles-new-spending-surge-shows-company-playing-catch">
            Google&#039;s New Spending Surge Shows a Company Playing Catch-Up            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Apr 24, 2018</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/high-speed-storage/3d-xpoint-technology-could-be-boon-ai-ml">
            3D XPoint Technology Could Be a Boon for AI, ML            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Apr 24, 2018</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/iot/bosch-exec-talks-industrie-40-trends-hannover-messe-2018">
            Bosch Exec Talks Industrie 4.0 Trends at Hannover Messe 2018            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Apr 24, 2018</span>        </span>
          </div>
  </div>
</article>
      </aside>
</section>


<section id="penton_featured_content_block">
  <aside>
    <div class="r-a-header">Featured</div>
          
<article class="article-teaser article-teaser__icon__white-paper article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/business-intelligence/automating-it-operations">
            Automating IT Operations            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Mar 08, 2018</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/microsoft-azure/government-cloud-adoption-demands-change-people-and-policy">
            Government Cloud Adoption Demands Change in People and Policy            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Mar 24, 2018</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__article article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/risk-and-compliance/gdpr-checklist-getting-ready-new-regulations-europe">
            GDPR Checklist - Getting Ready for New Regulations in Europe            <i class="fa "></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Mar 08, 2018</span>        </span>
          </div>
  </div>
</article>
          
<article class="article-teaser article-teaser__icon__gallery article-teaser__aside">
    <div class="article-teaser__content">
    <div class="article-teaser__header">
      <div class="title">
          <a href="/windows-10/windows-10-redstone-4-build-tracker-pcs-0">
            Windows 10 (Redstone 4) Build Tracker for PCs            <i class="fa fa-camera"></i>
          </a>
      </div>
              <span>
          <span class="date-display-single">Apr 17, 2018</span>        </span>
          </div>
  </div>
</article>
      </aside>
</section>
    </div>
  </div>
        </aside>
        <!-- /Sidebar -->
            <!-- Main Content Area -->
      <div class="page main-area l-main-area">
        <div id="main_content" class="clearfix">
          
            <div class="region region-main-col">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <section class="main-articles-container js-lazy-pager-wrapper">

    <article itemscope itemtype="http://schema.org/NewsArticle" class=" big-article article-type-article article-126478 node-type-article with-feat-img article-standalone js-lazy-pager-content"  data-nid="126478" data-url="/containers/heptio-launches-kubernetes-load-balancing-application" data-title="Heptio Launches Kubernetes Load Balancing Application" data-seo-title="Heptio Launches Kubernetes Load Balancing Application" data-type="article" data-terms="software_development/containers" data-ptermhier="Software Development &gt; Containers" data-pterm="Containers" data-sterm="" data-program="" data-tax="Containers" data-ext="" data-author="Christine Hall" data-pub="Apr 25, 2018" data-visibility="visible" data-perm="public" data-pid="efda269d-8129-48d6-a452-c9339a0f5cd7" data-content="">
    <meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="http://www.itprotoday.com/containers/heptio-launches-kubernetes-load-balancing-application"/>
    <meta itemprop="datePublished" content="2018-04-25T17:27:00-04:00"/>    <meta itemprop="dateModified" content="2018-04-25T13:30:15-04:00"/>
              <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
          <meta itemprop="url" content="http://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/header.png">
          <meta itemprop="width" content="980">
          <meta itemprop="height" content="173">
        </div>
        <meta itemprop="name" content="IT Pro">
      </div>
    
    <div class="big-article__top">

      
              <div class="big-article__image" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
          <img class="medium js-imgpxr" data-x2src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_featured_retina/public/see-saw-339506_640_0.jpg?itok=nuYYd8Iu" src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_featured_standard/public/see-saw-339506_640_0.jpg?itok=YpFyIqCx" width="770" height="400" alt="Kubernetes, load balancer, containers" title="Kubernetes, load balancer, containers" />          <meta itemprop="url" content="http://www.itprotoday.com/sites/itprotoday.com/files/see-saw-339506_640_0.jpg">
          <meta itemprop="width" content="640">
          <meta itemprop="height" content="395">

                      <span class="text-to-image">Pixabay</span>
                  </div>
              
      <div class="big-article__head row">
        <div class="heading ">
                    <div class="breadcrumbs"><span class="parent-category"><a href="/software-development">Software Development</a><span>&gt;</span></span><a href="/software-development/containers">Containers</a></div>          <h1 itemprop="headline">Heptio Launches Kubernetes Load Balancing Application</h1>
                      <div itemprop="description">
              
  <div class="field field-name-field-penton-content-summary field-type-text-long field-label-hidden">
    Container centered startup Heptio has announced the alpha launch of an open source Kubernetes load balancing system that's legacy friendly.
  </div>
            </div>
                                <p class="author-and-date" itemprop="author" itemscope="" itemtype="https://schema.org/Person"><span itemprop="name"><a href="/author/christine-hall" itemprop="url">Christine Hall</a></span> | <span class="date-display-single">Apr 25, 2018</span></p>
                  </div>
      </div>

      
    </div>

          <div class="share-icons">
            <a href="/penton_modal/nojs/print/126478"
         class="print ctools-use-modal ctools-modal-modal-popup-basic"
         rel="nofollow">
        <i class="fa fa-print"></i>
      </a>
          <a href="/penton_modal/nojs/forward/126478/0"
         class="envelope ctools-use-modal ctools-modal-modal-popup-basic-email"
         rel="nofollow">
        <i class="fa fa-envelope"></i>
      </a>
                  <a href="http://www.facebook.com/sharer.php?u=http://www.itprotoday.com/containers/heptio-launches-kubernetes-load-balancing-application&amp;t=Heptio Launches Kubernetes Load Balancing Application"
         class="facebook"
         target="_blank">
        <i class="fa fa-facebook"></i>
      </a>
                <a href="https://plus.google.com/share?url=http://www.itprotoday.com/containers/heptio-launches-kubernetes-load-balancing-application"
         class="google-plus"
         target="_blank">
        <i class="fa fa-google-plus"></i>
      </a>
                <a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http://www.itprotoday.com/containers/heptio-launches-kubernetes-load-balancing-application&amp;title=Heptio Launches Kubernetes Load Balancing Application&amp;summary=It's not yet ready for prime time, but on Monday Seattle-based startup Heptio announced it's bringing a Kubernetes load balancing solution to market. The project, Gimbal, is the result of a collaboration with Actapio, a subsidiary of Yahoo Japan Corporation.&amp;source=IT Pro"
         class="linkedin"
         target="_blank">
        <i class="fa fa-linkedin"></i>
      </a>
                <a href="http://twitter.com/share?url=http://www.itprotoday.com/containers/heptio-launches-kubernetes-load-balancing-application&amp;text=Heptio Launches Kubernetes Load Balancing Application"
         class="twitter"
         target="_blank">
        <i class="fa fa-twitter"></i>
      </a>
                <a href="http://pinterest.com/pin/create/button/?url=http://www.itprotoday.com/containers/heptio-launches-kubernetes-load-balancing-application&amp;description=It's not yet ready for prime time, but on Monday Seattle-based startup Heptio announced it's bringing a Kubernetes load balancing solution to market. The project, Gimbal, is the result of a collaboration with Actapio, a subsidiary of Yahoo Japan Corporation.&amp;media="
         class="pinterest"
         target="_blank">
        <i class="fa fa-pinterest"></i>
      </a>
              <a class="pinterest"
           target="_blank">
           <i class="fa fa-pinterest"></i>
        </a>
            </div>

          
    <div class="article-content-wrap">
      <div itemprop="articleBody" class="article-content ">
                  <div class="article-banner dfp-ad-hideempty hidden">
            <div data-dfp-position="inarticle1"></div>
          </div>
                          
        <p>It's not yet ready for prime time, but on Monday Seattle-based startup Heptio announced it's bringing a Kubernetes load balancing solution to market. The project, Gimbal, is the result of a collaboration with Actapio, a subsidiary of Yahoo Japan Corporation.</p>
<p>We might call this "software defined load balancing," because it's all done with ones and zeros, without any need for expensive hardware, but it can work in conjunction with existing hardware-based load balancing infrastructures. This being Heptio, the software is designed to bring load balancing to containers and container clusters, working hand-in-hand with Kubernetes, something that most hardware driven load balancing solutions aren't designed to do.</p>
<p class="inline-related"><b>Related:</b> <a href="/containers/heptios-craig-mcluckie-kubernetes-orchestrations-start-google">Heptio&#039;s Craig McLuckie On Kubernetes Orchestration&#039;s Start at Google</a></p><p>"Even the software load balancing systems were not really built around the container universe," Heptio's co-founder and CEO, Craig McLuckie, told ITPro Today in an interview that included Joe Beda, also a co-founder and the company's CTO. "If you think about Nginx and HAProxy, it's an older generation of technology that doesn't fit as well into the Kubernetes ecosystem. What we've tried to create here is something that's cloud native really, but also legacy workload friendly."</p>
<p>Gimbal routes high volume traffic into both Kubernetes clusters and existing solutions like OpenStack that often live side by side in enterprise data centers. Because it's a cloud native solution, it can handle the dynamic nature of managing Kubernetes workloads.</p>
<p class="inline-related"><b>Related:</b> <a href="/cloud-data-center/microsoft-and-heptio-bring-ark-azure-kubernetes">Microsoft and Heptio to Bring &#039;Ark&#039; to Azure Kubernetes</a></p><p>The project began development after Actapio sought Heptio's help in developing a Kubernetes load balancing system that could take advantage of cloud native technologies while keeping useful legacy applications in play.</p>
<p>"As they looked to move to containers in Kubernetes, they wanted to find a way to seamlessly shift these applications from being OpenStack only, to being split between OpenStack and Kubernetes, and then eventually to be completely Kubernetes," Beda explained. "By extracting the load balancing from being sort of one to one between a hardware device and the OpenStack cluster to being something that's a software system that's scalable and actually sits in front of a set of clusters, they are able to achieve that goal of being able to move applications around and shift the load balancing targeting as the applications move."</p>
<p>The project is built to work with Envoy, an open source&nbsp;<a href="http://www.itprotoday.com/software-development/kubernetes-aws-leads-cncf-cloud-native-survey" target="_blank">Cloud Native Computing Foundation</a> project originally developed by Lyft to help the ride sharing company move away from a monolithic architecture to take advantage of containers and other cloud native technologies.</p>
<p>At present, a single Gimbal deployment won't scale across multiple clouds, but is confined to the data center or public cloud on which it's installed. According to McLuckie, however, a hybrid cloud using multiple cloud providers can use it both on-prem and on each cloud service being leveraged with multiple installations.</p>
<p>"While it's not really set up to manage load balancing in to multiple cloud deployments, it is something that you can run in a variety of different cloud environments," McLuckie said. "You can have a standard way to set up or manage a load balancing function that works on Amazon, Google, Microsoft or on-prem."</p>
<p>It's not surprising that Actapio turned to Heptio for help with with its efforts to get Kubernetes into its OpenStack environment. Heptio's co-founders, along with Microsoft's Brendan Burns, were the&nbsp;<a href="http://www.itprotoday.com/containers/heptios-craig-mcluckie-kubernetes-orchestrations-start-google">original developers of Kubernetes,</a> and were responsible for convincing Google to release it under an open source license.</p>
<p>There's also no surprise that Gimbal is being released as open source. Like Red Hat, Heptio is a pure open source player and has released all of its products -- a list that includes&nbsp;<a href="http://www.itprotoday.com/cloud-data-center/microsoft-and-heptio-bring-ark-azure-kubernetes">Ark,</a> Sonobuoy, ksonnet, and Contour -- as open source.</p>
<p>Actapio's parent company, Yahoo Japan, also has open source DNA in its blood, especially on the hardware side. The company is an active community member of the&nbsp;<a href="http://www.datacenterknowledge.com/hardware/will-open-compute-fall-victim-cloud-s-success">Open Compute Project</a> (OCP), an organization started by Facebook to share data center designs in an open source manner. On April 17, the company announced that a new data center it's building in Washington State will be built using OCP designs.</p>
<p>So when will Gimbal be ready to fly solo?</p>
<p>"It's something that is still in active development," McLuckie said. "It will take, I would say, months rather than years before we get it to a point where we consider it production ready. Our preference is always to put something out there early so that we can bring the [open source] community along rather than waiting a long time and then dropping something that isn't necessarily shaped by the community itself."</p>
<p>Anyone who wants to take a test spin can&nbsp;<a href="https://github.com/heptio/gimbal">download it on GitHub.</a></p>
        
                                        </div>

      
      
              
  <div class="comments-wrapper" id="comments-126478">
    <div class="comments">
      <a href="javascript:void(0)" class="comments--show hidden">0 comments</a>    </div>
    <div class="comments-container">
      <div class="fill-comments">
        <div class="comments-header"><span class="comments--hide">Hide comments</span></div>
                  <form class="comment-form" action="/comment/reply/126478" method="post" id="comment-form" accept-charset="UTF-8"><div><div class="user-comment-body">
  <div class="user-comment-field">
    <div class="user-photo">
      <img class="user-thumb-img" src="http://www.itprotoday.com/sites/all/themes/penton_core_theme/images/account-default-image.png" alt="" />    </div>
    <div class="user-content">
      <div class="user-name">
        <a href="/" class="js-penton-user-url-profile"></a>      </div>
      <div class="user-comment">
        <div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="comment_body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label class="element-invisible" for="edit-comment-body-126478">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full ckeditor-mod form-textarea required" placeholder="Be the first to comment..." id="edit-comment-body-126478" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
<fieldset class="filter-wrapper element-invisible form-wrapper" id="edit-comment-body-und-0-format"><div class="fieldset-wrapper"><div class="filter-help form-wrapper" id="edit-comment-body-und-0-format-help"><p><a href="/filter/tips" target="_blank">More information about text formats</a></p></div><div class="form-item form-type-select form-item-comment-body-und-0-format">
  <label for="edit-comment-body-und-0-format--2">Text format </label>
 <select class="filter-list form-select" id="edit-comment-body-und-0-format--2" name="comment_body[und][0][format]"><option value="comments" selected="selected">Comments</option><option value="plain_text">Plain text</option></select>
</div>
<div class="filter-guidelines form-wrapper" id="edit-comment-body-und-0-format-guidelines"><div class="filter-guidelines-item filter-guidelines-comments"><h3>Comments</h3><ul class="tips"><li>Allowed HTML tags: &lt;em&gt; &lt;strong&gt; &lt;blockquote&gt; &lt;br&gt; &lt;p&gt;</li></ul></div><div class="filter-guidelines-item filter-guidelines-plain_text"><h3>Plain text</h3><ul class="tips"><li>No HTML tags allowed.</li><li>Web page addresses and e-mail addresses turn into links automatically.</li><li>Lines and paragraphs break automatically.</li></ul></div></div></div></fieldset>
</div>
<a href="#" class="element-invisible publish js-publish user-comment__publishbtn">Publish</a><span class='comment-error'><a href="/penton_modal/nojs/login" class="ctools-use-modal ctools-modal-modal-popup-login" rel="nofollow">Log in or register to comment</a></span></div></div>      </div>
    </div>
  </div>
</div>
<input type="hidden" name="cid" value="" />
<input type="hidden" name="pid" value="" />
<input type="hidden" name="form_build_id" value="form-XZiu71KAvEIqAH2c0QrfH8e1HlzmqBukfNiBF1kyeOQ" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<input type="hidden" name="honeypot_time" value="1524707155|sVVs4m2qVuq97wPKnr3G3k3ogCPeR72AZnR_RlhuuMU" />
<input type="hidden" name="captcha_sid" value="25707856" />
<input type="hidden" name="captcha_token" value="b15dd46884918f541e0cc02b06912f38" />
<div class="element-invisible"><div class="form-actions form-wrapper" id="edit-actions"><button id="edit-submit-126478" name="op" value="Save" class="form-submit">Save</button>
</div></div><div class="url-textfield"><div class="form-item form-type-textfield form-item-url">
  <label for="edit-url">Leave this field blank </label>
 <input autocomplete="off" type="text" id="edit-url" name="url" value="" size="20" maxlength="128" class="form-text" />
</div>
</div></div></form>                <div class="comments-inner-container">
                  </div>
      </div>
    </div>
  </div>
      
    </div>

    
    <div class="row related-articles-row">
      <div class="related-articles-heading">Related</div><div class="related-articles-wrapper"><a href="/open-source/netflixs-container-management-system-now-open-source" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/Link%20-%20netflix-2705725_640.jpg?itok=wRlueodm" src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/Link%20-%20netflix-2705725_640.jpg?itok=ySvzISRv" width="90" height="83" alt="Netflix, Titus, open source, containers" /></div><div class="small-article__inner"><div class="small-article__inner-title">Netflix's Container Management System Is Now Open Source</div><span>Apr 20, 2018</span></div></article></a><a href="/containers/open-container-initiative-sets-container-distribution-standard" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/Link%20-%20containers.jpg?itok=bgUV8lsh" src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/Link%20-%20containers.jpg?itok=WDWpXg0s" width="90" height="83" alt="OCI, containers, distribution" /></div><div class="small-article__inner"><div class="small-article__inner-title">Open Container Initiative Sets Container Distribution Standard</div><span>Apr 13, 2018</span></div></article></a><a href="/hybrid-cloud/new-ibm-mainframes-deliver-more-capacity-much-smaller-footprint" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/GettyImages-109503852_3.jpg?itok=Vlsmxjb2" src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/GettyImages-109503852_3.jpg?itok=FczfHE8A" width="90" height="83" alt="IBM mainframes" /></div><div class="small-article__inner"><div class="small-article__inner-title">New IBM Mainframes Deliver More Capacity with Much Smaller Footprint</div><span>Apr 10, 2018</span></div></article></a><a href="/containers/your-quick-guide-containerization" class="small-article-link"><article class="small-article"><div class="img-crop"><img class="js-imgpxr" data-x2src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_retina/public/container-2934279_640_1.jpg?itok=N8nz35ml" src="http://www.itprotoday.com/sites/itprotoday.com/files/styles/article_related_thumb_standard/public/container-2934279_640_1.jpg?itok=6aqe3BBd" width="90" height="83" alt="Here&#039;s a crane amongst some shipping containers" /></div><div class="small-article__inner"><div class="small-article__inner-title">Your Quick Guide to Containerization</div><span>Apr 05, 2018</span></div></article></a></div>    </div>

    <div class="item-list"><ul class="lazy-pagination"><li class="read-more pagination-read-more next first"><a href="/hybrid-cloud/it-budgets-shift-address-cloud-security-threats?parent=126478&infscr=1" rel="nofollow">Load More</a></li>
<li><a href="/iot/arm-mbed-gets-expanded-iot-and-security-capabilities" rel="next">Next Article</a></li>
<li class="last"><a href="/machine-learning/why-microsoft-has-bet-fpgas-infuse-its-cloud-ai" rel="prev">Previous Article</a></li>
</ul></div>
    
  </article>

  
</section>
  </div>
</div>
  </div>

        </div>
                <div class="banner-bottom-wrapper">
          <div id="banner-bottom" class="dfp-ad-hideempty hidden">
            <div data-dfp-position="bottom_banner"></div>
          </div>
        </div>
                <!-- /Main Content Area -->
                  <!-- Footer -->
          <!-- Check to see if we are in the store -->
  <footer class="l-footer l-footer-min ">
    <div class="l-footer-inner">
      <div class="l-footer-info">
        <div class="footer-logo-min">
                      <a href="/"><img class="footer-logo-min__site_logo" src="http://www.itprotoday.com/sites/all/themes/penton_subtheme_itprotoday/images/logos/footer.png" alt="Logo" /></a>                    <div class="small-12 medium-5 columns">
            <div class="footer-links">
              <a href="https://informa.com/"><img src="/sites/all/themes/penton_core_theme/images/powered_by_informa_businessline.png" alt="Powered by Informa" /></a>            </div>
          </div>
        </div>
        <ul class="footer-min-col">
          <li class="footer-min-col__item">
      <a href="/about-us" class="footer-min-col-link">About</a>    </li>
          <li class="footer-min-col__item">
      <a href="http://www.itprotoday.com/advertise-itpro-today" class="footer-min-col-link">Advertise</a>    </li>
          <li class="footer-min-col__item">
      <a href="/contact-us" class="footer-min-col-link">Contact Us</a>    </li>
          <li class="footer-min-col__item">
      <a href="/sitemap" class="footer-min-col-link">Sitemap</a>    </li>
            </ul>
      <ul class="footer-min-col no-margin">
        <li class="footer-min-col__item">
      <a href="http://engage.informa.com/privacy-statement" class="footer-min-col-link">Privacy Policy</a>    </li>
          <li class="footer-min-col__item">
      <a href="http://engage.informa.com/terms-of-service" class="footer-min-col-link">Terms of Service</a>    </li>
          <li class="footer-min-col__item">
      <a href="http://www.penton.com/privacy-policy#ThirdPartyAdvertisingTech" class="footer-min-col-link">Ad Choices</a>    </li>
  </ul>
<div class="social-min-col">
  <p class="social-min-col__label">Follow us:</p>
  <div class="social-icons"><a href="https://www.facebook.com/ITProToday/" title="" class="social-icons__link"><i class="social-icons__icon fa fa-facebook"></i></a><a href="https://twitter.com/ITProToday" title="" class="social-icons__link"><i class="social-icons__icon fa fa-twitter"></i></a><a href="https://plus.google.com/115563256559407060026 " title="" class="social-icons__link"><i class="social-icons__icon fa fa-google-plus"></i></a><a href="https://www.linkedin.com/groups/1163947" title="" class="social-icons__link"><i class="social-icons__icon fa fa-linkedin"></i></a></div></div>
      </div>
      <div class="l-footer-rights">
        <span class="copyrights">
          &#169; 2018 Informa USA, Inc., All Rights Reserved
        </span>
      </div>
    </div>
  </footer>
          <!-- /Footer -->
              </div>
    </div>
  </div>
</main>
<!-- /Page -->
<div id="hidden-dfp" class="dfp-ad-hideempty hidden">
  <div data-dfp-position="hidden" class="hidden-for-ads"></div>
</div>
      <script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_KUtWmy_QP6atnDjXwpDAH183eelDuv-2PY5ksEFKvNQ.js"></script>
<script type="text/javascript" src="http://www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_s3L_uC35AiN5EGYY533su-jccnLRp2aKpOnjgPLbo34.js"></script>
<script type="text/javascript" src="//assets.adobedtm.com/2ebe67d2ca0193084439038012c34f9112a85c00/satelliteLib-48191dfa1509ee2d203e3f6eb4bc8a3de3320ce9.js"></script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_eOe-hGqK6-bRjj7DQYO_Y-oCu3MIoF2vYxLUbQbtu4I.js"></script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_3Uw33PZgsGuP7FMg-z8p_cxrG5AL4S5leWudlYRn04E.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.CKEDITOR_BASEPATH = "/sites/all/modules/contrib/ckeditor/ckeditor/"
//--><!]]>
</script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_FloLC-L2hL--gn7qKaXXBNWxL6qI_-SL4q2_WBFL5X4.js"></script>
<script type="text/javascript" src="//video.limelight.com/player/embed.js"></script>
<script type="text/javascript" src="https://embed.calculoid.com/scripts/combined.min.js"></script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_m4Cfw_k95I6kgJagMEdxPTh-eHH8uO3Vg7qfEma7zgI.js"></script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_m0Qm7ZLBa0Us5bK_pvZ1T3hMtRZOtWiklopETCWH6Qk.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
Drupal.settings.penton_eloqua_api = {"fields":["nl","utm_rid"]};
//--><!]]>
</script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_2QLg0QavkHsRBi6FWUcTxM-mYPG7L5TNgt9uS3ypY4Q.js"></script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_ywc9dAUJSKyPb9vtClfeSL-atpFcz95avlXpvCer_HI.js"></script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_KIwLxGMqoJtHLuCU1tBsjwRtZcXqJAAPjkc5R7V3izE.js"></script>
<script type="text/javascript">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</script>
      <script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_yBfMcJqDRqllnqGw9cUCSpLi8jJ_zCvz8eaES44X4xo.js"></script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/all/modules/contrib/ckeditor/ckeditor/ckeditor.js?p7bl11"></script>
<script type="text/javascript" src="http://www.itprotoday.com/sites/itprotoday.com/files/js/js_hTvEvnr-CSP0ayePYXq_lDVR4Xlir2rUBDh7jP_21fI.js"></script>
    </div>
  </body>
</html>
