Windows 8.1, Outlook Web App, and IE11

Windows 8.1, Outlook Web App, and IE11

Apparently, over two million people have downloaded Windows 8.1 RTM since the software was released by Microsoft. I’m in that category as I have an awful weakness for wanting to use new software; even worse, I have a habit of installing the new software after it is downloaded.

Generally speaking, the Windows 8.1 Pro RTM upgrade is very smooth and easy. I’ve run into a small issue with VMware workstation 8.0 that is causing me some concern. Apparently I need to upgrade to VMware workstation 10.0 to support Windows 8.1, which is slightly odd because version 8.0.6 worked perfectly well for the past year with Windows 8.0. I’ll investigate this more when I have the time.

Today another little glitch came to light when Internet Explorer version 11 (IE11) refused point blank to display the premium version of Outlook Web App (OWA) when connected to an Exchange 2013 RTM CU2 server. IE11 is, of course, the newest, brightest, and most wonderful browser known to man. Unfortunately, OWA appears to disagree with something that IE11 is doing and so reverts to its light or “reach” version.

I have nothing against OWA light. It is a perfectly usable interface that gets the job done when all else fails, including in some pretty weird circumstances such as when forced to use an obsolete Firefox browser on a hotel TV. However, the light interface is the ugly sister to OWA’s full glory as revealed in the premium interface and it’s sad that IE11 appears to be unable to co-operate. Other browsers such as Firefox and Chrome are quite happy to display OWA premium on Windows 8.1 RTM.

What’s even more interesting (or strange) is that the premium version of OWA works perfectly well when connected to Exchange Online (Office 365). The rational explanation here is that Microsoft is well aware of the problem and has fixed whatever issue is causing IE11 to break in the software running on its Office 365 servers. The conclusion is that the on-premises crowd will have to wait until Exchange 2013 RTM CU3 appears to be able to use the Windows 8.1/IE11/OWA premium combination.

Before any of the "we're being forced to the cloud" folks seize on this as yet another example of Microsoft making cloud software work better than its on-premises counterpart, let me point out that the cloud systems are always a few weeks ahead of the software available to on-premises customers. If this were not the case, then Microsoft's assertion that they test software by running it inside Office 365 before it is released to on-premises customers would be so much tosh. 

I’m not vexed that this should be so. After all, Microsoft did everyone a favor by releasing Windows 8.1 RTM a few weeks earlier than originally planned and it is reasonable to assume that problems will appear when new software appears. This is, after all, why we test every new software release before deploying it into production. These kind of glitches will be sorted by the time people get around to using Windows 8.1 in production environments. At least, that's the theory!

Follow Tony @12Knocksinna

Hide comments

Comments

  • Allowed HTML tags: <em> <strong> <blockquote> <br> <p>

Plain text

  • No HTML tags allowed.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Lines and paragraphs break automatically.
Publish