Update causes Outlook 2013 to fail to open archive mailboxes

Update causes Outlook 2013 to fail to open archive mailboxes

I don’t tend to pay much attention to my archive mailbox. It sits there in the list of resources opened by Outlook but I never really feel the need to go and check that the Managed Folder Assistant (MFA) is moving items to the archive in accordance with my retention policy. It just happens, and like most users, I just let it happen and forget all about the items that accumulate in those archive folders.

That is, until someone posts a note to say that Outlook 2013 fails to open the archive after an update is applied, which is what happened today when Jim Collins noted in the unofficial Exchange 2013 Facebook group (and, I think, in a TechNet forum) that he had very diligently applied all of the updates issued by Microsoft on Patch Tuesday and then found that Outlook stubbornly refused to open his archive mailbox. The not-very-informative error message is shown below. 

Hmmm… my interest in the archive reawakened, I checked and discovered that the same problem existed in my environment (Outlook 2013 installed from the msi package as part of Office 2013 Pro 64-bit running on Windows 8.1 Pro) after I applied all of the 34 available updates suggested to me by Windows Update. In my case, the version reported by Outlook 2013 is 15.0.4641.1001. The click-to-run version of Outlook 2013 exhibits the same problem. 

The original report noted that the issue occurred with an on-premises deployment running Exchange 2013 CU5 (SP1 is also suspected but I haven't confirmed this); I reproduced the problem with Office 365. All other resources, including some site and shared mailboxes, opened normally.  In both instances, Outlook Web App was happy to open the archive, suggesting that something weird was happening inside Outlook.

Through trial and error (otherwise known as careful testing), Jim identified that the problem child in the set of updates is KB2881011. After this update is removed and you reboot the PC, Outlook 2013 is happy once more and will cheerfully connect to its archive mailbox.

I have not tested against other environments. According to MVP Jason Sherry, the problem is not seen when running Outlook 2013 against Exchange 2010. Because of the variations observed here between on-premises and cloud, click-to-run and other varients, it's wise to test your own environment, just to be sure. A Microsoft contact tells me that the problem can be reproduced using RPC/HTTP connections but that MAPI over HTTP links seem to work correctly. Interesting though this is, it's not really a workaround because on-premises deployments can't simply switchover to MAPI over HTTP connections without a lot of planning and Office 365 tenants don't get to vote when they switch.

Microsoft has updated KB2881011 to say that they have removed the update. Only they haven't, as Windows Update on my PC discovered last night when it downloaded the change and applied it. A reboot this morning (August 14) (someone has to test these things) revealed that archive access had once again been removed. Oh well, I guess it is one thing to say that you have removed an update, quite another to make sure that it actually happens.

Oddly, KB2881011 reports that the update only addresses the fact that some holidays have incorrect dates and inaccurate translations and should only affect these language versions; Hebrew, German, French, Dutch, Russian, Spanish, Brazilian, Ukrainian, Hungarian, Italian, Turkish, and Slovak. All I can say is that the update did a fine job of messing up my English-language version of Outlook. The other thought that comes into my mind is why the update was applied to my PC at all... surely it should have only updated PCs running the relevant language versions of Office 2013? Perhaps the fact that I am currently on vacation in France and French is in the list of affected languages prompted Windows Update to apply the change. Who knows!

I have no idea why this irritating problem happened, but it is just that - irritating. And unless you took the time to carefully test every client update for all functions, it's a problem that you could have easily missed and allowed users to install, with all of the attendant woes that could then ensue. It seems like this is yet another snafu that has snuck through Microsoft's fabled automated test harness. It certainly seems like the testing plan should have covered archive access.

I haven't noticed any other problems with the updates distributed yesterday. Then again, one of them might be lurking in a deep, dark part of Outlook waiting to bite me. In the interim, do yourself a favor and test before letting users have the new code. You know it makes sense.

Follow Tony @12Knocksinna

Update: If you use the click-to-run version of Outlook 2013, the command to reverse the change and get to a version that can access archive mailboes is

Officec2rclient.exe /update user updatetoversion=15.0.4631.1002 

Update 2 (August 20): Microsoft has released KB2889859 to fix the problem. You can download the 89MB patch and install it to fix the problem, which also apparently affects Outlook's Business Contact Manager (BCM). Despite what KB2889859 says, you will need to reboot your PC after the update finishes.

TAGS: Office 365
Hide comments

Comments

  • Allowed HTML tags: <em> <strong> <blockquote> <br> <p>

Plain text

  • No HTML tags allowed.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Lines and paragraphs break automatically.
Publish